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マイクロソフト内部サポート情報

BUG #: 56500 (コンテンツ管理)

マイクロソフト内部サポート情報

BUG #: 183877 (WindowsSE)

現象

以下の事例で説明します。Ktpass ツール (Ktpass.exe) を使用して、Microsoft Windows Server 2003 Service Pack 1 (SP1) で Kerberos キータブ ・ ファイルを作成する-ベースのコンピューター。ライトウェイト ディレクトリ アクセス プロトコル (LDAP) を使用して、セキュリティ ソケット レイヤー (SSL) 接続経由で、Ktpass ツールはないアカウントのパスワードが正しく設定 Active Directory にします。Ktpass ツールを使用して作成された keytab ファイルを使用して、事前認証エラーが発生します。

原因

この問題は、Windows Server 2003 SP1 に含まれている Ktpass ツールを使用して問題が発生したために発生します。Ktpass ツールはパスワードをリセット、正しく SSL 経由で LDAP を使用しています。

Ktpass ツール salts いないパスワード正しくコンピューター アカウント用の keytabs を生成するときです。Ktpass ツールは、キー配布センター (KDC) を使用してパスワードを salt 処理するsamAccountName属性ではなく、サービス プリンシパル名属性のホスト名の部分を使用します。不適切な salt を使用して作成されたが正しく生成された keytab ファイルには、認証エラーが発生します。

解決策

Service Pack 情報

この問題を解決するには、Windows Server 2003 の最新の service pack を入手します。詳細については、次の文書番号をクリックして、マイクロソフト サポート技術情報の資料をご参照ください。

Windows Server 2003 の最新の service pack の入手方法

修正プログラムの情報

サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この問題が発生しているシステムにのみ適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。

修正プログラムをダウンロードできる場合は、このサポート技術情報の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。

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