現象
2007 年 12 月 1 日より前に Microsoft System Center Configuration Manager (SCCM) 2007 サイト サーバーをインストールすると、SCCM サイト サーバーは提供情報の状態の概要データを処理しません。 このデータは、オファーの状態の概要データとも呼ばれます。 この場合、状態ファイル (.svf) は、SCCM サイト サーバーの \Program Files\Microsoft Configuration Manager\inboxes フォルダーにある offersum.box フォルダーに蓄積されます。
注: Microsoft System Management Server (携帯ショートメール) 2003 から SCCM 2007 にアップグレードする場合、offersum.box フォルダーは \携帯ショートメール\Inboxes フォルダーにあります。
さらに、Offersum.log ファイルには、次のようなエラーが含まれています。
集計 00011280001F2000。 新しい開始時刻: 12/01/2007 00:00:00、 New Expire Time: 12/08/2007 00:00:00 ---->: 例外が発生しました: 不特定エラー警告>: サマライザープロパティを初期化できませんでした。
これらのエラー メッセージは、Offersum.log ファイルで毎分発生します。
2007 年 12 月 1 日以降に SCCM サイト サーバーをインストールすると、SCCM サイト サーバーは状態メッセージを処理できません。 この動作は、offersum.box フォルダーが正常に作成されていないために発生します。 これにより、ステータス メッセージ システムがブロックされます。 さらに、Statmgr.log ファイルには、次のようなエントリが含まれています。
SMS_INBOX_MANAGERがサマライザー SMS_OFFER_STATUS_SUMMARIZERの "オファー ステータス サマライザー" 受信トレイを作成するのを待機しています。
注: この問題の影響を受けるサイト システム関数は他にありません。 この問題の影響を受けるのは、オファーの状態の概要化コンポーネントだけです。
原因
この問題は、集計間隔を決定するために不適切な日付計算が使用されているために発生します。 日付の計算は、携帯ショートメール Executive Service のオファーステータス サマライザー スレッドが開始された直後に実行されます。
解決方法
Service Pack 情報
この問題を解決するには、この Microsoft Web サイトから入手できる Microsoft System Center Configuration Manager 2007 用の最新のサービス パックを入手 http://www.microsoft.com/download/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
このサービス パックで解決された問題の一覧については、Microsoft Knowledgebase の次の記事番号をクリックしてください。
971348 System Center Configuration Manager 2007 Service Pack 2 に含まれる修正プログラムと更新プログラムの一覧
修正プログラム情報
この更新プログラムのスタンドアロン パッケージを取得するには、 Microsoft Update Catalog Web サイトにアクセスします。
Microsoft サポート ファイルをダウンロードする方法の詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を参照してください。
119591 オンライン サービスから Microsoft サポート ファイルを取得する方法 Microsoft はこのファイルをスキャンしてウイルスを検出しました。 配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。 配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。
修正プログラムの情報
サポートされている修正プログラムは、Microsoft から入手できるようになりました。 ただし、この記事で説明されている問題のみを修正することを目的としています。 この特定の問題が発生しているシステムにのみ適用します。 この修正プログラムは、追加のテストを受け取る場合があります。 したがって、この問題の影響を大きく受けない場合は、この修正プログラムを含む次のSystem Center Configuration Manager 2007 サービス パックを待機することをお勧めします。
この問題を直ちに解決するには、Microsoft カスタマー サポート サービスに連絡して修正プログラムを入手してください。 Microsoft カスタマー サポート サービスの電話番号とサポート コストに関する情報の完全な一覧については、次の Microsoft Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support 注: 特別なケースでは、特定の更新プログラムによって問題が解決されるとMicrosoft サポート Professionalが判断した場合、サポート呼び出しに通常発生する料金が取り消される可能性があります。 ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。
必要条件
この修正プログラムを適用する前に、System Center Configuration Manager 2007 をインストールする必要があります。
再起動の必要性
この修正プログラムを適用した後、コンピューターを再起動する必要はありません。
修正プログラムの置き換えに関する情報
この修正プログラムを適用しても、以前にリリースされた修正プログラムが置き換えられることはありません。
ファイル情報
この修正プログラムの英語版には、次の表に示すファイル属性 (またはそれ以降のファイル属性) があります。 これらのファイルの日付と時刻は世界協定時 (UTC) で記載されています。 ファイル情報を表示すると、ローカル時刻に変換されます。 UTC とローカル時刻の違いを見つけるには、コントロール パネルの [日付と時刻] 項目の [タイム ゾーン] タブを使用します。
日付 |
時刻 |
バージョン |
サイズ |
File name |
---|---|---|---|---|
2007 年 12 月 1 日 |
06:50 |
4.0.5931.111 |
88,504 |
Offersum.dll |
この修正プログラムを適用すると、offersum.box フォルダーにバックログされた状態メッセージが処理されます。 Offersum.log ファイルを監視する場合、次のようなエントリが複数の異なるメッセージに表示される場合があります。
クライアント ClientName からのメッセージ MessageID を含むオファー 'AdvertisementName' の時間が無効です。
MessageID の値は異なります。 さらに、特定のクライアントに対してログ エントリが繰り返される回数は異なります。
ステータス サマライザ コンポーネントがステータス メッセージを読み取ると、ステータス サマライザー コンポーネントは、メッセージ内のタイムスタンプを特定の概要間隔の開始時刻と比較します。 処理されるメッセージが指定された範囲外になると、ログ エントリが Offersum.log ファイルに生成されます。 たとえば、12 月 3 日に生成され、12 月 5 日に処理される状態メッセージは、 12:00:00AM 以降 の概要には表示されません。 そのため、12 月 3 日のログ エントリは無視できます。
14 の異なる状態の概要間隔が定義されています。 状態の概要の間隔は、携帯ショートメール管理者コンソールでステータス メッセージの概要を表示するときに使用できる表示間隔情報に似ています。 たとえば、状態の概要の間隔は 、午前 12:00:00以降または日曜日以降のようになります。