メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

次のような状況を考えます。

  • Windows Server 2008 ベースのシステムでは、HYPER-V 役割が有効です。

  • コンピューター上の既定の入力言語がドイツ語に設定されています。

  • Linux 仮想マシンは、このコンピューターにインストールされています。

このシナリオでは、AltGr キーは Linux の仮想マシンでは動作しません。その結果、次の文字を入力することはできません。

  • ²

  • ³

  • {

  • [

  • ]

  • }

  • \

  • @

  • µ

  • ~

注: AltGr キーは、右側のドイツ語のキーボードで ALT キーです。

原因

Windows システムでは、左 ctrl キーをスキャン コードとは、右の ALT のスキャン コードを使用して、ドイツ語のキーボードに AltGr キーを示します。ただし、Linux 仮想マシンでは、右の ALT のスキャン コードのみを表示するのには期待しています。Windows では、左の ctrl キーを押しますスキャン コードとコードのスキャンを送信するとき、Linux 仮想マシンを解釈しません。 これら AltGr キーとコードをスキャンします。

解決策

サービス パックの情報

この問題を解決するには、Windows Server 2008 の最新の service pack を入手します。詳細については、次の文書番号をクリックして、マイクロソフト サポート技術情報の資料をご参照ください。

968849 Windows Server 2008 の最新の service pack の入手方法

修正プログラムの情報

サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、この資料に記載されている問題のみを修正するものです。この修正プログラムは、この資料に記載された問題があったシステムのみに対して適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。

修正プログラムをダウンロードできる場合は、このサポート技術情報の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。

注: さらなる問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストの作成が必要な場合があります。この修正プログラムの対象外の追加の質問および問題については、通常のサポート料金が適用されます。マイクロソフト カスタマー サービス サポートの電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。

http://support.microsoft.com/contactus/?ws=support注: [修正プログラムのダウンロード] フォームには、修正プログラムが提供されている言語が表示されます。お使いの言語が表示されない場合は、その言語の修正プログラムが利用できないためです。

同じパッケージには、重要な Windows Vista と Windows Server 2008 の修正プログラムが含まれます。ただし、"修正プログラムの要求] ページでこれらの製品の 1 つだけが表示されます。Windows Vista と Windows Server 2008 の両方に適用される修正プログラム パッケージを要求するには、ページに記載されている製品を選択します。

必要条件

この修正プログラムを適用するのにはインストールされている HYPER-V の役割を持つ Windows Server 2008 が必要です。

再起動の必要性

この修正プログラムを適用した後コンピューターを再起動する必要があります。

修正プログラムの置き換えに関する情報

この修正プログラムによって他の修正プログラムが置き換わることはありません。

ファイル情報

この修正プログラムの英語バージョンがファイル属性を持つ (またはそれ以降) 次の表に記載されています。世界協定時刻 (UTC) では、日付と時刻これらのファイルが一覧表示されます。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との差を検索するには、コントロール パネルの [日付と時刻]の[タイム ゾーン] タブを使用します。

Windows Server 2008 ファイル情報のメモ


マニフェスト ファイル (.manifest) および MUM ファイル (.mum) の各環境のインストールは、します。
別に一覧表示
.MUM と MANIFEST ファイルおよび関連付けられているセキュリティ カタログ (.cat) ファイルは、更新されたコンポーネントの状態を維持するために重要です。セキュリティ カタログ ファイル (属性一覧に表示されない) は、マイクロソフトのデジタル署名で署名されています。

X 64 の Windows Server 2008

ファイル名

ファイル バージョン

ファイル サイズ

日付

時刻

プラットフォーム

Vmwp.exe

6.0.6001.22366

3,524,608

02-Feb-2009

06:35

x64


警告: [レジストリ エディタ] または別の方法を使用してレジストリを誤って修正すると、深刻な問題が発生することがあります。これらの問題は、オペレーティング システムを再インストールする必要があります。マイクロソフトは、これらの問題を解決できることを保証することはできません。自己の責任においてレジストリを変更してください。
問題を解決するには、次の手順を実行します。

  1. 963709 修正プログラムをインストールします。

  2. 次のレジストリ キーの下には、"KeyboardWorkaroundEnabled"という名前のREG_DWORDの種類を設定し、値を1に設定し、レジストリ エントリを追加します。

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Virtualization\Worker

注: 修正プログラムをインストールし、新しいレジストリ エントリを作成し後、Windows Server 2008 ベースのシステムは、右の ALT のスキャン コードが続くと、左の ctrl キーをスキャン コードを削除します。ただし、意図的な左 ctrl キーを右の ALT キーの組み合わせを影響この可能性があります。この問題を回避するには、右 ALT キーを押しながら前に数秒の左の CTRL キーを押しします。

状況

マイクロソフトでは、この資料の冒頭に記載されているマイクロソフト製品に問題があることを認識しています。

詳細

詳細については、次の文書番号をクリックして、マイクロソフト サポート技術情報の資料をご参照ください。

899474 Service Pack 1 で、Virtual PC 2004 で、ALTGR と ALT キーまたは CTRL キーの組み合わせは機能しません

Windows Server 2008 の他のファイル情報

X 64 の他のファイルは、Windows Server 2008

ファイル名

ファイル バージョン

ファイル サイズ

日付

時刻

プラットフォーム

Amd64_microsoft-hyper-v-vstack-vmwp_31bf3856ad364e35_6.0.6001.22366_none_91adec95316ef36f.manifest

該当なし

192,587

02-Feb-2009

07:07

該当なし

Package_for_kb963709_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mum

該当なし

1,528

02-Feb-2009

14:02

該当なし

Package_for_kb963709_sc~31bf3856ad364e35~amd64~~6.0.1.0.mum

該当なし

1,430

02-Feb-2009

14:02

該当なし

Package_for_kb963709_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum

該当なし

1,532

02-Feb-2009

14:02

該当なし

Package_for_kb963709_server~31bf3856ad364e35~amd64~~6.0.1.0.mum

該当なし

1,438

02-Feb-2009

14:02

該当なし


詳細については、次の文書番号をクリックしてマイクロソフト サポート技術資料を参照してください。

824684マイクロソフトのソフトウェア更新プログラムを記述するために使用される一般的な用語説明

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×