Access 데이터베이스를 사용하면 인벤토리, 연락처, 비즈니스 프로세스 등 거의 모든 종류의 정보를 저장하고 추적할 수 있습니다. Access 데스크톱 데이터베이스를 만들고 데이터를 추가한 다음 새 데이터베이스를 사용자 지정하고 사용하는 다음 단계에 대해 알아보겠습니다.
이 문서의 내용
서식 파일 선택
Access 서식 파일에는 바로 사용할 수 있는 기본 제공 테이블, 쿼리, 폼 및 보고서가 있습니다. 서식 파일은 Access를 시작할 때 가장 먼저 표시되는 항목 중 하나이며, 온라인에서 더 많은 서식 파일을 검색할 수 있습니다.
- Access에서새로 만들기파일을> 선택합니다.
- 데스크톱 데이터베이스 템플릿을 선택한 다음 파일 이름에 데이터베이스 이름을 입력합니다. 적합한 서식 파일이 없으면 온라인 서식 파일 검색 상자를 사용하세요.
- 파일 이름 상자 아래에 표시되는 기본 위치를 사용하거나 폴더 아이콘을 선택하여 폴더 중 하나를 선택할 수 있습니다.
- 만들기를 선택합니다.
템플릿에 따라 시작하려면 다음 중 하나를 수행해야 할 수 있습니다.
Access에 빈 사용자 목록이 있는 로그인 대화 상자가 표시되는 경우:
- 새 사용자를 선택합니다.
- 사용자 세부 정보 양식을 작성합니다.
- 저장 후 닫기를 선택합니다.
- 방금 입력한 사용자 이름을 선택한 다음 로그인을 선택합니다.
Access의 메시지 표시줄에 보안 경고 메시지가 표시되고 서식 파일의 원본을 신뢰하는 경우 콘텐츠 사용을 선택합니다. 데이터베이스에 로그인이 필요한 경우 다시 로그인합니다.
자세한 내용은 서식 파일에서 Access 데스크톱 데이터베이스 만들기를 참조하세요.
처음부터 데이터베이스 새로 만들기
필요에 맞는 서식 파일이 없으면 빈 데스크톱 데이터베이스로 시작할 수 있습니다.
- Access에서 새>빈 데스크톱 데이터베이스를 선택합니다.
- 파일 이름 상자에 데이터베이스 이름을 입력합니다.
- 파일 이름 상자 아래에 표시되는 기본 위치를 사용하거나 폴더 아이콘을 선택하여 폴더 중 하나를 선택할 수 있습니다.
- 만들기를 선택합니다.
테이블 추가
데이터베이스에서 정보는 여러 관련 테이블에 저장됩니다. 테이블을 만들려면 다음을 수행합니다.
데이터베이스를 처음 열면 데이터를 추가할 수 있는 데이터시트 보기에 빈 테이블이 표시됩니다. 다른 테이블을 추가하려면테이블만들기>를 선택합니다. 빈 필드(셀)에 데이터 입력을 시작하거나 Excel 통합 문서와 같은 다른 원본의 데이터를 붙여넣을 수 있습니다.
열(필드) 이름을 바꾸려면 열 머리글을 두 번 클릭한 다음 새 이름을 입력합니다.
팁
의미 있는 이름을 지정하면 내용을 않고도 각 필드에 포함된 내용을 알 수 있습니다.
파일> 저장을 선택합니다.
- 필드를 더 추가하려면 추가하려면 클릭 열에 입력합니다.
- 열을 이동하려면 열 머리글을 클릭하여 열을 선택한 다음 원하는 위치로 끕니다. 인접한 열을 선택하여 함께 새 위치로 끌 수도 있습니다.
자세한 내용은 테이블 소개를 참조합니다.
데이터 복사 및 붙여넣기
Excel 또는 Word와 같은 다른 프로그램에서 데이터를 복사하여 Access 표에 붙여넣을 수 있습니다. 이 방법은 데이터를 열로 구분할 때 가장 효과적입니다. 데이터가 Word와 같은 워드 프로세싱 프로그램에 있는 경우 복사하기 전에 태그를 사용하여 열을 구분하거나 데이터를 표 형식으로 변환합니다.
전체 이름을 이름과 성으로 구분하는 등의 편집 작업이 필요한 경우 원본 프로그램에서 먼저 편집합니다.
소스를 열고 Ctrl+C를 눌러 데이터를 복사합니다.
데이터시트 보기에서 데이터를 추가할 Access 테이블을 연 다음 Ctrl+V를 눌러 붙여넣습니다.
각 열 머리글을 두 번 클릭한 다음 의미 있는 이름을 입력합니다.
파일>저장을 선택한 다음 새 테이블에 이름을 지정합니다.
참고
Access에서는 각 열의 첫 행에 붙여 넣는 정보를 기반으로 각 필드의 데이터 형식을 설정하므로 다음 행의 정보가 첫 번째 행과 일치해야 합니다.
데이터 가져오기 또는 연결
다른 원본에서 데이터를 가져오거나 저장된 위치에서 정보를 이동하지 않고 Access에서 데이터에 연결할 수 있습니다. 여러 사용자가 데이터를 업데이트하고 최신 버전이 표시되는지 확인하거나 저장소 공간을 절약하려는 경우 연결하는 것이 좋습니다. 대부분의 형식의 경우 데이터에 연결할지 또는 데이터를 가져올지 여부를 선택할 수 있습니다. 자세한 내용은 다른 Access 데이터베이스의 데이터 가져오기 또는 연결을 참조하세요.
프로세스는 데이터 원본에 따라 약간 다르지만 다음 지침은 시작하는 데 도움이 됩니다.
외부 데이터 탭의 & 링크 가져오기 그룹에서 새 데이터 원본을 선택한 다음 나열된 하위 메뉴 옵션에서 가져오거나 연결할 데이터 형식을 선택합니다.
참고
여전히 올바른 형식을 찾을 수 없는 경우 먼저 데이터를 Access에서 지원하는 파일 형식(예: 분리된 텍스트 파일)으로 내보내야 할 수 있습니다.
외부 데이터 가져오기 대화 상자의 지침을 따릅니다.
연결할 때 일부 형식은 읽기 전용으로 사용할 수 있습니다. 데이터를 가져오거나 연결할 수 있는 외부 원본은 다음과 같습니다.
| 원본 | 가져오기 | 링크 |
|---|---|---|
| Excel | 예 | 예(읽기 전용) |
| Access | 예 | 예 |
| ODBC 데이터베이스(예: SQL Server) | 예 | 예 |
| 텍스트 또는 CSV(쉼표로 구분된 값) 파일 | 예 | 예(새 레코드만 추가) |
| SharePoint 목록 | 예 | 예 |
| XML | 예 | |
| 데이터 서비스 | 예(읽기 전용) | |
| HTML 문서 | 예 | 예 |
| Outlook 폴더 | 예 | 예 |
자세한 내용은 다른 Access 데이터베이스의 데이터 가져오기 또는 연결을 참조하세요.
테이블 분석 마법사를 사용하여 데이터 구성
테이블 분석기 마법사를 사용하여 중복 데이터를 빠르게 식별할 수 있습니다. 마법사는 데이터를 별도의 테이블로 구성하는 간단한 방법을 제공합니다. 원본 테이블은 백업으로 보존합니다.
- 분석할 테이블이 포함된 Access 데이터베이스를 엽니다.
- 데이터베이스 도구> 테이블분석을 선택합니다. 마법사의 처음 두 페이지에는 예제가 포함된 간단한 자습서가 포함되어 있습니다. 소개 페이지 표시?라는 검사란이 있는 경우 해당 확인란을 선택한 다음 뒤로를 두 번 선택하여 소개를 봅니다. 소개 페이지를 다시 표시하지 않으려면 소개 페이지 표시?의 선택을 취소합니다.
자세한 내용은 테이블 분석기를 사용하여 데이터 정규화를 참조하세요.
다음 단계
나머지 디자인 프로세스는 원하는 작업에 따라 다르지만 쿼리, 폼, 보고서 및 매크로 만들기를 고려해 볼 수 있습니다. 다음 문서가 도움이 될 수 있습니다.