ODC(Office 데이터 연결) 파일을 사용하여 Excel 사용자 간에 외부 데이터 연결을 공유할 수 있습니다. ODC 파일은 이식 가능하고 쉽게 업데이트할 수 있도록 설계되었습니다. 다음 방법을 사용하여 외부 데이터 원본을 파워 쿼리로 셰이프된 데이터와 공유합니다.
참고
ODC 파일이 계속 지원되지만 많은 조직에서는 SharePoint, OneDrive, Power BI 데이터 흐름 또는 기타 중앙 집중식 데이터 원본을 사용하여 파워 쿼리 솔루션을 공유합니다.
이 예제에서는 데이터 통합 문서에서 가져온 데이터와 통합 문서를 공유합니다. 그러나 이 프로세스는 Excel에서 가져오고 연결할 수 있는 거의 모든 외부 데이터 원본에 적용됩니다. 유일한 예외는 테이블/범위의데이터> 사용하여, Excel 테이블 또는 이름을 가져온 동일한 통합 문서의 명명된 범위에 대한 ODC 파일에 연결 정보를 저장할 수 없다는 것입니다.
중요
인증 또는 개인 정보 보호 문제가 발생하는 경우 데이터 원본 설정 및 권한 관리(파워 쿼리) 및 개인 정보 수준 설정(파워 쿼리)을 참조하세요.
1단계: 데이터를 가져오고 연결 및 쿼리 정보를 ODC 파일에 저장
데이터를 쉽게 공유할 수 있도록 한 사람이 다음 단계를 완료합니다.
- 데이터> 선택Excel 통합 문서의파일>에서데이터를> 가져옵니다.
- 데이터 가져오기 대화 상자에서 데이터가 포함된 통합 문서를 찾아 선택한 다음 가져오기를 선택합니다.
- 탐색기 대화 상자에서 테이블을 선택한 다음 데이터 변환을 선택합니다.
- Power Query 편집기에서 원하는 방식으로 데이터를 셰이프한 다음 홈>닫기 & 로드를 선택합니다.
- 쿼리 데이터가 포함된 Excel 워크시트에서 테이블의 셀을 선택하고 데이터를 선택한 다음, 모두 새로 고침 옆의 화살표를 선택한 후 연결 속성을 선택한 후 정의 탭을 선택한 다음 대화 상자 하단에서 연결 파일 내보내기를 선택합니다.
- 파일 저장 대화 상자에서 파일 이름을 입력하고 저장을 선택한 다음 확인을 선택합니다.
- 네트워크 폴더, SharePoint 라이브러리 또는 OneDrive 폴더와 같이 다른 사용자가 액세스할 수 있는 신뢰할 수 있는 위치에 파일을 저장해야 합니다. 신뢰할 수 있는 데이터 원본에 대한 자세한 내용은 신뢰할 수 있는 문서, Microsoft Office 보안 센터에서 내 개인 정보 옵션 보기 및 신뢰할 수 있는 위치 추가, 제거 또는 변경을 참조하세요.
- 통합 문서를 저장합니다.
결과
ODC 파일에는 외부 데이터 원본에 대한 모든 연결 정보와 파워 쿼리 작업의 단계 및 공식이 포함되어 있습니다. 원하는 경우 메모장에서 ODC 파일을 열어 사용된 XML 형식을 검사합니다.
2단계: 저장된 ODC 파일 열기 및 사용
공유 데이터에 액세스하려면 다른 사용자가 다음 단계를 완료합니다.
ODC 파일을 찾아 엽니다.
Excel에서 새 Excel 통합 문서로 ODC 파일을 엽니다.
데이터 원본 신뢰에 대한 메시지가 나타나면 사용을 선택합니다.
데이터 가져오기 대화 상자에서 데이터를 가져올 방법을 결정한 다음 확인을 선택합니다. 이 대화 상자 사용에 대한 자세한 내용을 보려면 물음표(?)를 선택하세요.
모든 것이 제대로 작동하는지 확인하려면 통합 문서 데이터 원본을 업데이트한 다음 Ctrl + Alt + F5를 눌러 이 통합 문서의 모든 데이터를 새로 고칩니다.
통합 문서를 저장합니다.
결과
이제 다른 사용자가 외부 데이터 원본을 파워 쿼리로 셰이핑한 데이터와 공유할 수 있습니다.