Microsoft로 로그인
로그인하거나 계정을 만듭니다.
안녕하세요.
다른 계정을 선택합니다.
계정이 여러 개 있음
로그인할 계정을 선택합니다.

증상

Windows에서 작업을 할 때 다음 오류 메시지가 나타날 수 있습니다.

Windows 탐색기의 작동이 중지되었습니다.  Windows를 다시 시작합니다.

또한 오류 메시지가 나타나기 직전이나 나타난 직후에 화면이 깜박일 수 있습니다.

원인

이 문제는 다음 문제 중 하나로 인해 발생할 수 있습니다.

  • 비디오 드라이버가 오래되었거나 손상되었습니다.

  • PC의 시스템 파일이 손상되었거나 다른 파일과 일치하지 않습니다.

  • PC가 바이러스나 맬웨어에 감염되었습니다.

  • PC에서 실행되고 있는 일부 응용 프로그램이나 서비스로 인해 Windows 탐색기의 작동이 중지되었습니다.


해결 방법

이 문제를 해결하려면 Windows 탐색기 작동 중지의 원인을 확인해야 합니다. 문제를 확인하려면 아래의 문제 해결 단계를 수행해 보세요.

현재 비디오 드라이버 업데이트

비디오 드라이버가 오래되었거나 손상된 경우 Windows 탐색기의 작동이 중지될 수 있습니다. 최신 비디오 드라이버를 다운로드하여 설치하면 이러한 문제가 대부분 해결됩니다. 최신 비디오 드라이버는 Windows 업데이트를 통해 다운로드할 수도 있고, 시스템 제조업체 웹 사이트를 방문하거나 제조업체에 직접 연락을 하여 받을 수도 있습니다.
드라이버 업데이트에 대한 자세한 내용은 Microsoft 웹 사이트에서 다음 콘텐츠를 참조하세요.

제대로 작동되지 않는 하드웨어용 드라이버 업데이트

드라이버 업데이트: 권장 링크

SFC(시스템 파일 검사기)를 사용하여 파일 검사

시스템 파일 검사기를 사용하여 PC에서 누락되었거나 손상된 파일을 검사합니다. 이 작업을 수행하려면 다음 단계를 따르세요.

  1. 시작을 클릭한 후 검색 상자에 cmd를 입력합니다.

  2. 결과 영역에서 cmd.exe를 마우스 오른쪽 단추로 클릭한 다음 관리자 권한으로 실행을 클릭합니다. 관리자 계정의 암호를 입력하라는 메시지가 표시될 수 있습니다.

  3. 관리자인 경우 계속을 클릭하거나 관리자 암호를 입력한 다음 계속을 클릭합니다.

  4. 명령 프롬프트에 Sfc /scannow를 입력한 다음 Enter 키를 누릅니다.


이 검사는 다소 시간이 걸릴 수 있으므로 검사가 완료될 때까지 기다립니다. Windows는 발견된 손상되었거나 누락된 파일을 복구합니다. 문제를 복구하기 위해 설치 CD의 정보가 필요한 경우에는 Windows CD를 넣으라는 메시지가 나타날 수도 있습니다.

SFC(시스템 파일 검사기)에 대한 자세한 내용은 Microsoft 웹 사이트에서 다음 KB 문서를 참조하세요.

Windows Vista 또는 Windows 7에서 시스템 파일 검사기 도구를 사용하여 누락되었거나 손상된 시스템 파일 문제를 해결하는 방법

PC가 바이러스 또는 맬웨어에 감염되었는지 검사

바이러스나 맬웨어에 감염되면 응용 프로그램 성능과 관련한 문제가 발생할 수 있습니다. 평소 사용하는 바이러스 백신 소프트웨어에서 PC에 숨겨져 있을 수 있는 감염 파일을 검사합니다. 바이러스 백신을 사용하고 있지 않다면 아래 링크를 클릭하여 Microsoft Security Essentials를 무료로 다운로드 및 설치할 수 있습니다.

Microsoft Security Essentials

안전 모드로 PC를 시작하여 시작 문제 확인

PC를 안전 모드로 시작하여 오류를 재현할 수 있는지 확인합니다. 안전 모드로 PC를 시작한 후 일반적인 방식으로 작업을 하며 오류 발생 시 수행했던 것과 같은 작업을 수행합니다. 안전 모드에서도 오류가 발생하는 경우 다음 섹션으로 이동하여 클린 부팅을 통한 문제 해결 단계를 진행합니다. 

안전 모드로 PC를 시작하는 방법을 알아보려면 Microsoft 웹 사이트에서 다음 문서를 참조하세요.

안전 모드에서 컴퓨터 시작

클린 부팅 환경에서 PC를 시작하여 문제 해결

안전 모드에서는 동일한 작동 중단 현상이 발생하지 않는 경우 시작 항목으로 인해 문제가 발생하는 것일 가능성이 높습니다. 다음 문서에 나와 있는 단계에 따라 클린 부팅을 수행하여 문제의 원인이 되는 항목을 확인하세요.

Windows Vista 또는 Windows 7에서 클린 부팅을 수행하여 문제를 해결하는 방법

추가 문제 해결 단계

아래의 추가 문제 해결 단계는 흔히 사용되지는 않지만 Windows 탐색기의 작동 중단 원인을 해결하는 데 사용할 수 있습니다. 

시스템의 RAM 메모리 테스트

RAM(Random Access Memory)에 결함이 있으면 Windows 내에서 가끔씩 문제가 발생할 수도 있습니다. 이러한 경우에는 시작을 클릭하고 메모리 진단을 입력한 다음 목록에서 결과를 선택하여 Windows 메모리 진단 도구를 사용합니다. Windows 메모리 진단 도구 창이 나타나면 지금 다시 시작하여 문제 확인(권장)을 선택합니다.

손상되었을 수 있는 그림 파일 테스트

손상된 이미지로 인해 Windows 탐색기에서 문제가 발생하는 경우도 있습니다. 그림으로 작업을 하거나 그림이 포함된 폴더를 찾아보는 중에 Windows 탐색기의 작동이 중지되는 경우 그림 파일이 하나 이상 손상된 것일 수 있습니다. 이 문제를 테스트하려면 아래 단계를 따르세요.

  1. 시작을 클릭한 다음 컴퓨터를 클릭합니다.

  2. 구성을 클릭하고 드롭다운에서 폴더 및 검색 옵션을 선택합니다.

  3. 폴더 옵션 창에서 보기 탭을 클릭합니다.

  4. 아이콘은 항상 표시하고 미리 보기는 표시하지 않음 옵션을 선택합니다.

  5. 미리 보기에 파일 아이콘 표시 옵션의 선택을 취소합니다.

  6. 확인을 클릭하여 폴더 옵션 창을 닫습니다.

이제 그림이나 비디오가 포함된 폴더로 이동하여 문제를 재현할 수 있는지 확인합니다. Windows 탐색기의 작동이 중지된다면 손상되었거나 손상된 미리 보기 데이터가 들어 있는 그림 파일이 현재 표시 중인 폴더에 하나 이상 포함되어 있을 수 있습니다.

참고: 미리 보기에 파일 아이콘 표시 및 아이콘은 항상 표시하고 미리 보기는 표시하지 않음 옵션을 조정하고 나면 파일에 미리 보기가 더 이상 표시되지 않으므로 그림 및 기타 파일이 해당 파일 형식의 기본 아이콘으로 표시됩니다.  이러한 옵션을 설정한 상태로 오류를 재현할 수 있는 경우에는 그림이나 비디오에 문제가 있는 것이 아니므로 폴더 옵션을 원래 설정으로 되돌려야 합니다.

오류 세부 정보에서 Windows 탐색기 작동 중단의 원인이 된 응용 프로그램을 확인합니다. 이 작업을 수행하려면 다음 단계를 따르세요.

  1. 시작을 클릭하고 검색 영역에 알림 센터를 입력한 다음 반환되는 결과에서 알림 센터를 클릭합니다.

  2. 알림 센터 창에서 유지 관리, 안정성 기록 보기를 차례로 클릭한 다음 안정성 모니터 창 아래쪽에서 문제 보고서 모두 표시를 클릭합니다.

  3. 아래쪽의 Windows 탐색기 항목 목록으로 스크롤합니다.

  4. 중지된 작업을 두 번 클릭하여 기술 세부 정보를 확인하고 적어 둡니다.

시스템 복원 수행

위의 해결 방법을 시도해도 문제가 해결되지 않는다면 시스템 복원을 수행하여 문제 발생이 시작되기 전의 시간으로 PC를 복원할 수 있습니다. 문제가 1개월 이상 발생하고 있다면 다음 섹션의 단계에 따라 현재 위치 업그레이드를 수행하여 문제를 복구하는 것이 좋을 수도 있습니다. 시스템 복원을 수행하려면 아래 문서의 단계를 따르세요.

시스템 복원

현재 위치 업그레이드 수행

문제가 1개월 이상 발생하고 있다면 현재 위치 업그레이드를 수행하여 Windows를 원래 설치 상태로 복원하는 것이 좋을 수도 있습니다. 현재 위치 업그레이드를 수행해도 컴퓨터에 현재 설치되어 있는 파일 및 응용 프로그램은 손상되지 않습니다. 현재 위치 업그레이드를 수행하려면 아래 문서의 단계를 따르세요.

Windows Vista, Windows 7, Windows Server 2008 및 Windows Server 2008 R2에서 현재 위치 업그레이드를 수행하는 방법

추가 정보

다른 문의 사항이 있거나 무료로 지원을 받으려면 Microsoft 커뮤니티를 확인해 보세요. 여기서 해결 방법을 검색하거나 다른 사용자에게 특정 내용을 질문할 수 있습니다. 다음 링크를 클릭하면 Microsoft 커뮤니티 포럼을 방문할 수 있습니다.

Microsoft 커뮤니티 이 문제에 대해 게시된 대답을 확인하려면 다음 링크를 클릭하세요.

오류: Windows 탐색기의 작동이 중지되었습니다.

도움이 더 필요하세요?

더 많은 옵션을 원하세요?

구독 혜택을 살펴보고, 교육 과정을 찾아보고, 디바이스를 보호하는 방법 등을 알아봅니다.

커뮤니티를 통해 질문하고 답변하고, 피드백을 제공하고, 풍부한 지식을 갖춘 전문가의 의견을 들을 수 있습니다.

이 정보가 유용한가요?

언어 품질에 얼마나 만족하시나요?
사용 경험에 어떠한 영향을 주었나요?
제출을 누르면 피드백이 Microsoft 제품과 서비스를 개선하는 데 사용됩니다. IT 관리자는 이 데이터를 수집할 수 있습니다. 개인정보처리방침

의견 주셔서 감사합니다!

×