KB4463125 - FIX: SQL Server 2016 및 2017에서 데이터베이스 암호화 키가 3,456비트보다 길면 오류가 발생함

적용 대상
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer on Windows SQL Server 2017 Enterprise on Windows SQL Server 2017 Enterprise Core on Windows SQL Server 2017 Standard on Windows

증상

Microsoft SQL Server 2016 또는 2017의 instance에서 3,456비트보다 긴 DEK(데이터베이스 암호화 키)를 생성합니다. 이 DEK를 사용하여 TDE(투명한 데이터베이스 암호화)를 사용하도록 설정하면 다음과 유사한 오류 항목이 SQL Server 오류 로그에 기록됩니다.

참고

날짜/시간 spid 데이터베이스 'database_name'에 대해 데이터베이스 옵션 ENCRYPTION을 ON으로 설정합니다. 날짜/시간 spid 데이터베이스 '데이터베이스 이름'에 대한 데이터베이스 암호화 검사를 시작합니다. 날짜/시간 spid 데이터베이스에 대한 데이터베이스 암호화 검색이 중단되었습니다. ALTER DB를 다시 실행하여 검사를 다시 시작합니다.

원인

이 문제는 길이가 3,456비트보다 큰 DEK가 지원되지 않음을 나타내는 오류 메시지를 SQL Server가 throw하지 않기 때문에 발생합니다.

해결 방법

이 문제는 다음 SQL Server 업데이트에서 해결되었습니다.

SQL Server 2017용 누적 업데이트 13

SQL Server 2016 서비스 팩 2용 누적 업데이트 5

SQL Server 2016 서비스 팩 1용 누적 업데이트 11

노트 이 수정을 적용한 다음 3,456비트보다 긴 DEK를 만들려고 하면 실패하고 다음 오류 메시지가 표시됩니다.

참고

메시지 33178, 수준 16, 상태 2, 줄 LineNumber
암호화 키 길이가 현재 지원되는 최대 길이인 3456을 초과합니다.

SQL Server 빌드 정보

SQL Server의 각 새 빌드에는 이전 빌드의 모든 핫픽스 및 보안 수정 사항이 포함되어 있습니다. 사용 중인 SQL Server 버전에 맞는 최신 빌드를 설치하는 것이 좋습니다.

SQL Server 2017용 최신 누적 업데이트

SQL Server 2016용 최신 빌드

상태

Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.

참조 자료

Microsoft에서 소프트웨어 업데이트를 설명하는 데 사용하는 용어 에 대해 알아보세요.