증상
스냅샷 백업을 위해 서버를 일시 중단하기 위해 실행할 ALTER SERVER CONFIGURATION 때 오류가 발생한 후 데이터베이스가 잘못된 일시 중단 상태에 있는 것을 알 수 있습니다. 스냅샷 백업을 위해 서버를 일시 중단할 때 발생하는 오류는 다음 오류와 유사합니다.
메시지 9018, 수준 16, 상태 1, 줄 <LineNumber>
데이터베이스 <DatabaseName> 의 로그는 사용자 쓰기를 허용하지 않습니다.메시지 5901, 수준 16, 상태 1, 줄 <LineNumber>
데이터베이스 <DatabaseName> 에 속한 하나 이상의 복구 단위가 검사점을 생성하지 못했습니다. 이는 일반적으로 디스크 또는 메모리와 같은 시스템 리소스 부족 또는 일부 경우 데이터베이스 손상으로 인해 발생합니다. 이 오류에 대한 자세한 내용은 오류 로그의 이전 항목을 검사합니다.
이 오류가 발생하면 서버에서 일시 중단된 데이터베이스 수가 0으로 표시되지만 일부 데이터베이스가 제대로 일시 중단 해제되지는 않습니다.
이 상황에서는 후속 스냅샷 백업을 위해 서버를 일시 중단하는 명령을 실행할 ALTER SERVER CONFIGURATION 때 다음 오류가 발생합니다.
메시지 3081, 수준 16, 상태 4, 줄 <LineNumber>
데이터베이스 <DatabaseName>은 이전에 스냅샷 백업을 위해 일시 중단되었습니다.
해결 방법
이 문제는 SQL Server에 대한 다음 누적 업데이트에서 해결되었습니다.
SQL Server의 누적 업데이트 정보
SQL Server에 대한 각각의 새로운 누적 업데이트에는 이전 빌드의 모든 핫픽스 및 보안 수정 사항이 포함되어 있습니다. 사용 중인 SQL Server 버전에 맞는 최신 빌드를 설치하는 것이 좋습니다.
상태
Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.
참조 자료
Microsoft에서 소프트웨어 업데이트를 설명하는 데 사용하는 용어에 대해 알아보세요.