Operatorer angir hvilken type beregning du vil utføre på elementer i en formel, for eksempel addisjon, subtraksjon, multiplikasjon eller divisjon. I denne artikkelen lærer du standardrekkefølgen der operatorer fungerer på elementene i en beregning. Du vil også lære hvordan du endrer denne rekkefølgen ved hjelp av parenteser.

Operatortyper

Det finnes fire typer beregningsoperatorer: aritmetiske operatorer, sammenligningsoperatorer, tekstoperatorer og referanseoperatorer.

Hvis du vil utføre grunnleggende matematiske operasjoner som addisjon, subtraksjon eller multiplikasjon , eller for å kombinere tall , og produsere numeriske resultater, bruker du de aritmetiske operatorene i denne tabellen.

Aritmetisk operator

Betydning

Eksempel

+ (plusstegn)

Addisjon

=3+3

– (minustegn)

Subtraksjon
Negasjonen

=3–1
=–1

* (stjernetegn)

Multiplikasjon

=3*3

/ (skråstrek)

Divisjon

=3/3

% (prosenttegn)

Prosent

=20 %

^ (cirkumflekstegn)

Eksponentiering

=2^3

Med operatorene i tabellen nedenfor kan du sammenligne to verdier. Når to verdier sammenlignes ved hjelp av disse operatorene, er resultatet en logisk verdi enten SANN eller USANN.

Sammenligningsoperator

Betydning

Eksempel

= (likhetstegn)

Lik

=A1=B1

> (større enn-tegn)

Større enn

=A1>B1

< (mindre enn-tegn)

Mindre enn

=A1<B1

>= (større enn- eller lik-tegn)

Større enn eller lik

=A1>=B1

<= (mindre enn- eller lik-tegn)

Mindre enn eller lik

=A1<=B1

<> (ikke lik-tegn)

Ikke lik

=A1<>B1

Bruk ampersand (&) til å slå sammen, eller kjede sammen, én eller flere tekststrenger for å produsere én enkelt tekstdel.

Tekstoperator

Betydning

Eksempel

& (og-tegn)

Kobler sammen to verdier for å produsere én sammenhengende tekstverdi.

="Nord"&"vind"

Kombinere celleområder for beregninger med disse operatorene.

Referanseoperator

Betydning

Eksempel

: (kolon)

Områdeoperator som gir en referanse til alle cellene mellom (og innbefattet) de to referansene.

=SUMMER(B5:B15)

; (semikolon)

Unionoperator, som kombinerer flere referanser til én referanse.

=SUMMER(B5:B15,D5:D15)

(mellomrom)

Skjæringspunktoperator, som produserer en referanse til celler som er felles for de to referansene.

=SUMMER(B7:D7 C6:C8)

# (pund)

#-symbolet brukes i flere kontekster:

  • Brukes som en del av et feilnavn.

  • Brukes til å angi utilstrekkelig plass til å gjengi. I de fleste tilfeller kan du utvide kolonnen til innholdet vises riktig.

  • Operator for overflytområde, som brukes til å referere til et helt område i en dynamisk matriseformel.

  • #VERDI!

  • #####

  • =SUMMER(A2#)

@ (at)

Referanseoperator, som brukes til å angi implisitt skjæringspunkt i en formel. 

=@A1:A10

=SUMMER(Tabell1[@[Januar]:[Desember]])

Rekkefølgen som brukes til å utføre operasjoner i formler

I noen tilfeller kan rekkefølgen som beregningen utføres i, påvirke returverdien for formelen, så det er viktig å forstå rekkefølgen, og hvordan du kan endre rekkefølgen for å få resultatene du forventer å se.

I formler beregnes verdier i en bestemt rekkefølge. En formel i Excel starter alltid med et likhetstegn (=). Likhetstegnet forteller Excel at tegnene som følger utgjør en formel. Etter dette likhetstegnet kan det være en rekke elementer som skal beregnes (operandene), som er atskilt med beregningsoperatorer. I Excel beregnes formelen fra venstre til høyre, i henhold til en bestemt rekkefølge for hver operator i formelen.

Hvis du kombinerer flere operatorer i én enkelt formel, utføres operasjonene i den rekkefølgen som vises i tabellen nedenfor. Hvis en formel inneholder operatorer med samme prioritet – for eksempel en formel som inneholder både en operator for multiplikasjon og en for divisjon – blir operatorene evaluert fra venstre mot høyre.

Operator

Beskrivelse

: (kolon)

(enkelt mellomrom)

; (semikolon)

Referanseoperatorer

Negasjon (som i –1)

%

Prosent

^

Eksponentiering

* og /

Multiplikasjon og divisjon

+ og –

Addisjon og subtraksjon

&

Føyer sammen to strenger med tekst (sammenkobling)

=
< >
<=
>=
<>

Sammenligning

Hvis du vil endre rekkefølgen på evalueringen, må du omslutte den delen av formelen som skal beregnes først, med parenteser. Formelen nedenfor resulterer for eksempel i verdien 11, fordi Excel beregner multiplikasjon før addisjon. Formelen multipliserer først 2 med 3, og legger deretter til 5 i resultatet.

=5+2*3

Hvis du derimot bruker parenteser til å endre syntaksen, legger Excel sammen 5 og 2, og multipliserer deretter resultatet med 3 for å produsere 21.

=(5+2)*3

I eksemplet nedenfor vil parentesene som omslutter den første delen av formelen, tvinge Excel til å beregne B4+25 først, og deretter dele resultatet med summen av verdiene i celle D5, E5 og F5.

=(B4+25)/SUMMER(D5:F5)

Se denne videoen om operatorrekkefølge i Excel for å finne ut mer.

Hvordan Excel konverterer verdier i formler

Når du skriver inn en formel, forventer Excel bestemte verdityper for hver operator. Hvis du angir en annen type verdi enn forventet, kan Excel konvertere verdien.

Formelen

Produserer

Forklaring

= "1"+"2"

3

Når du bruker et plusstegn (+), forventer Excel tall i formelen. Selv om anførselstegnene betyr at «1» og «2» er tekstverdier, konverterer Excel automatisk tekstverdiene til tall.

= 1+"$4,00"

5

Når en formel forventer et tall, konverterer Excel tekst hvis den er i et format som vanligvis godtas for et tall.

= "01.06.2001"-"01.05.2001"

31

Excel tolker teksten som en dato i formatet mm/dd/åååå, konverterer datoene til serienumre og beregner deretter forskjellen mellom dem.

=ROT ("8+1")

#VERDI!

Excel kan ikke konvertere teksten til et tall fordi teksten «8+1» ikke kan konverteres til et tall. Du kan bruke «9» eller «8»+»1 i stedet for «8+1» til å konvertere teksten til et tall og returnere resultatet av 3.

= "A"&TRUE

ATRUE

Når teksten er forventet, konverterer Excel tall og logiske verdier som SANN og USANN til tekst.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excels tekniske fellesskap eller få hjelp i Svar-fellesskapet.

Se også

Trenger du mer hjelp?

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Microsoft Office Insider-deltakere

Var denne informasjonen nyttig?

Hvor fornøyd er du med språkkvaliteten?
Hva påvirket opplevelsen din?

Takk for tilbakemeldingen!

×