Bruke nestede funksjoner i en formel

Bruk av en funksjon som ett av argumentene i en formel som bruker en funksjon, kalles nestende, og vi vil referere til denne funksjonen som en nestet funksjon. Hvis du for eksempel nester GJENNOMSNITT- og SUMMER-funksjonen i argumentene for HVIS-funksjonen, summerer følgende formel et sett med tall (G2:G5) bare hvis gjennomsnittet av et annet sett med tall (F2:F5) er større enn 50. Ellers returneres 0.

Nestede funksjoner

FUNKSJONENE GJENNOMSNITT og SUMMER nestes i HVIS-funksjonen.

Du kan neste opptil 64 nivåer med funksjoner i en formel.

  1. Klikk i cellen der du vil sette inn formelen.

  2. Hvis du vil starte formelen med funksjonen, klikker du Sett inn Knapp på formellinjen Knapp .

    Likhetstegnet (=) settes inn automatisk for deg.

  3. Velg Alle i boksen Eller velg en kategori.

    Hvis du kjenner til funksjonskategoriene, kan du også velge en kategori.

    Hvis du ikke er sikker på hvilken funksjon du skal bruke, kan du skrive inn et spørsmål som beskriver hva du vil gjøre, i boksen Søk etter en funksjon ("legge sammen tall" returnerer for eksempel funksjonen SUMMER).

  4. Hvis du vil angi en annen funksjon som et argument, skriver du inn funksjonen i argumentboksen du vil bruke.

    Delene av formelen som vises i dialogboksen Funksjonsargumenter, gjenspeiler funksjonen du valgte i forrige trinn.

    Hvis du klikket HVIS, viser dialogboksen Funksjonsargumenter argumentene for HVIS-funksjonen. Hvis du vil neste en annen funksjon, kan du skrive den inn i argumentboksen. Du kan for eksempel skrive INN SUMMER(G2:G5) i Value_if_true forHVIS-funksjonen.

  5. Skriv inn eventuelle andre argumenter som kreves for å fullføre formelen.

    I stedet for å skrive inn cellereferanser, kan du også velge cellene du vil referere. Klikk Knapp for å minimere dialogboksen, merk cellene du vil referere til, og klikk deretter Knapp for å utvide dialogboksen på nytt.

    : Hvis du vil ha mer informasjon om funksjonen og argumentene, klikker du Hjelp med denne funksjonen.

  6. Når du har valgt argumentene for formelen, klikker du OK.

  1. Klikk i cellen der du vil sette inn formelen.

  2. Hvis du vil starte formelen med funksjonen, klikker du Sett inn Knapp på formellinjen Knapp .

  3. Velg Alle i Velg en kategori-boksen i dialogboksen Sett inn funksjon.

    Hvis du kjenner til funksjonskategoriene, kan du også velge en kategori.

  4. Hvis du vil angi en annen funksjon som et argument, skriver du inn funksjonen i argumentboksen i formelverktøyet eller direkte i cellen.

  5. Skriv inn eventuelle andre argumenter som kreves for å fullføre formelen.

  6. Når du har fullført argumentene for formelen, trykker du ENTER.

Eksempler

Nedenfor ser du et eksempel på hvordan du bruker nestede HVIS-funksjoner til å tilordne en bokstavkarakter til en numerisk testresultat.

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Poeng

45

90

78

Formel

Beskrivelse

Resultat

'=HVIS(A2>89,"A",HVIS(A2>79,"B", HVIS(A2>69,"C",HVIS(A2>59;"D";"F")))

Bruker nestede HVIS-betingelser til å tilordne en bokstavkarakter til poengsummen i celle A2.

=HVIS(A2>89,"A";HVIS(A2>79,"B",HVIS(A2>69,"C",HVIS(A2>59;"D";"F")))

'=HVIS(A3>89,"A",HVIS(A3>79,"B", HVIS(A3>69,"C",HVIS(A3>59;"D";"F"))))

Bruker nestede HVIS-betingelser til å tilordne en bokstavkarakter til poengsummen i celle A3.

=HVIS(A3>89,"A";HVIS(A3>79,"B",HVIS(A3>69,"C",HVIS(A3>59;"D","F")))

'=HVIS(A4>89,"A",HVIS(A4>79,"B", HVIS(A4>69,"C",HVIS(A4>59;"D";"F")))

Bruker nestede HVIS-betingelser til å tilordne en bokstavkarakter til poengsummen i celle A4.

=HVIS(A4>89,"A";HVIS(A4>79,"B",HVIS(A4>69,"C",HVIS(A4>59;"D";"F")))

: 

Trenger du mer hjelp?

Excel_CommunityLinks

Se også

Video: Nestede HVIS-funksjoner

Trenger du mer hjelp?

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

×