INDEKS-funksjonen returnerer en verdi eller referansen til en verdi fra en tabell eller et område.

Nettleseren støtter ikke video.

Det finnes to måter å bruke INDEKS-funksjonen på:

  • Hvis du vil returnere verdien til en angitt celle eller matrise av celler, kan du se Matriseform.

  • Hvis du vil returnere en referanse til angitte celler, kan du se Referanseform.

Matriseform

Beskrivelse

Returnerer verdien til et element i en tabell eller en matrise, merket av rad- og kolonnenummerindeksene.

Bruk matriseformelen hvis det første argumentet i INDEKS er en matrisekonstant.

Syntaks

INDEKS(matrise; rad_nr; [kolonne_nr])

Matriseformen for INDEKS-funksjonen har følgende argumenter:

  • matrise    Obligatorisk. Et celleområde eller en matrisekonstant.

    • Hvis matrise bare inneholder én rad eller kolonne, er det tilsvarende row_num eller column_num argumentet valgfritt.

    • Hvis matrise har mer enn én rad og mer enn én kolonne, og bare row_num eller column_num brukes, returnerer INDEKS en matrise av hele raden eller kolonnen i matrisen.

  • rad_nr    Obligatorisk, med mindre column_num finnes. Velger raden i en matrise som en verdi skal returneres fra. Hvis row_num er utelatt, column_num er obligatorisk.

  • column_num    Valgfri. Velger kolonnen i en matrise som en verdi skal returneres fra. Hvis column_num utelates, er row_num obligatorisk.

Merknader

  • Hvis argumentene row_num og column_num brukes, returnerer INDEKS verdien i cellen i skjæringspunktet mellom row_num og column_num.

  • row_num og column_num peker til en celle i matrisen. Ellers returnerer INDEKS en #REF! -feil.

  • Hvis du angir row_num eller column_num til 0 (null), returnerer INDEKS matrisen med verdier for henholdsvis hele kolonnen eller raden. Hvis du vil bruke verdier som returneres som en matrise, skriver du inn INDEKS-funksjonen som en matriseformel.

    Obs!: Hvis du har en gjeldende versjon av Microsoft 365, kan du skrive inn formelen i cellen øverst til venstre i utdataområdet, og deretter trykke ENTER for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved først å merke utdataområdet, skrive inn formelen i cellen øverst til venstre i utdataområdet, og deretter trykke CTRL+SKIFT+ENTER for å bekrefte den. Excel setter inn klammeparenteser i begynnelsen og slutten av formelen for deg. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

Eksempler

Eksempel 1

Disse eksemplene bruker INDEKS-funksjonen til å finne verdien i cellen i skjæringspunktet der en rad og kolonne møtes.

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker på F2 og deretter ENTER.

Data

Data

Epler

Sitroner

Bananer

Pærer

Formel

Beskrivelse

Resultat

=INDEKS(A2:B3,2,2)

Verdien i skjæringspunktet mellom andre rad og andre kolonne i området A2:B3.

Pærer

=INDEKS(A2:B3;2;1)

Verdien i skjæringspunktet mellom andre rad og første kolonne i området A2:B3.

Bananer

Eksempel 2

Dette eksemplet bruker INDEKS-funksjonen i en matriseformel til å finne verdiene i to celler angitt i en 2x2-matrise.  

Obs!: Hvis du har en gjeldende versjon av Microsoft 365, kan du skrive inn formelen i cellen øverst til venstre i utdataområdet, og deretter trykke ENTER for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved først å merke to tomme celler, skrive inn formelen i cellen øverst til venstre i utdataområdet, og deretter trykke CTRL+SKIFT+ENTER for å bekrefte den. Excel setter inn klammeparenteser i begynnelsen og slutten av formelen for deg. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

Formel

Beskrivelse

Resultat

=INDEKS({1,2;3,4},0,2)

Verdien i første rad, andre kolonne i matrisen. Matrisen inneholder 1 og 2 i første rad og 3 og 4 i andre rad.

2

Verdien i andre rad, andre kolonne i matrisen (samme matrise som ovenfor).

4

Til toppen av siden


Referanseskjema

Beskrivelse

Returnerer referansen for cellen i skjæringspunktet mellom en bestemt rad eller kolonne. Hvis referansen består av ikke-tilstøtende valg, kan du velge det merkede området du vil søke i.

Syntaks

INDEKS(referanse; rad_nr;[kolonne_nr]; [område_nr])

Referanseformen for INDEKS-funksjonen har følgende argumenter:

  • referanse    Obligatorisk. En referanse til ett eller flere celleområder.

    • Hvis du skriver inn et ikke-tilstøtende område for referansen, omslutter du referansen i parenteser.

    • Hvis hvert område i referansen bare inneholder én rad eller kolonne, er row_num eller column_num argumentet valgfritt. For en referanse til en enkelt rad, bruker du for eksempel INDEKS(referanse;kolonne_nr).

  • row_num    Obligatorisk. Nummeret på raden i referanse som en referanse returneres fra.

  • column_num    Valgfri. Nummeret på kolonnen i referanse som en referanse returneres fra.

  • area_num    Valgfritt. Velger et område i referansen du vil returnere skjæringspunktet mellom row_num og column_num. Det første området som er merket eller angitt, er nummerert 1, det andre er 2 og så videre. Hvis area_num utelates, bruker INDEKS område 1.  Områdene som er oppført her, må være plassert på ett ark.  Hvis du angir områder som ikke er på samme ark som hverandre, vil det føre til en #VALUE! -feil.  Hvis du trenger å bruke områder som er plassert på forskjellige ark fra hverandre, anbefales det at du bruker matriseformen for INDEKS-funksjonen, og bruker en annen funksjon til å beregne området som utgjør matrisen.  Du kan for eksempel bruke VELG-funksjonen til å beregne hvilket område som skal brukes.

Hvis referanse for eksempel beskriver cellene (A1:B4,D1:E4,G1:H4), er area_num 1 området A1:B4, area_num 2 er området D1:E4, og area_num 3 er området G1:H4.

Merknader

  • Når referanse og area_num har merket et bestemt område, merker row_num og column_num en bestemt celle: row_num 1 er den første raden i området, column_num 1 er den første kolonnen og så videre. Referansen som returneres av INDEKS, er skjæringspunktet mellom row_num og column_num.

  • Hvis du angir row_num eller column_num til 0 (null), returnerer INDEKS referansen for henholdsvis hele kolonnen eller raden.

  • row_num, column_num og area_num peker til en celle i referansen. Ellers returnerer INDEKS en #REF! -feil. Hvis row_num og column_num er utelatt, returnerer INDEKS området i referansen som er angitt av area_num.

  • Resultatet av INDEKS-funksjonen er en referanse og tolkes som en referanse av andre formler. Avhengig av formelen, kan returverdien fra INDEKS brukes som en referanse eller som en verdi. Formelen CELLE("bredde";INDEKS(A1:B2;1;2)) er for eksempel ekvivalent med CELLE("bredde";B1). CELLE-funksjonen bruker returverdien fra INDEKS som en cellereferanse. På den andre siden vil en formel som for eksempel 2*INDEKS(A1:B2;1;2) oversette returverdien fra INDEKS til tallet i celle B1.

Eksempler

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER.

Frukt

Pris

count

Epler

$0.69

40

Bananer

$0.34

38

Sitroner

$0.55

15

Appelsiner

$0.25

25

Pærer

$0.59

40

Mandler

$2.80

10

Acajounøtter

$3.55

16

Peanøtter

$1.25

20

Valnøtter

$1.75

12

Formel

Beskrivelse

Resultat

=INDEKS(A2:C6;2;3)

Skjæringspunktet mellom den andre raden og den tredje kolonnen i området A2:C6, som er innholdet i celle C3.

38

=INDEKS((A1:C6;A8:C11);2;2;2)

Skjæringspunktet mellom den andre raden og den andre kolonnen i det andre området for A8:C11, som er innholdet i celle B9.

1,25

=SUMMER(INDEKS(A1:C11;0;3;1))

Summen av den tredje kolonnen i det første området av område A1:C11, som er summen av C1:C11.

216

=SUMMER(B2:INDEKS(A2:C6;5;2))

Summen av området som starter i B2, og slutter i skjæringspunktet mellom den femte raden og den andre kolonnen i området A2:A6, som er summen av B2:B6.

2,42

Til toppen av siden

Se også

FINN.RAD (funksjon)

SAMMENLIGNE (funksjon)

INDIREKTE (funksjon)

Retningslinjer og eksempler på matriseformler

Oppslags- og referansefunksjoner (referanse)

Trenger du mer hjelp?

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Microsoft Insiders

Var denne informasjonen nyttig?

Hvor fornøyd er du med kvaliteten på oversettelsen?

Hva påvirket opplevelsen din?

Har du ytterligere tilbakemeldinger? (valgfritt)

Takk for tilbakemeldingen!

×