Logg på med Microsoft
Logg på, eller opprett en konto.
Hei,
Velg en annen konto.
Du har flere kontoer
Velg kontoen du vil logge på med.
Slik retter du en #REF! -feil

Feilen #REF! viser når en formel refererer til en celle som ikke er gyldig. Dette skjer oftest når celler som ble referert til i formler blir slettet eller limt over.

Følgende eksempel bruker formelen =SUM(B2,C2,D2) for kolonne E.

En formel som bruker eksplisitte cellereferanser som =SUMMER(B2,C2,D2) kan forårsake en #REF! hvis en kolonne slettes.

Hvis du slettet kolonne B, C eller D, ville det føre til en #REF! . I dette tilfellet sletter vi kolonne C (2007 Salg), og formelen leser nå =SUMMER(B2,#REF!,C2). Når du bruker eksplisitte cellereferanser som dette (der du refererer til hver celle individuelt, atskilt med komma) og sletter en referert rad eller kolonne, kan ikke Excel løse det, så det returnerer #REF! . Dette er hovedårsaken til at bruk av eksplisitte cellereferanser i funksjoner ikke anbefales.

Eksempel på #REF! feil forårsaket av sletting av en kolonne.

Løsning

  • Hvis du ved et uhell slettet rader eller kolonner, kan du umiddelbart klikke Angre-knappen på verktøylinjen for hurtigtilgang (eller trykke CTRL+Z) for å gjenopprette dem.

  • Juster formelen slik at den bruker en områdereferanse i stedet for enkeltceller, som for eksempel =SUM(B2:D2). Nå kan du slette en kolonne innenfor området for summen, og Excel vil automatisk justere formelen. Du kan også bruke =SUM(B2:B5) for en sum av rader.

I eksemplet nedenfor vil =FINN.RAD(A8,A2:D5,5,USANN) returnere en #REF! fordi den leter etter en verdi som skal returneres fra kolonne 5, men referanseområdet er A:D, som bare er fire kolonner.

Eksempel på en FINN.RAD-formel med feil område.  Formelen er =VLOOKU(A8,A2:D5,5,FALSE).  Det er ingen femte kolonne i FINN.RAD-området, så 5 fører til en #REF! -feil.

Løsning

Juster området til å være større, eller reduser kolonnen for oppslagsverdien til å samsvare med referanseområdet. =FINN.RAD(A8,A2:E5,5,USANN) vil være et gyldig referanseområde, og det vil også =FINN.RAD(A8,A2:D5,4,USANN).

I dette eksemplet returnerer formelen =INDEKS(B2:E5,5,5) en #REF! fordi INDEKS-området er fire rader ganger fire kolonner, men formelen ber om å returnere det som er i den femte raden og den femte kolonnen.

Eksempel på en INDEKS-formel med en ugyldig områdereferanse.  Formelen er =INDEKS(B2:E5,5,5), men området er bare 4 rader ganger 4 kolonner.

Løsning

Juster referanseraden eller -kolonnen slik at de er i INDEKS-oppslagsområdet. =INDEKS(B2:E5,4,4) vil returnere et gyldig resultat.

I eksemplet nedenfor forsøker en INDIREKTE-funksjon å referere til en arbeidsbok som er lukket, noe som forårsaker en #REF! -feil.

Eksempel på en #REF! feil forårsaket av indirekte referanse til en lukket arbeidsbok.

Løsning

Åpne arbeidsboken det refereres til. Det oppstår samme feil hvis du refererer til en lukket arbeidsbok med en dynamisk matrisefunksjon.

Strukturerte referanser til tabell- og kolonnenavn i koblede arbeidsbøker støttes ikke.

Beregnede referanser til koblede arbeidsbøker støttes ikke.

Flytting eller sletting av celler forårsaket en ugyldig cellereferanse, eller funksjonen returnerer referansefeil.

Hvis du har brukt en OLE-kobling (Object Linking and Embedding) som returnerer en #REF! , og start deretter programmet som koblingen kaller opp.

Obs! OLE er en teknologi som du kan bruke til å dele informasjon mellom programmer.

Hvis du har brukt et DDE-emne (Dynamic Data Exchange) som returnerer en #REF! må du først kontrollere at du refererer til det riktige emnet. Hvis du fortsatt mottar en #REF! kan du kontrollere innstillingene for klareringssenteret for eksternt innhold som beskrevet i Blokkere eller oppheve blokkering av eksternt innhold i Microsoft 365-dokumenter.

Obs! DDE (Dynamic Data Exchange)er en etablert protokoll for utveksling av data mellom Microsoft Windows-baserte programmer.

Makro-problemer

Hvis en makro angir en funksjon på regnearket som refererer til en celle over funksjonen, og cellen som inneholder funksjonen er i rad 1, returnerer funksjonen #REF! fordi det ikke finnes noen celler over rad 1. Kontroller funksjonen for å se om et argument refererer til en celle eller et celleområde som ikke er gyldig. Dette kan kreve at du redigerer makroen i Visual Basic Editor (VBE), for å ta hensyn til situasjonen.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i det tekniske fellesskapet for Excel eller få støtte i Fellesskap.

Se også

Oversikt over formler i Excel

Unngå formler med feil

Oppdage feil i formler

Funksjoner i Excel

Excel-funksjoner (etter kategori)

Trenger du mer hjelp?

Vil du ha flere alternativer?

Utforsk abonnementsfordeler, bla gjennom opplæringskurs, finn ut hvordan du sikrer enheten og mer.

Fellesskap hjelper deg med å stille og svare på spørsmål, gi tilbakemelding og høre fra eksperter med stor kunnskap.

Var denne informasjonen nyttig?

Hvor fornøyd er du med språkkvaliteten?
Hva påvirket opplevelsen din?
Når du trykker på Send inn, blir tilbakemeldingen brukt til å forbedre Microsoft-produkter og -tjenester. IT-administratoren kan samle inn disse dataene. Personvernerklæring.

Takk for tilbakemeldingen!

×