SUMMERPRODUKT (funksjon)

SUMMERPRODUKT-funksjonen returnerer summen av produktene i tilsvarende områder eller matriser. Standardoperasjonen er multiplikasjon, men addisjon, subtraksjon og divisjon er også mulig.

I dette eksemplet bruker vi SUMMERPRODUKT til å returnere totalt salg for en gitt vare og størrelse:

Eksempel på bruk av SUMMERPRODUKT-funksjonen til å returnere totalt salg når det følger med produktnavn, størrelse og individuelle salgsverdier for hver av dem.

SUMMERPRODUKT samsvarer med alle forekomster av element Y/størrelse M og summerer dem, så i dette eksemplet er 21 pluss 41 lik 62.

Syntaks

Slik bruker du standardoperasjonen (multiplikasjon):

=SUMMERPRODUKT(matrise1; [matrise2]; [matrise3]; ...)

Syntaksen for SUMMERPRODUKT har følgende argumenter:

Argument

Beskrivelse

matrise1   

Obligatorisk

Det første matriseargumentet som du vil multiplisere og deretter legge sammen.

[matrise2], [matrise3],...    

Valgfritt

Matriseargumenter fra 2 til 255 med komponenter du vil multiplisere og deretter legge sammen.

Slik utfører du andre aritmetiske operasjoner

Bruk SUMMERPRODUKT som vanlig, men erstatt kommaene som skiller matriseargumentene med de aritmetiske operatorene du vil bruke (*, /, +, -). Når alle operasjonene er utført, summeres resultatene som vanlig.

Obs!: Hvis du bruker aritmetiske operatorer, bør du vurdere å omslutte matriseargumentene i parenteser og bruke parenteser til å gruppere matriseargumentene for å kontrollere rekkefølgen på aritmetiske operasjoner.

Merknader

  • Matriseargumentene må ha samme dimensjoner. Hvis de ikke gjør det, returnerer SUMMERPRODUKT #VALUE! feilverdi. =SUMMERPRODUKT(C2:C10;D2:D5) returnerer for eksempel en feil siden områdene ikke har samme størrelse.

  • SUMMERPRODUKT behandler ikke-numeriske matriseoppføringer som om de var nuller.

  • For best ytelse bør IKKE SUMMERPRODUKT brukes med fullstendige kolonnereferanser. Vurder =SUMMERPRODUKT(A:A;B:B), her multipliseres 1 048 576 celler i kolonne A med 1 048 576 celler i kolonne B før de legges til. 

Eksempel 1

Eksempel på SUMMERPRODUKT-funksjonen som brukes til å returnere summen av solgte varer når oppgitt enhetskostnad og antall.

Hvis du vil opprette formelen ved hjelp av eksempellisten ovenfor, skriver du inn =SUMMERPRODUKT(C2:C5,D2:D5) og trykker ENTER. Hver celle i kolonne C multipliseres med den tilsvarende cellen i samme rad i kolonne D, og resultatene legges sammen. Det totale beløpet for dagligvarer er kr 78,97.

Hvis du vil skrive en lengre formel som gir deg samme resultat, skriver du inn =C2*D2+C3*D3+C4*D4+C5*D5 og trykker ENTER. Når du har trykket enter, er resultatet det samme: kr 78,97. Celle C2 multipliseres med D2, og resultatet legges til resultatet av celle C3 ganger celle D3 og så videre.

Eksempel 2

Følgende eksempel bruker SUMMERPRODUKT til å returnere det totale nettosalget etter salgsagent, der vi har både totalt salg og utgifter etter agent. I dette tilfellet bruker vi en Excel-tabellsom bruker strukturerte referanser i stedet for standard Excel-områder. Her ser du at områdene Salg, Utgifter og Agent refereres til etter navn.

Eksempel på SUMMERPRODUKT-funksjonen for å returnere totalt salg etter selger når det følger med salg og utgifter for hver av dem.

Formelen er: =SUMMERPRODUKT((((Tabell1[Salg])+(Tabell1[Utgifter]))*(Tabell1[Agent]=B8)), og den returnerer summen av alle salg og utgifter for agenten som er oppført i celle B8.

Eksempel 3

I dette eksemplet ønsker vi å returnere totalsummen for et bestemt element som selges av et bestemt område. I dette tilfellet hvor mange kirsebær solgte østområdet?

Exampe av å bruke SUMMERPRODUKT til å returnere summen av elementer etter område. I dette tilfellet antall kirsebær som er solgt i det østlige området.

Her er formelen: =SUMMERPRODUKT((B2:B9=B12)*(C2:C9=C12)*D2:D9). Det multipliserer først antall forekomster av Øst med antall samsvarende forekomster av kirsebær. Til slutt summerer den verdiene for de tilsvarende radene i Salg-kolonnen. Hvis du vil se hvordan Excel beregner dette, merker du formelcellen og går til > evaluer formel >Evaluer.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excels tekniske fellesskap eller få hjelp i Svar-fellesskapet.

Se også

Utføre betingede beregninger på celleområder

Summer basert på flere vilkår med SUMMER.HVIS.HVIS.MULTIPLUM

Telle basert på flere vilkår med ANTALL.HVIS.HVIS.MULTIPLUM

Gjennomsnitt basert på flere vilkår med AVERAGEIFS

Trenger du mer hjelp?

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×