Symptomen
Stel dat u Microsoft BizTalk Server 2010 of 2013. De eigenschap DocumentSpecName context is onjuist ingesteld in het uitvoerbericht wanneer u een aangepaste pijplijncomponent Enterprise Service Bus (ESB) Transformation Service om berichten in ESB Toolkit 2.1 transformeren aanroepen, en u ontvangt het volgende foutbericht weergegeven:
Meld naam: toepassing
Bron: BizTalk Server
Gebeurtenis-ID: 5720
Categorie: BizTalk Server
Niveau: fout
Omschrijving: Er is een fout opgetreden bij het uitvoeren van de pijpleiding verzenden: "versie ESBTransform.SendPipeline1, ESBTransform, 1.0.0.0, Culture = neutral, PublicKeyToken = = ca09cc62b15919a7 ' bron: verzenden poort 'Platte bestand assembler': ' <SendPortName >" URI: reden "<SendPortURI>": het document "http://ESBTransform.FlatFileSchema1#TargetRoot" komt niet overeen met een bepaald schema's.
Oorzaak
Het probleem treedt op omdat ESB Transformation Service de eigenschap DocumentSpecName context van het uitvoerbericht stelt naar het doeltype schema worden na transformatie niet.
Oplossing
Informatie over de hotfix
Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld voor het probleem dat wordt beschreven in dit artikel. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet.
Als er een hotfix beschikbaar is om te downloaden, ziet u een sectie 'Hotfix kan worden gedownload' boven aan dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, dien dan een verzoek in bij Microsoft Customer Service and Support om de hotfix te verkrijgen.
Opmerking Als er andere problemen optreden of als probleemoplossing is vereist, moet u wellicht een apart serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen en problemen die niet in aanmerking komen voor deze specifieke hotfix. Voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of een afzonderlijk serviceverzoek maken, gaat u naar de volgende Microsoft-website:
http://support.microsoft.com/contactus/?ws=supportOpmerking Het formulier 'Hotfix kan worden gedownload' geeft de talen weer waarin de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is dit omdat een hotfix niet voor die taal beschikbaar is.
Cumulatieve update informatie
Dit probleem werd in eerste instantie opgelost in de volgende cumulatieve update van BizTalk Server 2013:
Vereisten
Deze hotfix moet u de BizTalk-ESB Toolkit 2.1 geïnstalleerd hebben.
Opnieuw opstarten
U hoeft de computer niet opnieuw op te starten nadat u deze hotfix hebt toegepast.
Informatie over het vervangen van hotfixes
Deze hotfix vervangt geen andere hotfixes.
Bestandsinformatie
De Engelse versie van deze hotfix heeft de bestandskenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Om het verschil tussen UTC en lokale tijd op te zoeken, gebruikt u het tabblad tijdzone in het onderdeel datum en tijd in het Configuratiescherm.
Bestandsnaam |
Bestandsversie |
Bestandsgrootte |
Datum |
Tijd |
Platform |
---|---|---|---|---|---|
Microsoft.Practices.ESB.Itinerary.Services.dll |
2.1.1.0 |
24576 |
13-Oct-2014 |
13:11 |
x86 |
Meer informatie
Zie Beschrijving van de standaardterminologie die wordt gebruikt voor het beschrijven van software-updates van Microsoftvoor meer informatie over terminologie voor software-update.
Status
Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.