Symptomen
Gebruikers geen toegang heeft tot het postvak in Outlook Web App (OWA) of Microsoft Exchange ActiveSync (EAS) wanneer aan de volgende voorwaarden voldaan wordt:
-
Alle postbussen worden verplaatst uit de database van een postbus.
-
De oorspronkelijke database in de postbus is verwijderd uit de organisatie.
Wanneer gebruikers zich aanmelden bij OWA, wordt een lege pagina of 'HTTP 500' foutbericht. Bijvoorbeeld, wordt het volgende foutbericht weergegeven:
De pagina HTTP 500 weergeven niet
Als u de Test-ActiveSyncConnectivity -cmdlet uitvoert, wordt uitvoer die lijkt op het volgende:
ClientAccessServer........: exch1.tailspintoys.comScenario................. : Options
ScenarioDescription.......: Issue an HTTP OPTIONS command to retrieve the Exchange ActiveSync protocol version.
Result....................: Failure
Error.....................: [System.Net.WebException]: The remote server returned an error: (500) Internal Server
............................Error.
............................HTTP response headers:
............................request-id: 20a9d8d4-5019-4048-9bf1-b659ef00fee4
............................X-CasErrorCode: DatabaseGuidNotFound
............................X-FailureContext:
FrontEnd;500;RGF0YWJhc2VHdWlkTm90Rm91bmQ=;VGhlIGRhdGFiYXNlIHdpdGggSUQgM
............................2QxNTMxYzktODEwOC00OGRiLWIyMmUtOTUxMzZkMWI4MjNlIGNvdWxkbid0IGJlIGZvdW5kLg==;DatabaseGuidNotFound;;
............................X-FEServer: EXCH1
............................Content-Length: 0
............................Cache-Control: private
............................Date: Tue, 08 Apr 2014 20:17:57 GMT
............................Server: Microsoft-IIS/8.5
............................X-AspNet-Version: 4.0.30319
............................X-Powered-By: ASP.NET
Oorzaak
Dit probleem doet zich voor omdat de database van de postbus van een gebruiker GUID (bron) bevindt zich in een cookie van de client-side en toegevoegd aan de cache op de Client Access server (CA's). De HTTP-proxy op de Certificeringsinstanties wordt gezocht naar de mailbox-database met behulp van de oude database GUID in de cache. Omdat de oude GUID-database is verwijderd, wordt de poging mislukt en retourneert een fout DatabaseGuidNotFound .
Oplossing
U kunt dit probleem oplossen door de volgende update te installeren:
2961810 cumulatieve Update 6 voor Exchange Server 2013
Tijdelijke oplossing
Voorkom dit probleem onmiddellijk Verwijder niet de brondatabase Postvak nadat de postvakverplaatsing voltooid is.
Als u dit probleem wilt omzeilen, verwijdert u alle cookies van de client en start de MSExchangeOWAAppPool en MSExchangeSyncAppPool groepen van toepassingen uit de cache.
Status
Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.
Meer informatie
Als de database van de postbus van een gebruiker wordt verwijderd nadat u cumulatieve Update 5 voor 2013 van Exchange Server is geïnstalleerd, kan een van de volgende problemen optreden:
-
De OWA-gebruiker ontvangt een 'HTTP 500' foutbericht één keer. Vervolgpogingen aanmelden bij OWA mislukt.
-
Als de OWA-site ooit geladen via https://domein/OWA is, wellicht de gebruiker de bijbehorende cookie op de browser te wissen. Dit is een eenmalige taak.
Open de Exchange Management Shell op de server waarop de CA-functie om te controleren of gebruikers een bijgewerkte cookie verzendt, en voert u de volgende opdracht:
Get-ChildItem 'C:\Program Files\Microsoft\Exchange Server\V15\Logging\HttpProxy\Owa' | Select-String (Get-MailboxDatabase <OldMailboxDatabase>).Guid | ft Path,LineNumber -AutoSize Opmerking Deze opdracht moet ook worden uitgevoerd tegen de EAS-map op de volgende locatie:
C:\Program Files\Microsoft\Exchange Server\V15\Logging\HttpProxy\EasDe uitvoer worden het logboek en de GUID gevestigd is. Wanneer de oude database GUID wordt niet langer in de huidige HttpProxy logboeken weergegeven, moet u mogelijk zijn veilig verwijderen van de database.