Je bent nu offline; er wordt gewacht tot er weer een internetverbinding is

FIX: Nieuwe verbindingen worden niet geaccepteerd op een bepaald webproxy of weblistener Threat Management Gateway 2010

BELANGRIJK: Dit artikel is vertaald door middel van automatische vertalingssoftware van Microsoft en is mogelijk nabewerkt door de Microsoft Community via CTF-technologie (Community Translation Framework) of door een menselijke vertaler. Microsoft biedt zowel automatisch vertaalde, door mensen vertaalde en door de community nabewerkte artikelen aan, zodat er in meerdere talen toegang is tot alle artikelen in onze Knowledge Base. Een vertaald of bewerkt artikel kan fouten bevatten in vocabulaire, syntaxis of grammatica.. Microsoft is niet verantwoordelijk voor eventuele onjuistheden, fouten of schade ten gevolge van een foute vertaling van de inhoud van een bericht of het gebruik van deze vertaalde berichten door onze klanten.

De Engelstalige versie van dit artikel is de volgende: 2967726
Symptomen
Een server waarop Microsoft Forefront Threat Management Gateway (TMG) 2010 accepteert geen nieuwe verbindingen op een bepaald webproxy of weblistener. Dit probleem kan optreden na enkele uren over meerdere dagen van de uptime van het systeem.
Oorzaak
Dit probleem treedt op wanneer TMG accepteert geen nieuwe verbindingen op de weblistener. Dit spoedig de wachtrij van de reserve voor de socket aanvullende functie-stuurprogramma (AFD) ingevuld. Nadat de reserve wachtrij vol is, begint de server nieuwe binnenkomende verbindingen opnieuw instelt. Als u de server controleren met behulp van Netwerkcontrole in deze situatie, zult u merken een SYN, ACK/eerste patroon voor elke nieuwe verbindingspoging.
Oplossing
U kunt dit probleem oplossen, installeren Rollup 5 voor Forefront Threat Management Gateway (TMG) 2010 Service Pack 2.
Status
Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.
Meer informatie
Nadat u updatepakket 5 hebt geïnstalleerd, moet u de functie tijd inactief out gesprekken accepteren inschakelen. Ga hiervoor als volgt te werk:
  1. Kopieer het volgende script naar Kladblok en sla de fileas SetAcceptIdleTimeout.vbs:
    'Define the constants needed.Const strVpsGUID = "{143F5698-103B-12D4-FF34-1F34767DEABC}"Const strVpsPropertyName = "AcceptIdleTimeout"Const Error_FileNotFound = &H80070002Set objArgs = wscript.Argumentsif objArgs.Count > 0 then    uAcceptIdleTimeout = objArgs(0)end ifif objArgs.Count <> 1 then    wscript.echo "Usage: SetAcceptIdleTimeout.vbs <timeout>"    wscript.echo    wscript.echo "Set async accept timeout to <timeout> value (in sec)"    wscript.echo "To disable async accept timeout set it to 0"    wscript.Quit 2end ifset objArray = CreateObject("FPC.Root").GetContainingArray()Set objVPSet = OpenVPSet(objArray, strVpsGUID)objVPSet.Value(strVpsPropertyName) = uAcceptIdleTimeoutobjArray.Save()objArray.RestartServices(1)function OpenVPSet(objParent, strVpsGUID)    Set objVPSets = objParent.VendorParametersSets    On Error Resume Next    Set OpenVPSet = objVPSets.Item(strVpsGUID)    ' Save the Err properties in case it needs to be re-raised    errNumber      = Err.Number    errSource      = Err.Source    errDescription = Err.Description    errHelpFile    = Err.HelpFile    errHelpContext = Err.HelpContext        On Error GoTo 0        if errNumber = Error_FileNotFound Then        Set OpenVPSet = objVPSets.Add(strVpsGUID)    Elseif errNumber < 0 Then        ' An error other than "file not found" occurred -- re-raise the error,        ' this time not under "On Error Resume Next"        Err.Raise errNumber, errSource, errDescription, errHelpFile, errHelpContext    End Ifend function

  2. Het script uitvoeren op een van de servers TMG. Voer de volgende uit een administratieve opdrachtprompt bijvoorbeeld de time-outperiode instellen op 5 minuten:

    cscript.exe SetAcceptIdleTimeout.vbs 300
  3. Als u deze wijziging door te voeren, start opnieuw op de firewall-service op alle matrixleden.

Als u wilt deze wijziging ongedaan te maken, voert u de volgende opdracht toset de time-out voor inactiviteit op 0:

cscript.exe SetAcceptIdleTimeout.vbs 0

Referenties
Meer informatie over de terminologie die door Microsoft wordt gebruikt om software-updates te beschrijven.

Waarschuwing: dit artikel is automatisch vertaald

Eigenschappen

Artikel-id: 2967726 - Laatst bijgewerkt: 06/23/2015 02:58:00 - Revisie: 2.0

Microsoft Forefront Threat Management Gateway 2010 Enterprise, Microsoft Forefront Threat Management Gateway 2010 Standard

  • kbqfe kbfix kbexpertiseinter kbbug kbsurveynew kbmt KB2967726 KbMtnl
Feedback
error="var m=document.createElement('meta');m.name='ms.dqp0';m.content='true';document.getElementsByTagName('head')[0].appendChild(m);" onload="var m=document.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?"> type="text/javascript">var guid = ("xxxxxxxx-xxxx-4xxx-Rxxx-xxxxxxxxxxxx".replace(/x/g, function () { return Math.floor(Math.random() * 16).toString(16); })).replace("R", (8 | Math.floor(Math.random() * 3)).toString(16)); var m = document.createElement("meta"); m.content = guid; m.name = "ms.dqid"; document.getElementsByTagName("head")[0].appendChild(m); rite("