ALS.FOUT, functie

U kunt de functie ALSFOUT gebruiken om fouten in een formule over te zetten en te verwerken. ALSFOUT retourneert een waarde die u opgeeft als een formule een fout als resultaat geeft. anders wordt het resultaat van de formule als resultaat gebruikt.

Syntaxis

ALS.FOUT(waarde;waarde_indien_fout)

De syntaxis van de functie ALS.FOUT heeft de volgende argumenten:

  • waarde    Vereist. Het argument dat op fouten wordt gecontroleerd.

  • value_if_error    Verplicht. De waarde die u wilt retourneren als de formule een fout wordt. De volgende fouttypen worden geëvalueerd: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, of #NULL!.

Opmerkingen

  • Als waarde of value_if_error een lege cel is, wordt deze als een lege tekenreekswaarde ("") behandeld.

  • Als waarde een matrixformule is, geeft ALS.FOUT een matrix met resultaten als resultaat voor elke cel in het bereik dat in waarde is opgegeven. Zie het tweede voorbeeld hierna.

Voorbeelden

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. Om resultaten van formules weer te geven, selecteert u deze, drukt u op F2 en drukt u vervolgens op Enter.

Geprojecteerde verkopen

Gerealiseerde verkopen

210

35

55

0

23

Formule

Beschrijving

Resultaat

=ALS.FOUT(A2/B2; "Fout in berekening")

Hiermee wordt gecontroleerd op een fout in het eerste argument van de formule (210 delen door 35), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

6

=ALS.FOUT(A3/B3; "Fout in berekening")

Hiermee wordt gecontroleerd op een fout in het eerste argument van de formule (55 delen door 0), wordt een 'delen door 0'-fout gevonden en wordt waarde_indien_fout als resultaat gegeven.

Fout in berekening

=ALS.FOUT(A4/B4; "Fout in berekening")

Hiermee wordt gecontroleerd op een fout in het eerste argument van de formule ("" delen door 23), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

0

Voorbeeld 2

Geprojecteerde verkopen

Gerealiseerde verkopen

Verhouding

210

35

6

55

0

Fout in berekening

23

0

Formule

Beschrijving

Resultaat

=C2

Hiermee wordt gecontroleerd op een fout in de formule in het eerste argument van het eerste element van de matrix (A2/B2 of 210 delen door 35), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

6

=C3

Hiermee wordt gecontroleerd op een fout in de formule in het eerste argument van het tweede element van de matrix (A3/B3 of 55 delen door 0), wordt een 'delen door 0'-fout gevonden en wordt waarde_indien_fout als resultaat gegeven.

Fout in berekening

=C4

Hiermee wordt gecontroleerd op een fout in de formule in het eerste argument van het derde element van de matrix (A4/B4 of "" delen door 23), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

0

Opmerking: Als u een huidige versie van Microsoft 365hebt, kunt u de formule invoeren in de linkerbovencel van het uitvoerbereik en vervolgens op Enter drukken om de formule te bevestigen als een dynamische matrixformule. Anders moet de formule worden ingevoerd als een oudere matrixformule door eerst het uitvoerbereik te selecteren, de formule in te voeren in de linkerbovencel van het uitvoerbereik en vervolgens op Ctrl+Shift+Enter te drukken om dit te bevestigen. In Excel worden automatisch accolades aan het begin en einde van de formule geplaatst. Zie Richtlijnen en voorbeelden van matrixformules voor meer informatie over matrixformules.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×