De fout #DEEL/0! corrigeren

De fout #DEEL/0! wordt weergegeven in Microsoft Excel als een getal wordt gedeeld door nul (0). Deze fout kan optreden wanneer u een eenvoudige formule invoert zoals =5/0 of wanneer een formule verwijst naar een cel met de waarde 0 of die leeg is, zoals in deze afbeelding.

Voorbeelden van formules die #DIV/0! moeten verdwijnen.

Ga op een van de volgende manieren te werk om de fout te corrigeren:

  • Zorg ervoor dat de deler in de functie of formule niet nul is of een lege cel.

  • Laat de celverwijzing in de formule verwijzen naar een andere cel die niet leeg is of waarvan de waarde niet nul (0) is.

  • Voer in de cel waarnaar wordt verwezen als deler in de formule de waarde #N/B in. Hierdoor verandert het resultaat van de formule in #N/B om aan te geven dat er geen waarde beschikbaar is voor de deler.

Vaak kunnen #DEEL/0!-fouten niet worden vermeden omdat uw formules wachten op uw invoer of die van andere personen. In dat geval wilt u helemaal niet dat het foutbericht verschijnt. Maak daarom gebruik van een van de methoden voor foutafhandeling om de fout te onderdrukken terwijl u op invoer wacht.

De noemer voor 0 of geen waarde evalueren

De eenvoudigste manier om het aantal #DIV-0 te onderdrukken! wordt de functie ALS gebruikt om de aanwezigheid van de noemer te evalueren. Als het een 0 of geen waarde is, wordt een 0 of geen waarde als het resultaat van de formule #DIV/0! als resultaat, anders wordt de formule berekend.

Als de formule die tot deze fout leidt bijvoorbeeld =A2/A3 is, gebruikt u =ALS(A3;A2/A3;0) om 0 als resultaat weer te geven of =ALS(A3;A2/A3;””) om een lege tekenreeks als resultaat weer te geven. U kunt er ook voor kiezen om een aangepast bericht als resultaat weer te geven, zoals dit: =ALS(A3;A2/A3;”Invoer vereist”). Met de functie QUOTIENT ziet het eerste voorbeeld er als volgt uit: =ALS(A3;QUOTIENT(A2;A3);0). Hiermee wordt aangegeven dat ALS(A3 bestaat, geef dan het resultaat van de formule weer; negeer anders het resultaat).

Voorbeelden van het oplossen #DIV/0! moeten verdwijnen.

Gebruik ALS.FOUT om de fout #DIV/0! corrigeren

U kunt deze fout ook onderdrukken door de deling binnen de functie ALS.FOUT te nesten. Als u opnieuw A2/A3 gebruikt, gebruikt u de formule =ALS.FOUT(A2/A3;0). Hiermee wordt aangegeven dat als uw formule tot een fout leidt, 0 als resultaat wordt weergegeven en dat in andere gevallen het resultaat van de formule wordt weergegeven.

In versies van Excel die ouder zijn dan Excel 2007 kunt u de methode ALS(ISFOUT()) gebruiken: =ALS(ISFOUT(A2/A3);0;A2/A3) (Zie IS-functies).

Opmerking: de methoden ALS.FOUT en ALS(ISFOUT()) zijn algemene handlers voor fouten, omdat ze alle fouten onderdrukken, niet alleen #DIV/0!. U moet ervoor zorgen dat uw formule goed werkt voordat u een foutafhandeling gaat toepassen, anders realiseert u zich mogelijk niet dat uw formule niet werkt zoals u zou verwachten.

Tip: Als foutcontrole is ingeschakeld in Excel, Afbeelding van knop klikt u naast de cel met de fout. Klik op Berekeningsstappen weergeven als deze optie beschikbaar is en selecteer de oplossing die werkt voor uw gegevens.

Hebt u een vraag over een bepaalde functie?

Stel een vraag op het forum van de Excel-community

Help ons Excel verbeteren

Hebt u suggesties voor het verbeteren van de volgende versie van Excel? Als dat het geval is, kijk dan eens naar de onderwerpen op Excel User Voice (Engelstalig).

Zie ook

ALS, functie

ALS.FOUT, functie

IS, functies

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten opsporen in formules

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×