De fout #VERW! wordt weergegeven wanneer een formule verwijst naar een cel die niet geldig is. Dit gebeurt meestal wanneer cellen zijn verwijderd waarnaar door formules wordt verwezen, of als er andere celinhoud overheen is geplakt.

Voorbeeld: #VERW!-fout veroorzaakt doordat er een kolom is verwijderd

In het volgende voorbeeld wordt de formule=SOM(B2;C2;D2) in kolom E gebruikt.

Een formule waarin naar expliciete cellen wordt verwezen zoals =SOM(B2,C2,D2) kan een fout #VERW! veroorzaken als een kolom wordt verwijderd.

Als u kolom B, C of D zou verwijderen, treedt er een #VERW!-fout op. In dit geval verwijderen we kolom C (Verkoop 2007). De formule ziet er nu als volgt uit =SOM(B2;#VERW!;C2). Wanneer u expliciete celverwijzingen zoals deze gebruikt (waarin u naar elke cel afzonderlijk verwijst, gescheiden door een komma) en vervolgens een rij of kolom verwijdert, kan Excel de formule niet toepassen, zodat de fout #VERW! optreedt. Dit is de belangrijkste reden waarom expliciete celverwijzingen in functies niet worden aanbevolen.

Voorbeeld van een fout #VERW! veroorzaakt doordat er een kolom is verwijderd

Oplossing

  • Als u rijen of kolommen per ongeluk verwijdert, kunt u direct op de knop Ongedaan maken op de werkbalk Snelle toegang klikken (of op Ctrl+Z drukken) om ze te herstellen.

  • Pas de formule zodanig aan dat deze gebruikmaakt van een verwijzing naar een cellenbereik in plaats van gebruik te maken van afzonderlijke cellen, zoals =SOM(B2:D2). Nu kunt u een kolom die in het bereik van de som voorkomt verwijderen. De formule wordt automatisch aangepast in Excel. U kunt ook =SOM(B2:B5) gebruiken voor een som rijen.

Voorbeeld: VERT.ZOEKEN met onjuiste bereikverwijzingen

In het volgende voorbeeld geeft =VERT.ZOEKEN(A8;A2:D5;5;ONWAAR) als resultaat een #VERW!-fout omdat er wordt gezocht naar een waarde uit kolom 5 die als resultaat kan worden geretourneerd, maar het bereik van de verwijzing is A:D, die uit slechts 4 kolommen bestaat.

Voorbeeld van een formule VERT.ZOEKEN met een ongeldig bereik.  Formule is =VERT.ZOEKEN(A8,A2:D5,5,ONWAAR).  Er is geen vijfde kolom in het VERT.ZOEKEN-bereik, dus 5 veroorzaakt een #VERW!- fout.

Oplossing

Maak het bereik groter of verlaag de kolomzoekwaarde zodat deze overeenkomt met het bereik van de verwijzing. =VERT.ZOEKEN(A8;A2:E5;5;ONWAAR) zou een geldig bereik kunnen zijn, evenals = VERT.ZOEKEN(A8;A2:D5;4;ONWAAR).

Voorbeeld: INDEX met onjuiste verwijzing voor rijen of kolommen

In dit voorbeeld geeft de formule =INDEX(B2:E5;5;5) een #VERW!-fout als resultaat omdat het bereik van de INDEX uit 4 rijen bij 4 kolommen bestaat, maar de formule vereist dat er een waarde wordt geretourneerd die zich in de vijfde rij en de vijfde kolom bevindt.

Voorbeeld van een INDEX-formule met een verwijzing naar een ongeldig bereik.  Formule is =INDEX(B2:E5,5,5) maar het bereik is alleen 4 rijen bij 4 kolommen.

Oplossing

Pas de verwijzingen naar de rij of kolom aan zodat ze in het opzoekbereik INDEX vallen. =INDEX(B2:E5;4;4) zou een geldig resultaat opleveren.

Voorbeeld: naar een gesloten werkmap verwijzen met INDIRECT

In het volgende voorbeeld verwijst een INDIRECT-functie naar een werkmap die gesloten is en zo een #VERW!-fout veroorzaakt.

Voorbeeld van een fout #VERW! veroorzaakt omdat INDIRECT verwijst naar een gesloten werkmap.

Oplossing

Open de werkmap waarnaar wordt verwezen. Dezelfde fout treedt op als u naar een gesloten werkmap verwijst met een dynamische matrixfunctie.

OLE-problemen

Als u een OLE-koppeling (Object Linking and Embedding) hebt gebruikt die een #VERW!-fout veroorzaakt, moet u het programma starten dat door de koppeling wordt aangeroepen.

Opmerking: OLE is een technologie die u kunt gebruiken om gegevens tussen programma's te delen.

DDE-problemen

Als u een DDE-onderwerp (Dynamic Data Exchange) hebt gebruikt dat een #VERW!-fout veroorzaakt, moet u controleren of u naar het juiste onderwerp verwijst. Als er nog steeds een #VERW!-fout optreedt, controleert u de Instellingen voor het Vertrouwenscentrum op externe inhoud, zoals beschreven in Externe inhoud in Office-documenten blokkeren of deblokkeren.

Opmerking: Dynamic Data Exchange (DDE)is een gangbaar protocol voor de uitwisseling van gegevens tussen Microsoft Windows-programma's.

Problemen met macro 's

Als met een macro een functie wordt toegevoegd aan het werkblad die naar een cel boven de functie verwijst en de cel met de functie in rij 1 staat, geeft de functie de fout #VERW! als resultaat omdat boven rij 1 geen cellen staan. Controleer of de functie een argument bevat dat verwijst naar een ongeldige cel of een ongeldig cellenbereik. Wellicht moet de macro dan in VBE (Visual Basic Editor) worden bewerkt, zodat er met deze situatie rekening wordt gehouden.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Zie ook

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten opsporen in formules

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft Office Insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de taalkwaliteit?
Wat heeft uw ervaring beïnvloed?

Bedankt voor uw feedback.

×