Een fout #VERW! corrigeren

Een fout #VERW! corrigeren

De fout #VERW! wordt weergegeven wanneer een formule verwijst naar een cel die niet geldig is. Dit gebeurt meestal wanneer cellen zijn verwijderd waarnaar door formules wordt verwezen, of als er andere celinhoud overheen is geplakt.

Voorbeeld: #REF! als gevolg van het verwijderen van een kolom

In het volgende voorbeeld wordt de formule=SOM(B2;C2;D2) in kolom E gebruikt.

Een formule waarin naar expliciete cellen wordt verwezen zoals =SOM(B2,C2,D2) kan een fout #VERW! veroorzaken als een kolom wordt verwijderd.

Als u kolom B, C of D zou verwijderen, treedt er een #VERW!-fout op. In dit geval verwijderen we kolom C (Verkoop 2007). De formule ziet er nu als volgt uit =SOM(B2;#VERW!;C2). Wanneer u expliciete celverwijzingen zoals deze gebruikt (waarin u naar elke cel afzonderlijk verwijst, gescheiden door een komma) en vervolgens een rij of kolom verwijdert, kan Excel de formule niet toepassen, zodat de fout #VERW! optreedt. Dit is de belangrijkste reden waarom expliciete celverwijzingen in functies niet worden aanbevolen.

Voorbeeld van een fout #VERW! veroorzaakt doordat er een kolom is verwijderd

Oplossing

  • Als u rijen of kolommen per ongeluk verwijdert, kunt u direct op de knop Ongedaan maken op de werkbalk Snelle toegang klikken (of op Ctrl+Z drukken) om ze te herstellen.

  • Pas de formule zo aan dat in plaats van afzonderlijke cellen een bereikverwijzing wordt gebruikt, zoals =SOM(B2:D2). U kunt nu elke kolom in het sombereik verwijderen en de formule wordt automatisch aangepast. U kunt =SOM(B2:B5) ook gebruiken voor een som rijen.

Voorbeeld: VERT.ZOEKEN met onjuiste bereikverwijzingen

In het volgende voorbeeld wordt met =VERT.ZOEKEN(A8;A2:D5;5;ONWAAR) een #REF! wordt weergegeven omdat er wordt gezocht naar een waarde die kan worden retourneert uit kolom 5, maar het bereik van de verwijzing is A:D, wat uit slechts 4 kolommen bestaat.

Voorbeeld van een formule VERT.ZOEKEN met een onjuist bereik.  Formule is =VERT.ZOEKEN(A8;A2:D5;5;ONWAAR).  Er is geen vijfde kolom in het bereik VERT.ZOEKEN dus 5 veroorzaakt een #REF! weergegeven.

Oplossing

Maak het bereik groter of verlaag de kolomzoekwaarde zodat deze overeenkomt met het bereik van de verwijzing. =VERT.ZOEKEN(A8;A2:E5;5;ONWAAR) zou een geldig bereik kunnen zijn, evenals = VERT.ZOEKEN(A8;A2:D5;4;ONWAAR).

Voorbeeld: INDEX met onjuiste verwijzing voor rijen of kolommen

In dit voorbeeld retourneert de formule =INDEX(B2:E5;5;5) een #REF! omdat het bereik VAN DE INDEX 4 rijen bij 4 kolommen is, maar de formule vraagt om te retourneren wat zich in de vijfde rij en de vijfde kolom.

Voorbeeld van een INDEX-formule met een verwijzing naar een ongeldig bereik.  Formule is =INDEX(B2:E5,5,5) maar het bereik is alleen 4 rijen bij 4 kolommen.

Oplossing

Pas de verwijzingen naar de rij of kolom aan zodat ze in het opzoekbereik INDEX vallen. =INDEX(B2:E5;4;4) zou een geldig resultaat opleveren.

Voorbeeld: naar een gesloten werkmap verwijzen met INDIRECT

In het volgende voorbeeld probeert een INDIRECT-functie te verwijzen naar een werkmap die gesloten is, waardoor een #REF! weergegeven.

Voorbeeld van een fout #VERW! veroorzaakt omdat INDIRECT verwijst naar een gesloten werkmap.

Oplossing

Open de werkmap waarnaar wordt verwezen. U krijgt dezelfde fout als u verwijst naar een gesloten werkmap met een dynamische matrixfunctie.

OLE-problemen

Als u een OLE-koppeling (Object Linking and Embedding) hebt gebruikt waarmee een OLE-koppeling (Object Linking and Embedding) wordt #REF! en start u het programma dat door de koppeling wordt aanroept.

Opmerking: OLE is een technologie die u kunt gebruiken om gegevens tussen programma's te delen.

DDE-problemen

Als u een DDE-onderwerp (Dynamic Data Exchange) hebt gebruikt dat een terugkerende #REF! controleert u eerst of u naar het juiste onderwerp verwijst. Als u nog steeds een e-#REF. controleert u de instellingen voor externe inhoud in het Vertrouwenscentrum zoals beschreven in Het blokkeren of deblokkeren van externe inhoud in Office-documenten.

Opmerking: DDE (Dynamic Data Exchange)is een vastgelegd protocol voor de uitwisseling van gegevens tussen Microsoft Windows-programma's.

Problemen met macro 's

Als met een macro een functie wordt toegevoegd aan het werkblad die naar een cel boven de functie verwijst en de cel met de functie in rij 1 staat, geeft de functie de fout #VERW! als resultaat omdat boven rij 1 geen cellen staan. Controleer of de functie een argument bevat dat verwijst naar een ongeldige cel of een ongeldig cellenbereik. Wellicht moet de macro dan in VBE (Visual Basic Editor) worden bewerkt, zodat er met deze situatie rekening wordt gehouden.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten opsporen in formules

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×