Matrixconstanten gebruiken in matrixformules

Wanneer u een matrixformule invoert, gebruikt u meestal een bereik van cellen in het werkblad, maar u hoeft dit niet zelf te doen. U kunt ook matrixconstantengebruiken, waarden die u net in de formulebalk typt, in accolades: {}. Vervolgens kunt u uw constante een naam geven zodat u deze eenvoudiger opnieuw kunt gebruiken.

U kunt constanten gebruiken in de matrixformules of afzonderlijk.

  1. Typ in de matrixformule een openingsaccolade, de gewenste waarden en een haakje sluiten. Hier ziet u een voorbeeld: = som (a1: E1 * {1, 2, 3, 4, 5})

    De constante bevindt zich tussen de accolades ({)} en ja, u kunt deze accolades handmatig typen.

  2. Voer de rest van de formule in en druk op CTRL + SHIFT + ENTER.

    De formule ziet er ongeveer zo uit: {= Sum (a1: E1 * {1, 2, 3, 4, 5})}en de resultaten zien er zo uit:


    Een matrixconstante die is genest in een formule SOM

    In de formule wordt a1 vermenigvuldigd met 1 en B1 met 2 enzovoort, zodat u niet 1, 2, 3, 4, 5 hoeft in te stellen op de cellen in het werkblad.

Met een constante waarden invoeren in een kolom

Als u waarden wilt invoeren in één kolom, zoals drie cellen in kolom C:

  1. Selecteer de cellen die u wilt gebruiken.

  2. Voer een gelijkteken en de constante in. Scheid de waarden in de constante met puntkomma's, geen komma's, en als u tekst invoert, moet u de waarde tussen dubbele aanhalingstekens plaatsen. Bijvoorbeeld: = {"Quarter 1"; " Quarter2";" Kwartaal 3 "}

  3. Druk op Ctrl+Shift+Enter. De constante ziet er als volgt uit:

    Een verticale matrixconstante waarin tekst wordt gebruikt

    In de Geek kunt-voorwaarden is dit een eendimensionale verticale constante.

Met een constante waarden invoeren in een rij

Als u snel waarden wilt invoeren in één rij, zoals de cellen F1, G1 en H1, doet u het volgende:

  1. Selecteer de cellen die u wilt gebruiken.

  2. Voer een gelijkteken en de constante in, maar u kunt deze keer de waarden scheiden met komma's, geen puntkomma's. Bijvoorbeeld: = {1, 2, 3, 4, 5}

  3. Druk op CTRL + SHIFT + ENTER en de constante ziet er als volgt uit:

    Een eendimensionale horizontale matrixconstante

    In Geek kunt-voorwaarden is dit een eendimensionale horizontale constante.

Met een constante waarden invoeren in meerdere kolommen en rijen

  1. Selecteer de gewenste cellen.

    Controleer of u het aantal rijen en kolommen selecteert dat overeenkomt met het aantal waarden in de constante. Als de constante bijvoorbeeld gegevens naar vier kolommen en drie rijen schrijft, selecteert u het aantal kolommen en rijen.

  2. Voer een gelijkteken en de constante in. In dit geval scheidt u de waarden in elke rij met komma's en gebruikt u een puntkomma aan het einde van elke rij. Bijvoorbeeld:

    ={1,2,3,4;5,6,7,8;9,10,11,12}

  3. Druk op CTRL + SHIFT + ENTER, en:

    Een tweedimensionale matrixconstante

    In de Geek kunt-voorwaarden is dit een tweedimensionale constante, omdat er kolommen en rijen worden opgevuld. Als u zich afvraagt, kunt u geen driedimensionale constante maken, wat betekent dat u geen constante binnen een andere constante kunt nesten.

Een constante gebruiken in een formule

Nu u bekend bent met matrixconstanten, vindt u hier een voorbeeld van het werk.

  • Voer deze formule in een lege cel in (of kopieer en plak de formule) en druk op CTRL + SHIFT + ENTER:

    =SOM(A1:E1*{1,2,3,4,5})

    De waarde 85 wordt weergegeven in cel A3.

    Wat is er gebeurd? U vermenigvuldigt de waarde in a1 met 1, de waarde in cel B2 met 2 enzovoort, en de functie som heeft deze resultaten toegevoegd. U kunt de formule ook opgeven met = som (a1 * 1, B1 * 2, C1 * 3, D1 * 4, E1 * 5)

U kunt desgewenst beide sets waarden invoeren als matrixconstanten:

=SOM({3,4,5,6,7}*{1,2,3,4,5})

Als u dit wilt doen, kopieert u de formule, selecteert u een lege cel en plakt u de formule in de formulebalk, en drukt u vervolgens op CTRL + SHIFT + ENTER. U ziet het resultaat.

Notities: Let op de volgende problemen als de constanten niet werken:

  • Zorg dat u de waarden met het juiste karakter scheidt. Als u een komma of puntkomma weglaat, of als u er een wilt toevoegen, is de matrixconstante mogelijk niet naar rechts of wordt er een waarschuwing weergegeven.

  • U hebt mogelijk een celbereik geselecteerd dat niet overeenkomt met het aantal elementen in de constante. Als u bijvoorbeeld een kolom van zes cellen selecteert voor gebruik met een constante van vijf cellen, wordt de #N/A-fout weergegeven in de lege cel. Als u niet voldoende cellen selecteert, worden de waarden die geen corresponderende cel bevatten, weggelaten in Excel.

  • Meer informatie over matrixformules:

Naar boven

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×