Operatoren geven het type berekening op dat u wilt uitvoeren op elementen in een formule, zoals optellen, aftrekken, vermenigvuldigen of deling. In dit artikel leert u de standaardorder waarin operatoren de elementen in een berekening uitvoeren. U leert ook hoe u deze volgorde kunt wijzigen met haakjes.

Typen operatoren

Er zijn vier typen operatoren voor berekeningen: rekenkundige operatoren, vergelijkingsoperatoren, samenvoegingsoperatoren en verwijzingsoperatoren.

Als u wiskundige basisbewerkingen wilt uitvoeren, zoals optellen, aftrekken of vermenigvuldigen of getallen wilt combineren, en numerieke resultaten wilt produceren, gebruikt u de rekenkundige operatoren in deze tabel.

Rekenkundige operator

Betekenis

Voorbeeld

+ (plusteken)

Optellen

=3+3

- (minteken)

Aftrekken
Negation

=3–1
=–1

* (sterretje)

Vermenigvuldigen

=3*3

/ (slash)

Delen

=3/3

% (procentteken)

Percentage

=20%

^ (accent circonflexe)

Machtsverheffen

=

Met de operatoren in de onderstaande tabel kunt u twee waarden vergelijken. Wanneer twee waarden worden vergeleken met behulp van deze operatoren, is het resultaat een logische waarde waar of ONWAAR.

Vergelijkingsoperator

Betekenis

Voorbeeld

= (gelijkteken)

Gelijk aan

=A1=B1

> (groter dan)

Groter dan

=A1>B1

< (kleiner dan)

Kleiner dan

=A1<B1

>= (groter dan of gelijk aan)

Groter dan of gelijk aan

=A1>=B1

<= (kleiner dan of gelijk aan)

Kleiner dan of gelijk aan

=A1<=B1

<> (niet gelijk aan)

Niet gelijk aan

=A1<>B1

Gebruik het ampersand (&) om een of meer tekenreeksen te samenvoegen of samen tevoegen om één stuk tekst te maken.

Tekstoperator

Betekenis

Voorbeeld

& (en-teken)

Er worden twee waarden met elkaar verbonden of samenvoegd om één doorlopende tekstwaarde te produceren.

="North"&"wind"

Combineer celbereiken voor berekeningen met deze operatoren.

Verwijzingsoperator

Betekenis

Voorbeeld

: (dubbele punt)

De bereikoperator, waarmee één celverwijzing naar alle cellen tussen twee verwijzingen wordt gemaakt, inclusief de twee verwijzingen.

=SOM(B5:B15)

, (komma)

Operator Union, die meerdere verwijzingen in één verwijzing combineert.

=SOM(B5:B15,D5:D15)

(spatie)

Snijpuntoperator, waarmee een verwijzing wordt geproduceerd naar cellen die gemeenschappelijk zijn voor de twee verwijzingen.

=SOM(B7:D7 C6:C8)

# (pond)

Het symbool # wordt in verschillende contexten gebruikt:

  • Gebruikt als onderdeel van een foutnaam.

  • Wordt gebruikt om aan te geven dat er onvoldoende ruimte is om weer te geven. In de meeste gevallen kunt u de kolom breder maken totdat de inhoud correct wordt weergegeven.

  • Gemorst bereikoperator, die wordt gebruikt om te verwijzen naar een volledig bereik in een dynamische matrixformule.

  • De fout #WAARDE!

  • #####

  • =SOM(A2#)

@ (bij)

Verwijzingsoperator, die wordt gebruikt om impliciet snijpunt in een formule aan te geven. 

=@A1:A10

=SOM(Tabel1[@[Januari]:[December]])

De volgorde waarin bewerkingen in formules door Excel worden uitgevoerd

In sommige gevallen kan de volgorde waarin de berekening wordt uitgevoerd van invloed zijn op de retourwaarde van de formule, dus is het belangrijk om de volgorde te begrijpen en hoe u de volgorde kunt wijzigen om de resultaten te verkrijgen die u verwacht te zien.

Met formules worden waarden altijd in een bepaalde volgorde berekend. Een formule in Excel begint altijd met het gelijkteken (=). Het gelijkteken geeft Excel dat de tekens die volgen een formule vormen. Na dit gelijkteken kan er een reeks elementen worden berekend (de operanden), die worden gescheiden door berekeningsoperatoren. In Excel wordt een formule van links naar rechts berekend, op basis van een bepaalde volgorde voor elke operator in de formule.

Als u diverse operatoren in een formule combineert, worden de bewerkingen in Excel uitgevoerd in de volgorde van de volgende tabel. Als een formule operatoren met dezelfde prioriteit bevat (bijvoorbeeld een formule met zowel een vermenigvuldigingsoperator als een deeloperator), worden de operatoren van links naar rechts geëvalueerd.

Operator

Description

: (dubbele punt)

(één spatie)

, (komma)

Verwijzingsoperatoren

Negatief maken (bijvoorbeeld -1)

%

Percentage berekenen

^

Machtsverheffen

* en /

Vermenigvuldigen en delen

+ en -

Optellen en aftrekken

&

Twee tekenreeksen aan elkaar koppelen

=
< >
<=
>=
<>

Vergelijken

Als u de evaluatievolgorde wilt wijzigen, plaatst u het deel van de formule dat u als eerste wilt berekenen, tussen haakjes. De volgende formule resulteert bijvoorbeeld in de waarde 11, omdat Excel vermenigvuldiging berekent vóór optelling. De formule vermenigvuldigt eerst 2 met 3 en voegt vervolgens 5 toe aan het resultaat.

=5+2*3

Als u haakjes gebruikt om de syntaxis te wijzigen, worden Excel 5 en 2 bij elkaar toegevoegd en wordt het resultaat vervolgens vermenigvuldigd met 3 om 21 te produceren.

=(5+2)*3

In het onderstaande voorbeeld dwingen de haakjes die het eerste deel van de formule omsluiten dat Excel eerst B4+25 moet berekenen en deelt u het resultaat vervolgens door de som van de waarden in de cellen D5, E5 en F5.

=(B4+25)/SOM(D5:F5)

Bekijk deze video over operatororder in Excel voor meer informatie.

Hoe Excel in formules converteert

Wanneer u een formule in typt, Excel u specifieke typen waarden voor elke operator. Als u een ander type waarde in typt dan verwacht, Excel u de waarde mogelijk converteren.

De formule

Produceert

Uitleg

= "1"+"2"

3

Wanneer u een plusteken (+) gebruikt, worden Excel getallen in de formule verwacht. Hoewel de aanhalingstekens betekenen dat '1' en '2' tekstwaarden zijn, worden Excel tekstwaarden automatisch ge converteert naar getallen.

= 1+"$4,00"

5

Wanneer een formule een getal verwacht, Excel tekst converteren als deze in een notatie is die gewoonlijk voor een getal wordt geaccepteerd.

= "1-6-2001"-"5-1-2001"

31

Excel interpreteert de tekst als een datum in de notatie mm/dd/yyyy, converteert de datums naar seriële getallen en berekent vervolgens het verschil tussen de datums.

=SQRT ("8+1")

De fout #WAARDE!

Excel kan de tekst niet converteren naar een getal omdat de tekst '8+1' niet kan worden geconverteerd naar een getal. U kunt '9' of '8'+'1' gebruiken in plaats van '8+1' om de tekst te converteren naar een getal en het resultaat van 3 te retourneren.

= "A"&WAAR

ATRUE

Wanneer tekst wordt verwacht, worden Excel getallen en logische waarden, zoals WAAR en ONWAAR, ge converteert naar tekst.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Zie ook

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de vertaalkwaliteit?

Wat heeft uw ervaring beïnvloed?

Hebt u aanvullende feedback? (Optioneel)

Bedankt voor uw feedback.

×