SOM.ALS, functie

Met de functie SOM.ALS kunt u de waarden in een bereik optellen die voldoen aan criteria die u opgeeft. Stel dat een kolom getallen bevat en u alleen de waarden die groter dan 5 zijn, wilt optellen. U kunt daarvoor de volgende formule gebruiken: =SOM.ALS(B2:B25;">5")

Impact maken met Aankondigingen

Deze video maakt deel uit van de trainingscursus getallen optellen in Excel.

Tips: 

  • Als u wilt, kunt u criteria toepassen op het ene bereik en de overeenkomende waarden in een ander bereik optellen. Met de formule =SOM.ALS(B2:B5; "John"; C2:C5) telt u alleen de waarden in het bereik C2:C5 op wanneer de overeenkomende cellen in het bereik B2:B5 gelijk zijn aan "John".

  • Zie SOMMEN.ALS, functie als u cellen wilt optellen op basis van meerdere criteria.

Belangrijk: De functie som. als retourneert onjuiste resultaten wanneer u deze gebruikt om tekenreeksen die meer dan 255 tekens of de tekenreeks #VALUE!te vergelijken.

Syntaxis

SOM.ALS(bereik;criterium;[optelbereik])

De syntaxis van de functie SOM.ALS heeft de volgende argumenten:

  • bereik   Vereist. Het cellenbereik dat u wilt evalueren per criterium. De cellen in elk bereik zijn getallen of namen, matrices of verwijzingen die getallen bevatten. Lege waarden en tekstwaarden worden genegeerd. Het geselecteerde bereik kan datums in standaard Excel-indeling bevatten (zie hieronder voor voorbeelden).

  • criterium   Vereist. Het criterium in de vorm van een getal, expressie, celverwijzing, tekst of functie op basis waarvan wordt bepaald welke cellen worden opgeteld. U kunt jokertekens opnemen: een vraagteken (?) voor één willekeurig teken, een sterretje (*), zodat het overeenkomt met een willekeurige reeks tekens. Als u echt een vraagteken of een sterretje wilt zoeken, moet u een tilde (~) voor dat teken typen.

    U kunt criteria bijvoorbeeld weergegeven als 32, ">32", B5, "3?", "Apple *", "* ~?" of vandaag ().

    Belangrijk: Een tekstcriterium of een ander criterium dat logische of wiskundige symbolen bevat, moet tussen dubbele aanhalingstekens staan ("). Als het criterium numeriek is, zijn geen dubbele aanhalingstekens vereist.

  • optelbereik   Optioneel. De cellen die u wilt optellen als u andere cellen wilt optellen dan de cellen die in het argument bereik zijn opgegeven. Als u het argument optelbereik weglaat, worden de cellen opgeteld die in het argument bereik zijn weergegeven (dezelfde cellen waarop het criterium wordt toegepast).

    Sum_range moet dezelfde grootte en vorm hebben als een bereik. Als dit niet het geval is, kan dit tot gevolg hebben dat de prestaties een bereik van cellen opleveren die beginnen met de eerste cel in sum_range , maar dezelfde afmetingen heeft als het bereik. Bijvoorbeeld:

    bereik

    optelbereik

    Werkelijke opgetelde cellen

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1: K5

    B1:B5

Voorbeelden

Voorbeeld 1

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. Om resultaten van formules weer te geven, selecteert u deze, drukt u op F2 en drukt u vervolgens op Enter. Indien nodig kunt u de kolombreedten aanpassen als u alle gegevens wilt zien.

Waarde onroerend goed

Commissie

Gegevens

€ 100.000

€ 7.000

€ 250.000

€ 200.000

€ 14.000

€ 300.000

€ 21.000

€ 400.000

€ 28.000

Formule

Beschrijving

Resultaat

=SOM.ALS(A2:A5;">160000";B2:B5)

De som van de commissies voor onroerend goed met een waarde boven € 160.000

€ 63.000

=SOM.ALS(A2:A5;">160000")

De som van onroerend goed met een waarde boven € 160.000

€ 900.000

=SOM.ALS(A2:A5;300000;B2:B5)

De som van de commissies voor onroerend goed met een waarde die gelijk is aan € 300.000

€ 21.000

=SOM.ALS(A2:A5;">" & C2;B2:B5)

De som van de commissies voor onroerend goed met een waarde die groter is dan de waarde in C2.

€ 49.000

Voorbeeld 2

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. Om resultaten van formules weer te geven, selecteert u deze, drukt u op F2 en drukt u vervolgens op Enter. Desgewenst kunt u de kolombreedte wijzigen om alle gegevens te zien.

Categorie

Eten

Verkoop

Groenten

Tomaten

€ 2.300

Groenten

Selderie

€ 5.500

Fruit

Sinaasappelen

€ 800

Boter

$ 400

Groenten

Wortels

€ 4.200

Fruit

Appels

€ 1,200

Formule

Beschrijving

Resultaat

=SOM.ALS(A2:A7;"Fruit";C2:C7)

De som van de omzet van al het eten in de categorie "Fruit".

$ 2.000

=SOM.ALS(A2:A7;"Groenten";C2:C7)

De som van de omzet van al het eten in de categorie "Groenten".

€ 12.000

=SOM.ALS(B2:B7;"*en";C2:C7)

De som van al het eten dat eindigt op "en" (Tomaten en Sinaasappelen).

€ 4.300

=SOM.ALS(A2:A7;"";C2:C7)

De som van de omzet van al het eten waarvoor geen categorie is opgegeven.

$ 400

Naar boven

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Met de functie SOMMEN.ALS worden alle waarden opgeteld die voldoen aan meerdere criteria

Met de functie KWADRATENSOM worden meerdere waarden opgeteld nadat een wiskundige kwadraatsbewerking op elke waarde is uitgevoerd

Met de functie AANTAL.ALS worden alleen de waarden opgeteld die voldoen aan één criterium

Met de functie AANTALLEN.ALS worden alleen de waarden opgeteld die voldoen aan meerdere criteria

ALS.VOORWAARDEN, functie (Office 365, Excel 2016 en later)

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten opsporen in formules

Wiskundige en trigonometrische functies

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Opmerking:  Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor je is. Wil je ons laten weten of deze informatie nuttig is? Hier is het Engelstalige artikel ter referentie.

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×