Symptoom
De gebruikers voeren een bureaubladstroom uit in de modus Onbeheerd en de uitvoering mislukt omdat de juiste elementen van de gebruikersinterface niet kunnen worden gevonden. Foutschermafbeeldingen laten zien dat de schermresolutie tijdens de run time verschilt van de schermresolutie die wordt gebruikt bij het maken van de bureaubladstroom.
Oorzaak
Sommige Windows of VM's kunnen standaard een kleinere schermresolutie hebben bij het uitvoeren van onbeheerde bureaubladstromen. Als de geautomatiseerde toepassingen gevoelig zijn voor de schermresolutie of als u op afbeeldingen gebaseerde automatisering gebruikt, kan dit leiden tot een fout in de bureaubladstroom.
Oplossing
Stel de standaardresolutie in het UIFlowService.exe.config in:
-
Ga naar 'C:\Program Files (x86)\Power Automate Desktop'
-
Een UIFlowService.exe.config in een teksteditor openen
-
Stel microsoft in. Flow. RPA. UIFlowService.ScreenDefaultResolutionEnabled to true
-
Pas de standaardschermresolutie aan door de eigenschappen Breedte en Hoogte in te stellen:
<!-- Screen resolution settings -->
<add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionEnabled" value="true" />
<add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionWidth" value="1920" />
<add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionHeight" value="1080" />
<add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionScale" value="100" />
-
Ga naar Menu start > Services, zoek de 'Power Automate-service' (in oudere versies wordt dit de 'UIFlowService' genoemd en de procesnaam is UIFlowService.exe als u Taakbeheer wilt gebruiken). Start deze service opnieuw door met de rechtermuisknop op 'Opnieuw starten' te klikken en te klikken. Of als u wilt, kunt u uw computer gewoon opnieuw opstarten.