Symptomen
In Commerce Server 2009 R2 Service Pack 1 (SP1), kunt u de catalogus exporteren Staging-expressie in de catalogus Staging-opties configureren. Echter wanneer de optie Alle niveaus geselecteerd is, werkt de afstammelingen van de Filter-component niet zoals verwacht.
Oorzaak
Dit probleem treedt op tijdens de opgeslagen procedure (ctlg_StoreFilteredCatalogItemsToExport). Dit proces doorloopt naar de structuur van de catalogus te zoeken en toevoegen van onderliggende objecten voor het exporteren. Tijdens de laatste ronde wanneer de procedure probeert toe te voegen back productfamilies ontbreekt, wordt de filtercomponent niet gebruikt.
Oplossing
U lost dit probleem, kunt u de volgende hotfix toepassen.installatie-instructies om de installatie van deze hotfix.
Zie het gedeelte metInformatie over de hotfix
Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing voor het in dit artikel beschreven probleem. Voer deze hotfix alleen uit op systemen waarop de in dit artikel beschreven problemen zich voordoen. Deze hotfix moet wellicht extra worden getest. Als u geen ernstige hinder ondervindt van dit probleem, is het daarom raadzaam te wachten op de volgende update waarin deze hotfix is opgenomen.
Als de hotfix gedownload kan worden, is er een sectie 'Hotfix downloaden' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, neem dan contact op met Microsoft Customer Service and Support om de hotfix te verkrijgen. Opmerking Als er andere problemen optreden of als probleemoplossing is vereist, moet u wellicht een apart serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen en problemen die niet in aanmerking komen voor deze specifieke hotfix. Voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of om een afzonderlijk serviceverzoek aan te maken, gaat u naar de volgende Microsoft-website:http://support.microsoft.com/contactus/?ws=supportOpmerking Het formulier 'Hotfix kan worden gedownload' geeft de talen weer waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is dit omdat een hotfix niet voor die taal beschikbaar is.
Vereisten
Deze hotfix moet u Service Pack 1 voor Commerce Server 2009 R2 is geïnstalleerd.
Installatie-instructies
Uitvoeren om de installatie van deze hotfix, het bestand Kb2931431.sql op alle bestaande databases in de catalogus.
Opstartinformatie
U hoeft de computer niet opnieuw op te starten nadat u deze hotfix hebt toegepast.
Informatie over vervanging
Deze hotfix vervangt geen eerder uitgebrachte hotfix.
Bestandsinformatie
De Engelse versie van deze hotfix heeft de bestandskenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Om het verschil tussen UTC en lokale tijd op te zoeken, gebruikt u het tabblad tijdzone in het onderdeel datum en tijd in het Configuratiescherm.
Bestandsnaam |
Bestandsversie |
Bestandsgrootte |
Datum |
Tijd |
Platform |
---|---|---|---|---|---|
Catalogcreate.sql |
Niet van toepassing |
1,166,263 |
25-Feb-2014 |
12:33 |
Niet van toepassing |
Kb2931431.sql |
Niet van toepassing |
8,680 |
04-Feb-2014 |
13:20 |
Niet van toepassing |
Opmerking Vanwege bestandsafhankelijkheden kan de meest recente oplossing waarin deze bestanden ook extra bestanden bevatten.
Status
Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.
Referenties
Meer informatie over de terminologie die door Microsoft wordt gebruikt om softwareupdates te beschrijven.