Symptomen
U ontvangt het volgende foutbericht in Business Portal voor Microsoft Dynamics GP:
Serverfout in '/' Toepassing.
Kan de sessietoestand niet serieel maken. In de modus StateServer en SQLServer worden ASP.NET de sessietoestandobjecten serieel gemaakt, waardoor niet-seriële objecten of MaarschalkByRef-objecten niet zijn toegestaan. Dezelfde beperking is van toepassing als vergelijkbare serialisatie wordt uitgevoerd door de aangepaste sessiestaat in de modus 'Aangepast'.
Dit probleem treedt op als een van de volgende voorwaarden waar is:
-
U klikt om het selectievakje Start-/stoptijden vereisen in te stellen in de Self Service Suite voor human resources management in business portal.
-
U kunt een rooster opslaan in Project Tijd & Kosten voor Microsoft Dynamics GP.
-
U maakt een nieuwe requisition in Requisition Management voor Microsoft Dynamics GP.
Oorzaak
Dit probleem treedt op omdat een andere toepassing de <sessiestate-modus> element in het Web.config bestand.
Oplossing
Als u dit probleem wilt oplossen, wijzigt u de <sessiestate-modus> element om de parameters te gebruiken die business portal nodig heeft. Ga hiervoor als volgt te werk:
-
Zoek het Web.config voor Business Portal. Dit bestand bevindt zich in de virtuele adreslijst in de map Inetpub op de server waarop Business Portal is geïnstalleerd. Dit bestand bevindt zich bijvoorbeeld op de volgende locatie:
C:\Inetpub\wwwroot\wss\VirtualDirectories\81
-
Maak een kopie van het Web.config bestand.
-
Open Kladblok of in een andere teksteditor het Web.config bestand.
-
Klik in het menu Bewerken op Zoeken.
-
Typ in het vak Zoeken naar de modus sessionState en klik vervolgens op Volgende zoeken.
-
Controleer of het <sessieState-modus> als volgt wordt weergegeven.
<sessionState mode="InProc" />
-
Als de <sessionState-modus>-element niet de kenmerkwaarde 'InProc' gebruikt, bewerkt u het <sessionState-modus>-element om de kenmerkwaarde 'InProc' te gebruiken.
-
Sla het Web.config op.
-
Als u de wijzigingen in het Web.config wilt inschakelen, moet u de opdracht iisreset uitvoeren. Volg de volgende stappen om dit te doen:
-
Klik op de server waarop de Business Portal is geïnstalleerd op Starten klik vervolgens op Uitvoeren.
-
Typ de volgende opdracht in het vak Openen en druk op Enter:
iisreset
-