Symptomen
Overweeg het volgende scenario:
-
U hebt een server waarop Windows Server 2012 R2 of Windows Server 2008 R2 Service Pack (SP1).
-
U kunt een softwarepakket van derden uitgevoerd op de server.
-
Het softwarepakket is een multithreaded Winsock-servertoepassing.
In dit scenario wordt de server reageert niet meer af en toe en worden er een hoge niet-wisselbare pool-gebruik van de pool-tag AfdP.
Oorzaak
Dit probleem wordt veroorzaakt door een lek van niet-wisselbare pool in het stuurprogramma afd.sys. Dit lek leidt tot uitputting van niet-wisselbare pool en zorgt ervoor dat de server niet meer reageert.
Het probleem kan optreden als u één toepassingsthread een functie Winsock Selecteer geboekt op een aantal sockets terwijl een tweede toepassingsthread is verwijderen van een of meer van de sockets.
Oplossing
Dit probleem in Windows Server 2012 R2 oplossen door update 2955164 te installeren. Voor meer informatie over update 2955164, klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
Windows RT 8.1, Windows 8.1 en Windows Server 2012 R2 updatepakket: mei 2014U lost dit probleem in Windows Server 2008 R2, installeert u de hotfix die wordt beschreven in dit artikel.
Informatie over de hotfix
Een ondersteunde hotfix is beschikbaar bij Microsoft Support. Deze hotfix is echter alleen bedoeld voor het probleem dat wordt beschreven in dit artikel. Voer deze hotfix alleen uit op systemen waarop de in dit artikel beschreven problemen zich voordoen. Deze hotfix moet wellicht extra worden getest. Als u geen ernstige hinder ondervindt van dit probleem, is het daarom raadzaam te wachten op de volgende update waarin deze hotfix is opgenomen.
Als de hotfix gedownload kan worden, is er een sectie 'Hotfix downloaden' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, neem dan contact op met Microsoft Customer Service and Support om de hotfix te verkrijgen.
Opmerking Als er andere problemen optreden of als probleemoplossing is vereist, moet u wellicht een apart serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen en problemen die niet in aanmerking komen voor deze specifieke hotfix. Voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of voor het indienen van een afzonderlijk serviceverzoek, gaat u naar de volgende Microsoft-website:
Opmerking Het formulier 'Hotfix kan worden gedownload' geeft de talen weer waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is dit omdat een hotfix niet voor die taal beschikbaar is.
Vereisten
Deze hotfix moet u voor Windows 7 of Windows Server 2008 R2 is geïnstalleerd.
Opnieuw opstarten
Nadat u deze hotfix hebt geïnstalleerd, moet u de computer opnieuw opstarten.
Informatie over het vervangen van hotfixes
Deze hotfix vervangt NIET een eerder uitgebrachte hotfix.
De Engelse (Verenigde Staten) versie van deze hotfix installeert bestanden met de bestandskenmerken die in de volgende tabellen worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). De datums en tijden voor deze bestanden op uw lokale computer worden weergegeven in uw lokale tijd samen met het huidige verschil met de zomertijd (DST). Bovendien kunnen de datums en tijden veranderen wanneer u bepaalde bewerkingen op de bestanden uitvoert.
Informatie over Windows 7 en Windows Server 2008 R2 en notitiesBelangrijk Hotfixes voor Windows 7 en Windows Server 2008 R2 zijn opgenomen in dezelfde pakketten. Hotfixes op de pagina Hotfix aanvragen worden echter vermeld onder de beide besturingssystemen. Als u het pakket met hotfixes die voor een of beide besturingssystemen geldt wilt aanvragen, selecteert u de hotfix die op de pagina staat vermeld onder 'Windows 7/Windows Server 2008 R2'. Raadpleeg altijd de sectie 'Van toepassing op' in de artikelen om het besturingssysteem te bepalen waarop elke hotfix van toepassing is.
-
De bestanden die van toepassing zijn op een specifiek product, SR_Level (RTM, SPn), en een specifieke servicestructuur (LDR, GDR) kunnen worden bepaald met de versienummers van de bestanden zoals vermeld in de volgende tabel.
-
GDR-servicestructuren bevatten uitsluitend deze oplossingen die algemeen worden uitgebracht wijdverbreide zeer belangrijk om problemen te verhelpen. LDR-servicestructuren bevatten hotfixes die op grote schaal beschikbaar gestelde oplossingen aanvullen.
-
De MANIFEST-bestanden (.manifest) en MUM-bestanden (.mum) die zijn geïnstalleerd voor elke omgeving zijn apart vermeld in de sectie 'Bestandsinformatie voor Windows 7 en Windows Server 2008 R2'. MUM- en MANIFEST-bestanden- en de bijbehorende beveiligingscatalogusbestanden (.cat)-bestanden zijn zeer belangrijk voor het statusbeheer van het bijgewerkte onderdelen. De beveiligingscatalogusbestanden, waarvan de kenmerken niet worden vermeld, zijn ondertekend met een digitale handtekening van Microsoft.
Status
Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.
Referenties
Meer informatie over de die door Microsoft wordt gebruikt om softwareupdates te beschrijven.