Symptomen

Wanneer u Business Portal start, wordt u mogelijk gevraagd om een gebruikersnaam en een wachtwoord. Dit probleem treedt op in de volgende producten:

  • Business Portal in Microsoft Dynamics GP

  • Business Portal in Microsoft Business Solutions - Great Plains

  • Business Portal in Microsoft Dynamics SL

  • Business Portal in Microsoft Business Solutions - Solomon

Oorzaak

Oorzaak 1

Dit probleem kan worden veroorzaakt door de configuratie-instelling in Microsoft Internet Information Services (IIS). Zie Resolutie 1 in de sectie 'Resolutie'.

Oorzaak 2

Dit probleem kan worden veroorzaakt door de configuratie-instellingen in Microsoft Internet Explorer. Zie Resolutie 2 in de sectie 'Resolutie'.

Oorzaak 3

Dit probleem kan optreden omdat de Windows SharePoint rollen en de business portal-rollen niet correct worden gesynchroniseerd. Zie Resolutie 3 in de sectie 'Resolutie'.

Oorzaak 4

Dit probleem kan optreden als de gebruikers zijn verwijderd en opnieuw zijn toegevoegd in de Active Directory-adreslijstservice met dezelfde gebruikersnaam, kan de beveiligings-id (SID) voor de gebruiker in Active Directory verschillen van wat wordt vermeld in Windows SharePoint Services (WSS). Zie Resolutie 4 in de sectie 'Resolutie'.

Oorzaak 5

Dit probleem kan optreden omdat er een beschadigd Ntuser.dat-bestand is voor de specifieke gebruiker die het probleem ondervindt. Zie Resolutie 5 in de sectie 'Resolutie'.

Oorzaak 6

Dit probleem kan optreden omdat een bedrijfslogo is toegevoegd aan de pagina's in business portal en de gebruiker mogelijk niet de machtigingen van het NTFS-bestandssysteem heeft voor het bestand dat het logo bevat. Zie Resolutie 6 in de sectie 'Resolutie'.

Oorzaak 7

Dit probleem kan optreden als een gebruiker niet de juiste rechten heeft op de fysieke ASP.NET *.aspx-bestanden. Zie Resolutie 7 in de sectie 'Resolutie'.

Oorzaak 8

Dit probleem kan optreden als SharePoint webtoepassing Kerberos-verificatie gebruikt. Zie Resolutie 8 in de sectie 'Resolutie'.

Oplossing

Resolutie 1

Als u de configuratie-instelling in IIS wilt controleren, gaat u als volgt te werk:

  1. Meld u aan bij de server met IIS als gebruiker met lokale beheerdersmachtigingen.

  2. Klik op Start,klik op Uitvoeren,typ inetmgr en klik vervolgens op OK.

  3. Klik met de rechtermuisknop op de website waarop de Business Portal is geïnstalleerd en klik vervolgens op Eigenschappen.

  4. Klik op het tabblad Adreslijstbeveiliging.

  5. Klik in het venster Verificatie en Toegangsbeheer op Bewerken.

  6. Klik om het selectievakje Geïntegreerde Windows verificatie in te schakelen en klik vervolgens op OK.Opmerking Het selectievakje Geïntegreerde Windows verificatie moet het enige selectievakje zijn dat is ingeschakeld in dit venster. Als Basisverificatie is ingeschakeld in IIS, wordt u gevraagd u aan te melden telkens wanneer de website wordt gebruikt in die Internet Explorer-sessie. Als Digest Authentication is ingeschakeld, wordt u ook gevraagd u aan te melden telkens wanneer de website wordt gebruikt. Voor digestverificatie is echter Active Directory vereist en worden de gebruikersnaam en het wachtwoord versleuteld.

  7. Vouw de website waarop de Business Portal is geïnstalleerd uit, klik met de rechtermuisknop op de virtuele adreslijst van BusinessPortal, klik op Eigenschappen enherhaal stap 5 tot en met 7 eerder in deze sectie.

Resolutie 2

Als u de configuratie-instellingen in Internet Explorer wilt controleren, gaat u als volgt te werk:

  1. Bepaal in Internet Explorer of Business Portal de zone Lokaal intranet of de zone Vertrouwde sites gebruikt. Als u dit wilt doen, start u Business Portal en noteer vervolgens welke zone wordt weergegeven in de rechterbenedenhoek van het venster Internet Explorer voor de business portalsite.

  2. Klik op Extra,klik op Internetoptiesen klik vervolgens op het tabblad Beveiliging.

  3. Afhankelijk van welke zone Business Portal wordt gebruikt, klikt u op Lokaal intranet of Vertrouwde sitesen klikt u vervolgens op Aangepast niveau.Opmerking Raadpleeg stap 1 eerder in deze sectie om te bepalen welke zone Business Portal gebruikt.

  4. Zorg ervoor dat alle ActiveX zijn ingesteld op Ingeschakeld.

  5. Controleer in de sectie Gebruikersverificatie of het selectievakje Automatische aanmelding met huidige gebruikersnaam en wachtwoord is ingeschakeld.

  6. Als u onjuiste wachtwoorden uit de cache wilt wissen, gebruikt u de juiste stap:

    • Als u een Windows Internet Explorer 7 gebruikt, klikt u op het tabblad Algemeen, klikt u op Verwijderen enklikt u vervolgens op Wachtwoorden verwijderen.

    • Als u een Windows Internet Explorer 6 gebruikt, klikt u op het tabblad Inhoud, klikt u op Automatischaanvullen en klikt u vervolgens op Wachtwoorden verwijderen.

  7. Controleer of de optie Bespreken niet is ingeschakeld in Internet Explorer. Klik hiervoor op Beeld,klik op Verkennerbalken klik vervolgens op om het vinkje naast Bespreken te verwijderen.

Opmerking De Internet Explorer-instellingen moeten op elk werkstation zijn geconfigureerd voor elke gebruiker die het probleem ondervindt.

Resolutie 3

Als u dit probleem wilt oplossen, kunt u Rollensynchronisatie uitvoeren in businessportal. Ga hiervoor als volgt te werk:

  1. Start Business Portal als een gebruiker aan wie de beheerdersrol is toegewezen in business portal voor alle bedrijven.

  2. Klik op Site Instellingen, klik op Gebruikers enmachtigingen, klik op Rollen beheren enklik vervolgens op Rolsynchronisatie controleren.

  3. Klik op Allesen klik vervolgens op Controleren.

  4. Als er fouten worden gerapporteerd, klikt u op Bijwerken.

Opmerking Deze functie bestaat niet in Business Portal in Microsoft Dynamics GP 10.0 of in Business Portal in Microsoft Dynamics SL 7.0.

Resolutie 4

U kunt dit probleem oplossen door het hulpprogramma ValidateBPUser uit te voeren om de gebruiker of gebruikers met ongeldige SID's te zoeken. Ga hiervoor als volgt te werk:

  1. Download het ValidateBPUser.exe hulpprogramma. Als u het hulpprogramma ValidateBPUser.exe downloaden, gaat u naar de volgende Microsoft-website:

    https://mbs.microsoft.com/fileexchange/?fileID=8069b581-a52b-4705-90c7-0ed728fe0b9eOpmerking Download het hulpprogramma naar de computer met Business Portal.

  2. Wijzig de volgende twee parameters in het ValidateBPusers.exe.config bestand, op basis van de specifieke omgeving:

    1. WebServerRootUrl Dit is de URL die business portal host. Als u bijvoorbeeld Business Portal hebt geïnstalleerd op de standaardwebsite, wordt de URL http://IISComputerName.

    2. BusinessPortalBPSharePointRootSiteUrl Dit is de Business Portal SharePoint Site Root URL. Dit komt overeen met de parameter wssObjectModelSiteURL in het BusinessFramework.config bestand.

  3. Voer het ValidateBPUser.exe uit. Voer hiervoor de volgende stappen uit Opmerking Zorg ervoor dat u het hulpprogramma als een gebruiker van de businessportal runt die de rol BP-beheerder (alle bedrijven) heeft toegewezen. Als de gebruiker niet is toegewezen aan de bp-beheerdersrol, wordt de gebruiker gevraagd om een gebruikersnaam en een wachtwoord.

    1. Ga in een MS-DOS-venster naar de adreslijst waarin u het hulpprogramma hebt opgeslagen en typ de volgende opdracht bij de opdrachtprompt:

      validateBPUsers.exe verbose

    2. Typ afsluiten om het venster te sluiten.

  4. Het hulpprogramma werkt het BusinessPortalSharepointSIDMismatches.xml bij. Het bestand bevat alle gebruikers waarvan de SID in Active Directory niet overeenkomt met de SID in WSS. Dit bestand bevindt zich standaard in de volgende map:

    C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN

  5. Als het bestand gebruikers bevat met niet-overeenkomende SID's, neem dan contact op met technische ondersteuning voor Microsoft Dynamics.

Resolutie 5

Als u het beschadigde bestand Ntuser.dat wilt oplossen, maakt u het gebruikersprofiel opnieuw. Klik op het volgende artikelnummer om het artikel te bekijken in de Microsoft Knowledge Base voor meer informatie over het opnieuw maken van het gebruikersprofiel:

811151 Gegevens uit een beschadigd gebruikersprofiel kopiëren naar een nieuw profiel

Resolutie 6

Als u dit probleem wilt oplossen, geeft u de gebruiker NTSF-machtigingen voor volledig beheer voor het bestand met het logo. Ga hiervoor als volgt te werk:

  1. Zoek het bestand met het logo. Klik hiervoor op Site-Instellingen, klik op Algemeen Instellingenen klik vervolgens op Portallogo wijzigen.

  2. Klik met de rechtermuisknop op het bestand en klik vervolgens op Eigenschappen.

  3. Klik op het tabblad Beveiliging op Toevoegen.

  4. Typ in het gebied De objectnamen invoeren om het gebied te selecteren de naam van de gebruiker die wordt gevraagd, klik op Namen controleren enklik vervolgens op OK.

  5. Klik in het gebied Machtigingen op Toestaan voor de optie Volledig beheer en klik vervolgens op OK.

Resolutie 7

Als u dit probleem wilt oplossen, geeft u explicate rechten op alle fysieke bestanden die door de website worden gebruikt. Of als test om te controleren of de fout nog steeds optreedt, maakt u van de gebruiker een lokale beheerder op de business portal-computer.

Resolutie 8

U kunt dit probleem oplossen door NTLM-verificatie in te schakelen voor uw webtoepassing voor zakelijke portals. Volg hiervoor de volgende stappen voor de juiste versie hieronder: Sharepoint 3.0

  1. Klik op de business portalserver op Start, klik op Configuratiescherm, klik op Beheerhulpmiddelen en klik vervolgens op SharePoint 3.0 Centraal beheer.

  2. Klik op het tabblad Toepassingsbeheer.

  3. Klik onder Toepassingsbeveiliging op Verificatieproviders.

  4. Zorg ervoor dat de webtoepassing Business Portal is geselecteerd in de rechterbovenhoek.

  5. Klik op Standaard.

  6. Controleer onder IIS-Instellingen of het selectievakje Geïntegreerde Windows verificatie is ingeschakeld. Zorg er ook voor dat NTLM is geselecteerd.

  7. Klik op Opslaan.

  8. Start IIS opnieuw.

  9. Start Business Portal en controleer of het probleem zich nog steeds voordoet.

Sharepoint 2010

  1. Klik op de Business Portal-server op Start,klik op Alle programma's, klik op SharePoint 2010-productenen klik vervolgens op SharePoint 2010 Centraal beheer.

  2. Klik op Webtoepassingen beheren.

  3. Klik om de site te markeren waarin uw webtoepassing voor zakelijke portal is geïnstalleerd.

  4. Klik in de sectie Beveiliging op Verificatieprovidersen klik vervolgens op Standaard.

  5. Controleer in de sectie IIS-Instellingen of het selectievakje Geïntegreerde Windows verificatie is ingeschakeld. Zorg er ook voor dat NTLM is geselecteerd.

  6. Klik op Opslaan.

  7. Start IIS opnieuw.

  8. Start Business Portal en controleer of het probleem zich nog steeds voordoet.

Meer hulp nodig?

Meer opties?

Verken abonnementsvoordelen, blader door trainingscursussen, leer hoe u uw apparaat kunt beveiligen en meer.

Community's helpen u vragen te stellen en te beantwoorden, feedback te geven en te leren van experts met uitgebreide kennis.