Ważne
Świadczenie pomocy technicznej dla programu Microsoft InfoPath 2013 zakończyło się 14 lipca 2026 r. Zalecamy migrację istniejących formularzy i przepływów pracy programu InfoPath do obsługiwanych rozwiązań platformy Microsoft 365. Dowiedz się więcej o wycofywaniu programu InfoPath.
W tym artykule
- Opis formularzy dostępnych w trybie offline
- Tworzenie połączenia danych z bazą danych SQL do użycia w trybie offline
- Tworzenie połączenia danych z bazą danych programu Access do użytku w trybie offline
- Tworzenie połączenia danych z biblioteką dokumentów programu SharePoint do użycia w trybie offline
- Konfigurowanie dostępności danych
- Wyłączanie trybu offline
Opis formularzy dostępnych w trybie offline
Może być konieczne zaprojektowanie szablonu formularza programu Microsoft Office InfoPath, który użytkownicy mogliby wypełniać, gdy ich komputery są odłączone od sieci. Można na przykład zaprojektować szablon formularza, z którego rzeczoznawca ubezpieczeniowy może korzystać w terenie podczas badania szkody. Szablon formularza zawiera pomocnicze połączenia danych udostępniające dane do formularza z zewnętrznej bazy danych. Rzeczoznawca potrzebuje tych danych do wypełnienia formularza. Będąc jeszcze w biurze i podłączony do sieci, rzeczoznawca ubezpieczeniowy może utworzyć formularz oparty na tym szablonie, a następnie zapisać go na swoim komputerze. W terenie rzeczoznawca może otworzyć i wypełnić formularz bez konieczności podłączania go do sieci. Po powrocie do biura i ponownym połączeniu się z siecią, rzeczoznawca może złożyć formularz.
Domyślnie formularz zapisany na komputerze może działać bez połączenia sieciowego. Podczas tworzenia formularza na podstawie szablonu formularza przez użytkownika program InfoPath pobiera i przechowuje kopię tego szablonu na komputerze użytkownika. Przy każdym otwarciu przez użytkownika formularza opartego na tym szablonie program InfoPath najpierw sprawdza, czy istnieje połączenie sieciowe z komputerem. Jeśli istnieje połączenie sieciowe, program InfoPath sprawdza lokalizację, z której pobrano szablon formularza, aby ustalić, czy istnieje zaktualizowana wersja szablonu formularza. Jeśli istnieje zaktualizowana wersja, program InfoPath zaktualizuje szablon formularza na komputerze użytkownika. Jeśli połączenie sieciowe nie istnieje, program InfoPath używa wersji szablonu formularza przechowywanej na komputerze użytkownika.
Aby można było zaprojektować szablon formularza do użytku w trybie offline, musi on być przechowywany na komputerze użytkownika, a wszelkie dane wymagane przez użytkownika do wypełnienia formularza, takie jak elementy pola listy, muszą być dostępne dla użytkownika, nawet jeśli komputer nie jest połączony z siecią. Dane w tych kontrolkach są dostarczane z pomocniczego połączenia danych z zewnętrznym źródłem danych. Dane te mogą być przechowywane na komputerze użytkownika w szablonie formularza lub w specjalnej lokalizacji nazywanej pamięcią podręczną.
Po dodaniu do szablonu formularza pomocniczego połączenia danych, które umożliwia wykonanie kwerendy dotyczącej danych z zewnętrznego źródła danych, program InfoPath wysyła zapytanie do tego zewnętrznego źródła danych. Wyniki zapytania są następnie przechowywane w szablonie formularza. Podczas tworzenia nowego formularza na podstawie tego szablonu dane zapisane w szablonie formularza stają się dostępne.
Gdy formularz używa tego pomocniczego połączenia danych do aktualizowania zawartości kontrolki pola listy lub pola kombi przy użyciu najnowszych danych z zewnętrznego źródła danych, program InfoPath przechowuje wyniki tej kwerendy w specjalnej lokalizacji przechowywania, nazywanej pamięcią podręczną, o ile komputer jest połączony z siecią. Program InfoPath używa danych z tej pamięci podręcznej do dostarczania danych do tych formantów.
Aby udostępnić użytkownikom dane z pomocniczego połączenia danych nawet wtedy, gdy ich komputery nie są połączone z siecią, możesz wykonać jedną lub obie z następujących czynności:
- Zapisz dane z zewnętrznego źródła danych w szablonie formularza.
- Użyj pomocniczego połączenia danych po otwarciu formularza.
Po skonfigurowaniu pomocniczego połączenia danych do działania, gdy komputer użytkownika jest w trybie offline, można również skonfigurować szablon formularza w celu pobierania najnowszych danych z zewnętrznego źródła danych. Możesz skonfigurować szablon formularza tak, aby pobierał najnowsze dane (ograniczając dostępność danych istniejących w formularzu do określonej liczby dni), a następnie dodaj przycisk pobierania najnowszych danych.
Przechowywanie danych w szablonie formularza
Dane z pomocniczego połączenia danych można przechowywać w szablonie formularza, zaznaczając pole wyboru Zapisz kopię danych w szablonie formularza w Kreatorze połączenia danych podczas tworzenia pomocniczego połączenia danych.
Jeśli to pole wyboru zostanie zaznaczone, program InfoPath będzie pobierał dane z zewnętrznego źródła danych przy użyciu połączenia danych. Te dane są następnie przechowywane w szablonie formularza. Gdy użytkownik utworzy formularz lub otworzy istniejący formularz oparty na szablonie formularza, na komputer użytkownika jest pobierana kopia tego szablonu formularza wraz z zapisanymi danymi. Jeśli komputer użytkownika jest połączony z siecią podczas tworzenia formularza, program InfoPath pobiera dane z połączenia danych zewnętrznych za każdym razem, gdy formularz używa tego połączenia danych. Jeśli podczas tworzenia formularza użytkownik nie ma połączenia z siecią, program InfoPath korzysta z danych przechowywanych w szablonie formularza na komputerze użytkownika.
Ponieważ dane zostały pobrane podczas tworzenia połączenia danych, zewnętrzne źródło danych mogło zostać zaktualizowane zanim użytkownik utworzył formularz oparty na tym szablonie formularza. Aby użytkownicy otrzymywali najnowsze dane z zewnętrznego źródła danych, gdy tworzą nowy formularz lub otwierają istniejący formularz oparty na szablonie formularza, należy zaprojektować formularz w taki sposób, aby przy pierwszym otwarciu formularza używało pomocniczego połączenia danych.
Użyj pomocniczego połączenia danych po otwarciu formularza
Jeśli użytkownicy mają otrzymywać najnowsze dane z zewnętrznego źródła danych, a nie z danych przechowywanych w szablonie formularza, zaznacz pole wyboru Automatycznie pobieraj dane po otwarciu formularza w Kreatorze połączenia danych podczas tworzenia pomocniczego połączenia danych.
Gdy użytkownik tworzy nowy formularz, mając połączenie z siecią, program InfoPath pobiera najnowsze dane z zewnętrznego źródła danych, korzystając z tego pomocniczego połączenia danych. Te dane są przechowywane w pamięci podręcznej. Jeśli użytkownik otworzy istniejący formularz zapisany na jego komputerze, program InfoPath sprawdzi, czy komputer jest połączony z siecią. Jeśli komputer jest połączony z siecią, program InfoPath pobiera najnowsze dane z zewnętrznego źródła danych, korzystając z tego połączenia danych. Jeśli użytkownik pracuje w trybie offline, program InfoPath używa danych przechowywanych w pamięci podręcznej lub w szablonie formularza.
Uwaga
Dane pobrane z pomocniczego źródła danych są przechowywane na komputerze w postaci zwykłego tekstu. Jeśli używasz pomocniczego połączenia danych do pobierania poufnych danych z zewnętrznego źródła danych, możesz wyłączyć tę funkcję, aby chronić dane przed nieautoryzowanym użyciem w przypadku zgubienia lub kradzieży komputera. Jeśli ta funkcja zostanie wyłączona, dane będą dostępne tylko wtedy, gdy użytkownik ma połączenie z siecią.
Uzyskiwanie najnowszych danych
Jeśli zewnętrzne źródło danych jest regularnie aktualizowane, można skonfigurować szablon formularza w celu umożliwienia użytkownikom pobierania najnowszych danych za pośrednictwem pomocniczego połączenia danych. W tym celu można ograniczyć dostępność danych przechowywanych w pamięci podręcznej do określonej liczby dni, a następnie dodać przycisk umożliwiający pobieranie danych z dowolnych zewnętrznych źródeł danych przy użyciu wszystkich pomocniczych połączeń danych w formularzu. Dzięki temu użytkownicy pracują z najnowszymi danymi.
Dostępność danych z pomocniczego połączenia danych można również ograniczyć, ustawiając datę wygaśnięcia danych, jak długo dane mają być przechowywane na komputerze użytkownika.
W przypadku użycia tej opcji program InfoPath udostępnia formularzowi dane ze wszystkich pomocniczych połączeń danych tylko przez określoną liczbę dni. Po upływie tej liczby dni dane nie będą wyświetlane w formularzu. Następnie można dodać do formularza przycisk, który użytkownicy będą klikać w celu pobrania danych za pomocą określonego pomocniczego połączenia danych lub wszystkich pomocniczych połączeń danych w formularzu.
Uwaga
Nawet jeśli dane nie są dostępne dla formularza, pozostają na komputerze użytkownika po upływie ustawionej liczby dni. Dane zostaną zastąpione tylko wtedy, gdy system operacyjny użyje tego miejsca do przechowywania innego elementu.
Tworzenie połączenia danych z bazą danych SQL do użycia w trybie offline
Przed dodaniem pomocniczego połączenia danych z bazą danych programu Microsoft SQL Server do szablonu formularza należy uzyskać poniższe informacje od administratora bazy danych.
- Nazwa serwera, na którym jest przechowywana baza danych, która będzie używana z tym szablonem formularza.
- Nazwa bazy danych, która będzie używana z tym szablonem formularza.
- Uwierzytelnianie wymagane przez bazę danych. Baza danych może używać uwierzytelniania systemu Microsoft Windows lub uwierzytelniania programu SQL Server, aby określić, jak użytkownicy mogą uzyskać dostęp do bazy danych.
- Nazwa tabeli zawierającej dane, które mają zostać wysłane do formularza. Jest to tabela podstawowa. Jeśli w bazie danych ma być używana więcej niż jedna tabela, potrzebne są nazwy pozostałych tabel podrzędnych. Potrzebne są także nazwy pól w tabelach podrzędnych, które mają relacje z polami w tabeli podstawowej.
- Czy można bezpiecznie przechowywać wyniki zapytania w formularzu do użycia w trybie offline.
Po uzyskaniu tych informacji możesz użyć poniższej procedury, aby utworzyć połączenie danych z bazą danych SQL do użycia w trybie offline.
W menu Narzędzia kliknij polecenie Połączenia danych.
W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.
W Kreatorze połączenia danych kliknij pozycję Utwórz nowe połączenie, kliknij pozycję Odbierz dane, a następnie kliknij przycisk Dalej.
Na następnej stronie kreatora kliknij pozycję Baza danych (tylko program Microsoft SQL Server lub Microsoft Office Access), a następnie kliknij przycisk Dalej.
Na następnej stronie kreatora kliknij pozycję Wybierz bazę danych.
W oknie dialogowym Wybieranie źródła danych kliknij pozycję Nowe źródło.
Na liście Z jakiego rodzaju źródłem danych chcesz nawiązać połączenie kliknijpozycję Microsoft SQL Server, a następnie kliknij przycisk Dalej.
W polu Nazwa serwera wpisz nazwę serwera, na którym jest przechowywana baza danych.
W obszarze Poświadczenia logowania wykonaj jedną z następujących czynności:
- Jeśli baza danych określa, kto ma dostęp do serwera, na podstawie poświadczeń używanych w sieci systemu Microsoft Windows, kliknij opcję Użyj uwierzytelniania systemu Windows.
- Jeśli baza danych określa, kto ma dostęp do serwera, na podstawie określonej nazwy użytkownika i hasła otrzymanego od administratora bazy danych, kliknij opcję Użyj następującej nazwy użytkownika i hasła, a następnie wpisz te nazwy użytkownika i hasło w polach Nazwa użytkownika i hasło .
Kliknij przycisk Dalej.
Na następnej stronie kreatora na liście Wybierz bazę danych zawierającą dane , której chcesz użyć, kliknij bazę danych, której chcesz użyć, zaznacz pole wyboru Połącz z określoną tabelą , kliknij nazwę podstawowej tabeli, a następnie kliknij przycisk Dalej.
Na następnej stronie kreatora w polu Nazwa pliku wpisz nazwę pliku przechowującego informacje o połączeniu danych.
Aby zapisać te ustawienia, kliknij przycisk Zakończ.
Dodaj wszelkie inne tabele, których chcesz użyć w połączeniu danych kwerendy.
Jak?- Kliknij przycisk Dodaj tabelę.
- W oknie dialogowym Dodawanie tabeli lub kwerendy kliknij nazwę tabeli podrzędnej, a następnie kliknij przycisk Dalej. Program InfoPath spróbuje ustawić relacje, dopasowując nazwy pól w obu tabelach. Jeśli nie chcesz używać sugerowanej relacji, zaznacz relację, a następnie kliknij przycisk Usuń relację. Aby dodać relację, kliknij przycisk Dodaj relację. W oknie dialogowym Dodawanie relacji kliknij nazwy poszczególnych powiązanych pól w odpowiedniej kolumnie, a następnie kliknij przycisk OK.
- Kliknij przycisk Zakończ.
- Aby dodać kolejne tabele podrzędne, powtórz te kroki.
Kliknij przycisk Dalej.
Aby dane z tego pomocniczego połączenia danych były dostępne nawet wówczas, gdy komputer użytkownika nie jest połączony z siecią, zaznacz pole wyboru Zapisz kopię danych w szablonie formularza . Po zaznaczeniu tego pola wyboru program InfoPath wyśle zapytanie do zewnętrznego źródła danych i zapisze wyniki w szablonie formularza.
Uwaga
Zaznaczenie tego pola wyboru powoduje zachowanie wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, są dostępne w formularzach wypełnianych przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią. Jeśli za pomocą tego połączenia danych pobierane są poufne dane, można wyłączyć tę funkcję, aby zwiększyć ochronę danych na wypadek utraty lub kradzieży komputera.
Kliknij przycisk Dalej.
Na następnej stronie kreatora wpisz opisową nazwę tego pomocniczego połączenia danych. Sprawdź poprawność informacji w sekcji Podsumowanie . Aby umożliwić użytkownikom korzystanie z tego pomocniczego połączenia danych podczas tworzenia nowych formularzy lub otwierania istniejącego formularza opartego na tym szablonie formularza, zaznacz pole wyboru Automatycznie pobieraj dane przy otwieraniu formularza .
Tworzenie połączenia danych z bazą danych programu Access do użytku w trybie offline
Przed dodaniem pomocniczego połączenia danych z bazą danych programu Access do szablonu formularza należy uzyskać poniższe informacje od administratora bazy danych:
Nazwa i lokalizacja bazy danych.
Uwaga
Musisz także wiedzieć, czy baza danych znajduje się w lokalizacji sieciowej dostępnej dla użytkowników. Jeśli inni użytkownicy w sieci będą tworzyć formularze na podstawie tego szablonu formularza, baza danych musi znajdować się w lokalizacji sieciowej dostępnej dla użytkowników.
Jeśli szablon formularza służy tylko do wysyłania kwerendy do bazy danych, potrzebna jest nazwa tabeli zawierającej wyniki kwerendy wysyłanej do bazy danych. Ta tabela będzie podstawową tabelą podczas konfigurowania połączenia danych zapytania.
Nazwy innych tabel, z których tabela podstawowa może wymagać danych. W większości przypadków relacje pomiędzy tabelami są już ustanowione w bazie danych. Jeśli jest konieczne ustanowienie relacji między podstawową tabelą a inną tabelą, potrzebne będą powiązane nazwy pól w obu tabelach.
Po uzyskaniu tych informacji możesz użyć poniższej procedury w celu utworzenia połączenia danych z bazą danych programu Access do użytku w trybie offline.
W menu Narzędzia kliknij polecenie Połączenia danych.
W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.
W Kreatorze połączenia danych kliknij pozycję Utwórz nowe połączenie, kliknij pozycję Odbierz dane, a następnie kliknij przycisk Dalej.
Na następnej stronie kreatora kliknij pozycję Baza danych (tylko program Microsoft SQL Server lub Microsoft Office Access), a następnie kliknij przycisk Dalej.
Na następnej stronie kreatora kliknij pozycję Wybierz bazę danych.
W oknie dialogowym Wybieranie źródła danych przejdź do lokalizacji bazy danych.
Uwaga
Jeśli baza danych jest przechowywana w lokalizacji sieciowej, przejdź do ścieżki UNC tej lokalizacji. Nie przechodź do lokalizacji sieciowej za pośrednictwem zamapowanego dysku sieciowego. Jeśli używasz zamapowanego dysku sieciowego, formularze utworzone na podstawie tego szablonu formularza będą wyszukiwać bazę danych z zamapowanego dysku sieciowego. Jeśli użytkownik nie ma zamapowanego dysku sieciowego, formularz nie odnajdzie bazy danych.
Kliknij nazwę bazy danych, a następnie kliknij przycisk Otwórz.
W oknie dialogowym Wybieranie tabeli kliknij podstawową tabelę, której chcesz użyć, a następnie kliknij przycisk OK.
Na następnej stronie kreatora zaznacz pole wyboru Pokaż kolumny tabeli .
Domyślnie wszystkie pola tabeli zostaną dodane do głównego źródła danych szablonu formularza.W obszarze Struktura źródła danych wyczyść pola wyboru obok pól, które nie powinny być uwzględniane w głównym źródle danych.
Dodaj wszelkie inne tabele lub zapytania, których chcesz użyć w tym połączeniu danych.
Jak?- Kliknij przycisk Dodaj tabelę.
- W oknie dialogowym Dodawanie tabeli lub kwerendy kliknij nazwę tabeli podrzędnej, a następnie kliknij przycisk Dalej. Program InfoPath spróbuje ustawić relacje, dopasowując nazwy pól w obu tabelach. Jeśli nie chcesz używać sugerowanej relacji, zaznacz relację, a następnie kliknij przycisk Usuń relację. Aby dodać relację, kliknij przycisk Dodaj relację. W oknie dialogowym Dodawanie relacji kliknij nazwy poszczególnych powiązanych pól w odpowiedniej kolumnie, a następnie kliknij przycisk OK.
- Kliknij przycisk Zakończ.
- Aby dodać kolejne tabele podrzędne, powtórz te kroki.
Kliknij przycisk Dalej.
Aby dane z tego pomocniczego połączenia danych były dostępne nawet wtedy, gdy komputer użytkownika nie jest połączony z siecią, zaznacz pole wyboru Zapisz kopię danych w szablonie formularza . Po zaznaczeniu tego pola wyboru program InfoPath wysyła zapytanie do zewnętrznego źródła danych i zapisuje wyniki zapytania w szablonie.
Uwaga
Zaznaczenie tego pola wyboru powoduje zachowanie wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, są dostępne w formularzach wypełnianych przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią. Jeśli za pomocą tego połączenia danych pobierane są poufne dane, można wyłączyć tę funkcję, aby zwiększyć ochronę danych na wypadek utraty lub kradzieży komputera.
Kliknij przycisk Dalej.
Na następnej stronie kreatora wpisz opisową nazwę tego pomocniczego połączenia danych. Sprawdź poprawność informacji w sekcji Podsumowanie . Aby umożliwić użytkownikom korzystanie z tego pomocniczego połączenia danych podczas tworzenia nowych formularzy lub otwierania istniejącego formularza opartego na tym szablonie formularza, zaznacz pole wyboru Automatycznie pobieraj dane przy otwieraniu formularza .
Tworzenie połączenia danych z biblioteką dokumentów programu SharePoint do użycia w trybie offline
Zanim dodasz pomocnicze połączenie danych do szablonu formularza, potrzebujesz następujących informacji od administratora witryny.
- Lokalizacja witryny programu Microsoft Windows SharePoint Services i wymagane uprawnienia dostępu do niej.
- Potwierdzenie, że witryna została skonfigurowana w taki sposób, aby użytkownicy mogli uzyskiwać dostęp do danych z biblioteki dokumentów lub listy.
- Potwierdzenie, że dane z biblioteki dokumentów lub listy można przechowywać na komputerach użytkowników w trybie offline.
Po uzyskaniu tych informacji możesz użyć poniższej procedury w celu utworzenia połączenia danych z bazą danych programu Access do użytku w trybie offline.
W menu Narzędzia kliknij polecenie Połączenia danych.
W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.
W Kreatorze połączenia danych kliknij pozycję Utwórz nowe połączenie, kliknij pozycję Odbierz dane, a następnie kliknij przycisk Dalej.
Na następnej stronie kreatora kliknij pozycję Biblioteka lub lista programu SharePoint, a następnie kliknij przycisk Dalej.
Na następnej stronie kreatora wpisz adres URL witryny programu SharePoint zawierającej bibliotekę dokumentów lub listę, a następnie kliknij przycisk Dalej.
Na następnej stronie kreatora w oknie Wybierz listę lub bibliotekę kliknij listę lub bibliotekę, której chcesz użyć, a następnie kliknij przycisk Dalej.
Na następnej stronie kreatora zaznacz pola wyboru obok pól, które będą dostarczać dane do szablonu formularza. Jeśli szablon formularza zostanie opublikowany w bibliotece dokumentów i chcesz, aby formularze oparte na tym szablonie formularza pobierały metadane dotyczące formularza, zaznacz pole wyboru Dołącz dane tylko do aktywnego formularza .
Kliknij przycisk Dalej.
Aby dane z tego pomocniczego połączenia danych były dostępne nawet wtedy, gdy komputer użytkownika nie jest połączony z siecią, zaznacz pole wyboru Zapisz kopię danych w szablonie formularza . Po zaznaczeniu tego pola wyboru program InfoPath wysyła zapytanie do zewnętrznego źródła danych i zapisuje wyniki zapytania w szablonie formularza.
Uwaga
Zaznaczenie tego pola wyboru powoduje zachowanie wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, są dostępne w formularzach wypełnianych przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią. Jeśli za pomocą tego połączenia danych pobierane są poufne dane, można wyłączyć tę funkcję, aby zwiększyć ochronę danych na wypadek utraty lub kradzieży komputera.
Kliknij przycisk Dalej.
Na następnej stronie kreatora wpisz opisową nazwę tego pomocniczego połączenia danych, a następnie sprawdź, czy informacje w sekcji Podsumowanie są poprawne.
Aby umożliwić użytkownikom korzystanie z tego pomocniczego połączenia danych podczas tworzenia nowych formularzy lub otwierania istniejącego formularza opartego na tym szablonie formularza, zaznacz pole wyboru Automatycznie pobieraj dane przy otwieraniu formularza .
Konfigurowanie dostępności danych
Jeśli zewnętrzne źródło danych jest regularnie aktualizowane o nowe dane, można skonfigurować szablon formularza w taki sposób, aby wszelkie dane z pamięci podręcznej były dostępne. Te dane są dostępne dla formularzy opartych na tym szablonie formularza przez ograniczoną liczbę dni, która odpowiada harmonogramowi aktualizacji zewnętrznego źródła danych. Dzięki ograniczeniu liczby dni, przez które dane są dostępne dla formularzy opartych na tym szablonie formularza, można wymagać regularnego aktualizowania danych z zewnętrznego źródła danych przez użytkowników.
Aby zaktualizować dane, można dodać do szablonu formularza przycisk, który użytkownicy mogą klikać w celu zaktualizowania danych ze wszystkich pomocniczych połączeń danych użytych w szablonie formularza.
Uwaga
Jeśli chcesz odświeżyć połączenie danych za pomocą przycisku, poinformuj użytkowników, aby klikali ten przycisk tylko wtedy, gdy są połączeni z siecią.
Określanie liczby dni, przez które dane przechowywane w pamięci podręcznej są dostępne
To ustawienie dotyczy wszystkich pomocniczych połączeń danych w szablonie formularza.
- W menu Narzędzia kliknij polecenie Opcje formularza.
- Na liście Kategoria w oknie dialogowym Opcje formularza kliknij pozycję Offline.
- W obszarze Offline zaznacz pole wyboru Przechowuj dane zwrócone przez zapytania, aby można ich było używać w trybie offline .
- Kliknij pozycję Zapisane zapytania wygasają po upływie określonej liczby dni.
- Z listy wybierz liczbę dni, przez które dane przechowywane w pamięci podręcznej mają być dostępne dla formularza.
Dodawanie przycisku w celu odświeżenia połączenia danych
Jeśli szablon formularza zawiera wiele widoków, kliknij pozycję Nazwa widoku w menu Widok , aby przejść do widoku zawierającego kontrolkę, w którym chcesz wyświetlić dane z pomocniczego źródła danych.
Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.
Przeciągnij kontrolkę przycisku do szablonu formularza.
Kliknij dwukrotnie kontrolkę przycisku, która właśnie została dodana do szablonu formularza.
Kliknij kartę Ogólne.
Na liście Akcja kliknij pozycję Odśwież.
W polu Etykieta wpisz nazwę, która ma być wyświetlana na przycisku.
Kliknij pozycję Ustawienia.
W oknie dialogowym Odświeżanie wykonaj jedną z następujących czynności:
- Aby skonfigurować przycisk pobierania najnowszych danych za pośrednictwem tego połączenia danych, kliknij opcję Jedno pomocnicze źródło danych.
- Aby skonfigurować przycisk pobierania najnowszych danych za pośrednictwem wszystkich pomocniczych połączeń danych, kliknij opcję Wszystkie pomocnicze źródła danych.
Na liście Wybierz pomocnicze źródło danych kliknij pomocnicze źródło danych skojarzone z połączeniem danych zapytania.
Kliknij przycisk OK , aby zamknąć wszystkie otwarte okna dialogowe.
Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.
Wyłączanie trybu offline
W niektórych przypadkach można zaprojektować szablon formularza w taki sposób, aby użytkownicy mogli go wypełniać tylko wtedy, gdy mają połączenie z siecią. Jeśli na przykład szablon formularza ma połączenie danych z zewnętrznym źródłem danych zawierającym dane poufne, można go skonfigurować w taki sposób, aby pozwalał na wypełnianie formularzy tylko w stanie połączonym. Skonfigurowany w ten sposób szablon formularza pomaga chronić dane na wypadek utraty lub kradzieży komputera, ponieważ dane nie są przechowywane na komputerze użytkownika.
Aby skonfigurować szablon formularza w celu umożliwienia użytkownikom wypełniania formularza tylko wtedy, gdy ich komputer jest podłączony do sieci, wykonaj poniższe czynności.
- W menu Narzędzia kliknij polecenie Opcje formularza.
- Na liście Kategoria w oknie dialogowym Opcje formularza kliknij pozycję Offline.
- W obszarze Offline wyczyść pole wyboru Zezwalaj użytkownikom na wypełnianie tego formularza, jeśli dane są niedostępne .