W programie Microsoft Access 2010 można tworzyć bazy danych sieci Web i publikować je w witrynie programu SharePoint. Osoby odwiedzające program SharePoint mogą używać aplikacji bazy danych w przeglądarce sieci Web przy użyciu uprawnień programu SharePoint w celu określenia, kto co może zobaczyć. Możesz też rozpocząć od szablonu, aby od razu rozpocząć współpracę.

Zmienił się również interfejs użytkownika programu Access. Widok Backstage, który jest nowością w programie Access 2010, zapewnia dostęp do wszystkich poleceń, które dotyczą całej bazy danych, takich jak kompaktowanie i naprawianie, lub poleceń dostępnych w menu Plik.

W tym artykule opisano funkcje wprowadzone w Access 2010. Jeśli potrzebujesz ogólnego wprowadzenia do programu Access, zobacz artykuł Wprowadzenie do programu Access 2010.

W tym artykule

Omówienie

Jeśli masz dostęp do witryny programu SharePoint ze skonfigurowanymi usługami programu Access, możesz utworzyć bazę danych sieci Web przy użyciu Access 2010. Osoby, które mają konta w witrynie programu SharePoint, mogą korzystać z bazy danych w przeglądarce sieci Web, ale w celu Access 2010 projektu należy użyć tej funkcji. Chociaż niektóre funkcje bazy danych dla komputerów stacjonarnych nie są tłumaczone na sieć Web, wiele z tych samych czynności można wykonać przy użyciu nowych funkcji, takich jak pola obliczeniowe i makra danych.

Udostępnianie bazy danych w sieci Web

  • Korzystanie z szablonu    Pięć szablonów zawiera wiele Access 2010: Kontakty, Majątek, Projekty, Wydarzenia i Działalności charytatywne. Możesz także zmodyfikować dowolny szablon przed opublikowaniem lub po jego opublikowaniu.

  • Zacznij od podstaw    Podczas tworzenia pustej nowej bazy danych wybiera się pomiędzy zwykłą bazą danych a bazą danych sieci Web. Ten wybór ma wpływ na funkcje projektowania i polecenia, które są dostępne, dzięki czemu łatwo jest mieć pewność, że aplikacja jest zgodna z siecią Web.

  • Konwertowanie istniejącej bazy danych na bazę danych sieci Web    Istniejącą aplikację można opublikować w sieci Web. Nie wszystkie funkcje bazy danych dla komputerów stacjonarnych są obsługiwane w sieci Web, więc może być trzeba dostosować niektóre funkcje aplikacji.

    Możesz uruchomić nowe sprawdzanie zgodności z siecią Web, aby ułatwić identyfikowanie i rozwiązywanie problemów ze zgodnością.

  • Intranet lub Internet    Możesz opublikować na własnym serwerze programu SharePoint lub użyć hostowanej rozwiązania programu SharePoint.

    Uwaga: Używanie bazy danych sieci Web wymaga konta użytkownika. Dostęp anonimowy nie jest obsługiwany.

Aby uzyskać więcej informacji na temat baz danych sieci Web, zobacz artykuł Tworzenie bazy danych do udostępnienia w sieci Web.

Nowy konstruktor makr

Access 2010 oferuje nowego konstruktora makr, który zawiera intelliSense i przejrzysty, prosty interfejs.

Konstruktor makr

1. Wybierz akcję z listy...

2. ... lub kliknij dwukrotnie akcję w Wykazie akcji, aby dodać ją do makra.

3. Karta Projektowanie jest wyświetlana podczas pracy nad makrem.

Po dodaniu akcji w konstruktorze makr zostanie wyświetlonych więcej opcji. Na przykład po dodaniu akcji "Jeżeli" zobaczysz:

Makro z akcją „Jeżeli”

Obejrzyj poniższy klip wideo, aby zobaczyć, jak działa nowy konstruktor makr.

Twoja przeglądarka nie obsługuje wideo.

Makra danych, nowa funkcja, oprócz tradycyjnych makr, można tworzyć za pomocą nowego konstruktora makr.

Makra danych: zmienianie danych na podstawie zdarzeń

Makra danych obsługują agregacje w bazach danych sieci Web, a także zapewniają sposób implementowania "wyzwalaczy" w dowolnej Access 2010 danych.

Załóżmy na przykład, że masz pole ProcentUzupełnianie i pole Stanu. Za pomocą makra danych można ustawić wartość ProcentUzupełniania na 100 po skonfigurowaniu stanu Ukończono,a 0 w przypadku ustawienia stanu Nie rozpoczęto.

Makra danych możesz zobaczyć w działaniu w poniższym klipie wideo.

Twoja przeglądarka nie obsługuje wideo.

Rozszerzony Konstruktor wyrażeń

Konstruktor wyrażeń jest teraz wyposażony w technologii IntelliSense, dzięki czemu opcje są dostępne podczas pisania. W oknie Konstruktora wyrażeń jest również wyświetlana pomoc dla obecnie wybranej wartości wyrażenia. Jeśli na przykład wybierzesz funkcję Przytnij, Konstruktor wyrażeń wyświetli:

Trim(string) Zwraca wariant ciągu typu zawierający kopię określonego ciągu bez spacji wiodących i końcowego.

Aby uzyskać więcej informacji, zobacz artykuł Korzystanie z Konstruktora wyrażeń.

Pola obliczeniowe

Można utworzyć pole wyświetlace wyniki obliczeń. Obliczenia muszą zawierać odwołania do innych pól w tej samej tabeli. Obliczenia można tworzyć za pomocą Konstruktora wyrażeń.

Nowe szablony baz danych

Access 2010 zawiera pakiet profesjonalnie zaprojektowanych szablonów baz danych do śledzenia między innymi kontaktów, zadań, wydarzeń, uczniów i zasobów. Możesz ich użyć od razu lub ulepszyć je i uściślić, aby śledzić informacje dokładnie tak, jak chcesz.

Dostępne szablony w widoku Backstage

Każdy szablon to pełna aplikacja do śledzenia, która zawiera wstępnie zdefiniowane tabele, formularze, raporty, zapytania, makra i relacje. Szablony zaprojektowano tak, aby od razu stał się przydatne, dzięki czemu możesz szybko rozpocząć z nich korzystać. Jeśli projekt szablonu spełnia Twoje potrzeby, możesz rozpocząć. W przeciwnym razie możesz użyć tego szablonu, aby rozpocząć tworzenie bazy danych spełniającej Określone potrzeby.

Baza danych sieci Web składników majątku

Oprócz szablonów dołączonych do programu Access 2010 możesz połączyć się z Office.com pobrać więcej szablonów.

Części aplikacji do dodawania funkcji do istniejącej bazy danych

Korzystając z części aplikacji, można łatwo dodać funkcje do istniejącej bazy danych. W programie Access 2010 część aplikacji to szablon, który stanowi część bazy danych — na przykład wstępnie sformatowaną tabelę lub tabelę ze skojarzonym formularzem i raportem. Możesz na przykład dodać do bazy danych część aplikacji Zadania, aby uzyskać tabelę Zadania, formularz Zadania oraz opcję powiązać tabelę Zadania z inną tabelą w bazie danych.

Części aplikacji na karcie Tworzenie

Aby uzyskać więcej informacji, zobacz artykuł Zapisywanie i ponowne używanie elementów projektu bazy danych.

Ulepszony widok arkusza danych

Możesz utworzyć tabelę i zacząć jej używać bez definiowania pól z wyprzedzeniem — wystarczy kliknąć pozycję Tabela na karcie Tworzenie i rozpocząć wprowadzanie danych w wyświetlonym nowym arkuszu danych. Access 2010 automatycznie określa najlepszy typ danych dla każdego pola, dzięki czemu za każdym razem wszystko jest już uruchomione. Kolumna Kliknij, aby dodać zawiera informacje o tym, gdzie dodać nowe pole. Jeśli chcesz zmienić typ danych lub format wyświetlania nowego lub istniejącego pola, możesz użyć poleceń na wstążce na karcie Pola. Możesz również wkleić dane z tabel programu Microsoft Excel do nowego arkusza danych — Access 2010 automatycznie utworzy wszystkie pola i rozpozna typy danych.

Kliknij, aby dodać w widoku arkusza danych

Okienko Lista pól

Okienko Lista pól umożliwia dodawanie pól z innych tabel. Można przeciągać pola z tabeli w źródle rekordów, z tabel pokrewnych lub z niepowiązanych tabel w bazie danych. Jeśli jest potrzebna relacja między tabelami, jest ona tworzona automatycznie lub jest wyświetlany monit w ramach tego procesu.

Okienko Lista pól

Widok układu przyspiesza projektowanie formularzy i raportów

Widok układu służy do zmieniania projektu podczas wyświetlania danych w formularzu lub raporcie.

Widok układu zawiera kilka ulepszeń i jest wymagany w przypadku projektowania formularza lub raportu dla sieci Web.

Formularz w widoku układu, w którym są pokazane dane dynamiczne

Korzystanie z układów kontrolek w celu utrzymania porządku

Układy to grupy kontrolek, które można przenosić i zmieniać ich rozmiar jako jednostki. W Access 2010 ulepszono układy, aby umożliwić bardziej elastyczne rozmieszczanie kontrolek w formularzach i raportach. Komórki można dzielić lub scalać w poziomie lub w pionie, co pozwala na łatwe rozmieszczanie pól, kolumn lub wierszy.

Podczas projektowania baz danych sieci Web należy używać widoku układu, ale widok projektu pozostaje dostępny do projektowania baz danych dla komputerów stacjonarnych.

Nowy interfejs użytkownika

Nowy interfejs użytkownika — rozszerzony w programie Access 2010 — został zaprojektowany tak, aby ułatwić znajdowanie poleceń i funkcji, które wcześniej były często zasypane złożonymi menu i paskami narzędzi.

Wstążka

Wstążka to zbiór kart, które zawierają grupy poleceń zorganizowane według funkcji i funkcji. Wstążka zastępuje warstwy menu i pasków narzędzi znalezionych we wcześniejszych wersjach programu Access. Na poniższej ilustracji przedstawiono wstążkę z wybraną kartą Narzędzia główne.

Wstążka w programie Access 2010

Najważniejsze funkcje wstążki to między innymi:

  • Karty poleceń — karty z często używanymi poleceniami, dzięki czemu można znaleźć potrzebne polecenia w razie potrzeby.

  • Kontekstowe karty poleceń — karta poleceń wyświetlana w zależności od kontekstu — czyli obiekt, nad który pracujesz, lub zadanie, które wykonujesz. Kontekstowa karta poleceń zawiera polecenia, które najprawdopodobniej będą stosowane do tego, co robisz.

  • Galerie — nowe kontrolki, dla których jest wyświetlany podgląd stylu lub opcji, dzięki czemu można zobaczyć wyniki przed zatwierdzeniem wyboru.

Widok Backstage

Nowość w Access 2010 widoku Backstage zawiera polecenia stosowane do całej bazy danych, takie jak kompaktowanie i naprawianie lub otwieranie nowej bazy danych. Polecenia są rozmieszczone na kartach po lewej stronie ekranu, a każda karta zawiera grupę powiązanych poleceń lub linków. Na przykład po kliknięciu przycisku Nowy zostanie wyświetlony zestaw przycisków, które umożliwiają tworzenie nowej bazy danych od podstaw lub przez wybranie z biblioteki profesjonalnie zaprojektowanych szablonów baz danych.

Karta Nowy w widoku Backstage

Wiele poleceń dostępnych w widoku Backstage było dostępnych w menu Plik we wcześniejszych wersjach programu Access, a także w ostatnio otwieranych bazach danych oraz (jeśli masz połączenie z Internetem) do office.com artykułów.

Aby uzyskać dostęp do widoku Backstage, kliknij kartę Plik.

Okienko nawigacji

Okienko nawigacji zawiera listę i zapewnia łatwy dostęp do wszystkich obiektów w obecnie otwartej bazie danych.

Okienko nawigacji — baza danych Northwind 2007

Okienko nawigacji umożliwia organizowanie obiektów według typu obiektu, daty utworzenia, modyfikacji, powiązanej tabeli (na podstawie zależności obiektów) lub w utworzonych grupach niestandardowych. Potrzebujesz więcej miejsca do pracy nad projektem formularza? Okienko nawigacji można łatwo zwinąć, aby zajmujeło niewiele miejsca, ale nadal pozostaje dostępne.

Obiekty na kartach

Domyślnie tabele, zapytania, formularze, raporty i makra są wyświetlane w oknie programu Access jako obiekty z kartami.

To ustawienie można zmienić dla bazy danych i używać okien obiektów zamiast kart.

Obiekt wyświetlany na karcie w programie Access 2007 Klikając karty obiektów, możesz łatwo przełączać się między różnymi obiektami.

Okno Pomocy

Access 2010 udostępnia w tym samym oknie Pomocy zarówno pomoc programu Access, jak i zawartość "Materiały referencyjne dla deweloperów programu Access". Oba systemy zawierają różne typy zawartości pomocy. Podgląd Pomocy pozwala wybrać zawartość do wyświetlenia. Na przykład możesz zmienić zakres wyszukiwania tylko na zawartość "Materiały referencyjne dla deweloperów programu Access". Niezależnie od ustawień w oknie Pomocy cała zawartość Pomocy i materiałów referencyjnych deweloperów programu Access jest zawsze dostępna w trybie online, w witrynie Office.com lub w witrynie MSDN.

Bardziej zaawansowane narzędzia do tworzenia obiektów

Access 2010 udostępnia intuicyjne środowisko do tworzenia obiektów bazy danych.

Karta Tworzenie

Karta Tworzenie umożliwia szybkie tworzenie nowych formularzy, raportów, tabel, zapytań i innych obiektów bazy danych. Jeśli wybierzesz tabelę lub zapytanie w okienku nawigacji, możesz utworzyć nowy formularz lub raport oparty na tym obiekcie jednym kliknięciem przy użyciu polecenia Formularz lubRaport.

Karta Tworzenie na Wstążce w programie Access

W nowych formularzach i raportach utworzonych za pomocą tego procesu jednym kliknięciem zaktualizowano projekt, aby ułatwić wizualne i natychmiastowe korzystanie z nich. Automatycznie generowane formularze i raporty mają profesjonalnie wyglądający projekt z nagłówkami z logo i tytułem. Ponadto automatycznie wygenerowany raport zawiera również datę i godzinę, a także stopki i sumy informacyjne.

Widok raportu i widok układu

Te widoki rozszerzone w programie Access 2010 umożliwiają interakcyjną pracę z formularzami i raportami. Za pomocą widoku raportu można przeglądać dokładne renderowanie raportu bez konieczności drukowania ani wyświetlania go w podglądzie wydruku. Aby skupić się na określonych rekordach, użyj funkcji filtrowania lub użyj operacji znajdowanie w celu wyszukania pasującego tekstu. Za pomocą polecenia Kopiuj możesz skopiować tekst do Schowka lub kliknąć aktywne hiperlinki wyświetlane w raporcie, aby użyć linku w przeglądarce.

Widok układu umożliwia zmianę projektu podczas przeglądania danych. Za pomocą widoku układu można wprowadzać wiele typowych zmian projektu podczas wyświetlania danych w formularzu lub raporcie. Możesz na przykład dodać pole, przeciągając jego nazwę z nowego okienka Lista pól lub zmienić właściwości za pomocą arkusza właściwości.

Widok układu oferuje teraz ulepszone układy projektu — grupy kontrolek, które można dostosowywać jako jeden, dzięki czemu można łatwo zmieniać rozmieszczenie pól, kolumn, wierszy lub całych układów. Możesz również łatwo usunąć pole lub dodać formatowanie w widoku układu.Raport w widoku układu

Usprawnione tworzenie grupowania i sortowania w raportach

Program Access oferuje nowy sposób grupowania i sortowania danych w raportach oraz dodawania sum. Interfejs jest łatwy do nawigowania i zrozumienia, a gdy jest używany w nowym widoku układu, natychmiast widać efekt wprowadzonych zmian.

Okienko Grupowanie, sortowanie i sumowanie

Załóżmy, że chcesz wyświetlić w raporcie łączną sprzedaż według regionów. Użyj widoku układu oraz okienka Grupowanie, sortowanie i sumowanie, aby dodać poziom grupy i zażądać sumy — a także zobaczyć zmiany na żywo w raporcie. Wiersz Suma ułatwia dodawanie do nagłówków i stopek raportu sum, średniej, liczby, wartości maksymalnych lub minimalnych. Proste sumy nie wymagają już ręcznego tworzenia pola obliczeniowego. Teraz wystarczy wskazać i kliknąć.

Tworzenie sumy w raporcie

Ulepszone układy kontrolek, które ułatwiają tworzenie ulepszonych formularzy i raportów

Formularze i raporty często zawierają informacje tabelaryczne, takie jak kolumna zawierająca nazwy klientów lub wiersz zawierający wszystkie pola klienta. Te kontrolki można grupować w układ, który można łatwo modyfikować jako jedną jednostkę, łącznie z etykietą.

Polecenia w grupie Sterowanie układem na karcie Rozmieszczanie

Ponieważ można wybrać kontrolki z różnych sekcji, takich jak etykieta w nagłówku lub stopce sekcji, istnieje znaczna elastyczność. Możesz łatwo:

  • Przenoszenie układu lub zmienianie jego rozmiaru. Na przykład przenieś kolumnę w lewo lub w prawo.

  • Formatowanie układu. Na przykład ustaw pogrubioną kolumnę z nazwą klienta, aby wyróżniała się.

  • Dodawanie kolumny (pola) do układu.

  • Usuwanie kolumny (pola) z układu.

  • Scalanie lub dzielenie komórek

Przenoszenie kolumny w widoku układu

Układy są zapisywane razem z projektem, dzięki czemu pozostają dostępne. W poniższym klipie wideo pokazano, jak działają układy w formularzach i raportach.

Twoja przeglądarka nie obsługuje wideo.

Formularze dzielone w celu szybkiego przeglądania danych

Formularz dzielony służy do tworzenia formularza łączącego widok arkusza danych i widoku formularza. Możesz ustawić właściwość, aby program Access umieszczał arkusz danych u góry, u dołu, w lewo lub w prawo.

Formularz dzielony

Uwaga: Formularze dzielone nie są dostępne w bazach danych sieci Web.

Osadzone makra w formularzach i raportach

Makr osadzonych można używać w celu uniknięcia konieczności pisania kodu. Makro osadzone jest przechowywane we właściwości i stanowi część obiektu, do którego należy. Projekt makra osadzonego można zmienić bez konieczności martwienia się o inne kontrolki, które mogą z niego korzystać — każde osadzone makro jest niezależne. Osadzone makra są zaufane, ponieważ automatycznie nie mogą wykonywać potencjalnie niebezpiecznych operacji.

Przypisywanie makra osadzonego do zdarzenia Przy kliknięciu dwukrotnym

Nowe typy danych i kontrolki

Nowe w Access 2010 pola obliczeniowe umożliwiają przechowywanie wyników obliczeń.

  • Pola wielowartościowe

  • Typ danych Załącznik

  • Rozszerzone pola noty

  • Wbudowana kontrolka kalendarza dla pól daty/godzin

Pola obliczeniowe

Można utworzyć pole wyświetlace wartość obliczoną na podstawie innych danych w tej samej tabeli. Do tworzenia obliczeń używasz Konstruktora wyrażeń, co ułatwia uzyskiwanie korzyści z funkcji IntelliSense i łatwego dostępu do Pomocy w przypadku wartości wyrażeń.

Dane z innych tabel nie mogą być używane jako źródło obliczanych danych. Niektóre wyrażenia nie są obsługiwane w polach obliczeniowych.

Pola wielowartościowe

Pole wielowartościowe może przechowywać więcej niż jedną wartość na rekord. Załóżmy, że musisz przydzielić zadanie jednem z twoich pracowników lub wykonawców, ale chcesz je przydzielić więcej niż jednej osobie. W większości systemów zarządzania bazami danych i w wersjach programu Access starszych niż Office Access 2007 trzeba było utworzyć relację wiele-do-wielu, aby zrobić to poprawnie.

Uwaga: Program Access tworzy ukrytą tabelę w celu zachowania koniecznej relacji wiele-do-wielu dla każdego pola wielowartościowego.

Pola wielowartościowe są szczególnie przydatne podczas pracy z listą programu SharePoint, która zawiera jeden z typów pól wielowartościowych używanych w programie Windows SharePoint Services. Access 2010 jest zgodna z tymi typami danych.

Pole wielowartościowe

Pola załączników dla plików

Typ danych Załącznik umożliwia łatwe przechowywanie wszystkich rodzajów dokumentów i plików binarnych w bazie danych bez niepotrzebnego wzrostu rozmiaru bazy danych. Program Access automatycznie kompresuje załączniki, gdy jest to możliwe, w celu zminimalizowania wykorzystania miejsca. Chcesz dołączyć dokument programu Word do rekordu lub zapisać serię obrazów cyfrowych w bazie danych? Korzystanie z załączników znacznie ułatwia te zadania. Możesz nawet dodać wiele załączników do jednego rekordu.

Okno dialogowe Załączniki

Uwaga: W bazach danych sieci Web można używać pól załączników, ale każda tabela sieci Web może mieć najwyżej jedno pole załącznika.

Pola typu Nota zawierają teraz tekst sformatowany i historię poprawek pomocy technicznej

Pola typu tekst sformatowany oznacza, że użytkownik nie jest już ograniczony do zwykłego tekstu w rekordach. Tekst można formatować przy użyciu opcji (takich jak pogrubienie, kursywa, różne czcionki i kolory oraz inne popularne opcje formatowania) i przechowywać tekst w bazie danych. Tekst sformatowany sformatowany sformatowany jest przechowywany w polu noty w formacie HTML, który jest zgodny z typem danych tekst sformatowany w programie Windows SharePoint Services. Ustaw nową właściwość TextFormat na richtext lub plaintext,a informacje będą następnie poprawnie sformatowane w kontrolkach pól tekstowych i w widoku arkusza danych.

Pola typu Nota umożliwiają przechowywanie dużych ilości informacji. Właściwość Tylko dołącz można skonfigurować tak, aby zachowywała historię wszystkich zmian w polu typu Nota. Historię tych zmian można później przeglądać. Ta funkcja obsługuje również funkcję śledzenia w programie Windows SharePoint Services dzięki czemu można również wyświetlać historię zawartości listy programu SharePoint za pomocą programu Access.

Kalendarz do wybierania dat

Pola i kontrolki, które korzystają z typu danych Data/Godzina, automatycznie uzyskują obsługę wbudowanego kalendarza interakcyjnego. Przycisk kalendarza jest automatycznie wyświetlany z prawej strony daty. Chcesz poznać datę tego nadchodzącego piątku? Kliknij ten przycisk, a kalendarz zostanie automatycznie wyświetlony, aby znaleźć i wybrać datę. Możesz wyłączyć kalendarz dla pola lub kontrolki przy użyciu właściwości.

Ulepszona prezentacja danych

Nowe funkcje prezentacji danych ułatwiają szybkie tworzenie obiektów bazy danych, a następnie ułatwiają analizowanie danych.

Ulepszone narzędzia do sortowania i filtrowania

Załóżmy, że musisz szybko znaleźć pasującą wartość lub posortować kolumnę danych. Funkcja Autofiltr zwiększa już możliwości filtrowania, dzięki czemu możesz szybko skupić się na potrzebnych danych. Unikatowe wartości w kolumnie można łatwo wybrać, co jest przydatne w sytuacjach, gdy nie można odwołać potrzebnej nazwy lub można posortować wartości przy użyciu opcji menu kontekstowego w zwykłym języku, takich jak Sortuj od najstarszych do najnowszych lub Sortuj od najmniejszych do największych.

Autofiltr

Najczęściej spotykane opcje filtrowania są łatwo widoczne w poleceniach menu lub za pomocą szybkich filtrów można ograniczyć informacje na podstawie wprowadzanych danych. Opcje szybkiego filtrowania zmieniają się automatycznie w zależności od typu danych, dzięki czemu będą dostępne sensowne opcje dotyczące tekstu, daty i informacji liczbowych.

Menu Filtry dat

Sumy i naprzemiennie kolory tła w arkuszach danych

Widok arkusza danych udostępnia wiersz sumy, w którym można pokazać sumę, liczbę, średnią, maksimum, minimum, odchylenie standardowe lub wariancja. Po dodaniu wiersza sumy wskaż strzałkę w komórce kolumny i wybierz odpowiednie obliczenie.

Wiersz sumy w arkuszu danych

Arkusze danych, raporty i formularze ciągłe obsługują naprzemienny kolor tła wierszy, który można skonfigurować niezależnie od domyślnego koloru tła. Cieniowanie co drugiego wiersza jest łatwe i można wybrać dowolny kolor.

Arkusz danych, w którym jest używany alternatywny kolor wiersza

Formatowanie warunkowe

Access 2010 dodaje nowe funkcje formatowania warunkowego, umożliwiając uzyskanie niektórych stylów formatowania dostępnych w programie Excel. Teraz można na przykład dodać paski danych, aby kolumny liczb bardziej czytelne, jak pokazano na poniższej ilustracji:

Formatowanie warunkowe w raporcie programu Access

Uwaga: Formatowanie warunkowe nie jest dostępne w bazach danych sieci Web.

Ulepszone zabezpieczenia

Ulepszone funkcje zabezpieczeń i silna integracja z programem Windows SharePoint Services ułatwiają bardziej efektywne zarządzanie aplikacjami do śledzenia informacji i zwiększenie bezpieczeństwa aplikacji do śledzenia informacji. Przechowując dane aplikacji do śledzenia na listach w Windows SharePoint Services, można inspekcjić historię poprawek, odzyskiwać usunięte informacje i konfigurować uprawnienia dostępu do danych.

Office Access 2007 wprowadzono nowy model zabezpieczeń, który został jeszcze ulepszony w Access 2010. Ujednolicone decyzje dotyczące zaufania są zintegrowane z Centrum zaufania pakietu Microsoft Office. Zaufane lokalizacje ułatwiają ufanie wszystkim bazom danych w bezpiecznych folderach. Możesz załadować aplikację sieci Office Access 2007 z wyłączonymi kodami lub makrami, aby zapewnić bezpieczniejsze środowisko w trybie piaskownicy (czyli nie można uruchamiać niebezpiecznych poleceń). Zaufane makra są uruchamiane w trybie piaskownicy.

Zbieranie danych przy użyciu formularzy programu InfoPath i programu Outlook

Funkcja zbierania danych ułatwia zbieranie opinii przy użyciu programu Outlook i (opcjonalnie) programu InfoPath. Formularz programu InfoPath lub formularz HTML można automatycznie wygenerować i osadzić w treści wiadomości e-mail. Następnie możesz wysłać formularz do adresatów wybranych z kontaktów programu Outlook lub do nazw adresatów przechowywanych w polu w bazie danych programu Access.

Zbieranie danych za pomocą wiadomości e-mail

Użytkownik określa, czy chcesz zbierać nowe informacje, czy aktualizować istniejące informacje. Adresaci wypełnij formularz i zwróć go. Program Outlook rozpoznaje przychodzące formularze i automatycznie zapisuje dane w bazie danych programu Access — nie jest wymagane ponowne wpisywanie.

Eksportowanie do plików PDF i XPS

W programie Access 2010 można eksportować dane do formatu PDF (Portable Document Format) lub XPS (XML Paper Specification) w celu drukowania, publikowania i rozpowszechniania wiadomości e-mail, pod warunkiem, że najpierw zainstalujesz dodatek Publikuj jako plik PDF lub XPS. Eksportowanie formularza, raportu lub arkusza danych do pliku pdf lub xps umożliwia przechwytywanie informacji w łatwym do rozpowszechnienia formularzu, który zachowuje wszystkie cechy formatowania, ale nie wymaga od innych osób instalowania programu Access na ich komputerach w celu wydrukowania lub przejrzenia danych wyjściowych.

  • Portable Document Format    PDF to format pliku elektronicznego o stałym układzie, który zachowuje formatowanie dokumentu i ułatwia udostępnianie plików. Format PDF zapewnia, że podczas wyświetlania w trybie online lub drukowania plik zachowuje dokładnie ten format, jaki został zamierzony, a danych w pliku nie można łatwo skopiować ani zmienić. Format PDF jest także przydatny w przypadku dokumentów, które będą powielane metodami drukowania komercyjnego.

  • Specyfikacja papieru XML    Format XPS to format pliku elektronicznego, który zachowuje formatowanie dokumentu i ułatwia udostępnianie plików. Format XPS zapewnia, że podczas wyświetlania w trybie online lub drukowania plik zachowuje dokładnie ten format, który został zamierzony, a danych w pliku nie można łatwo skopiować ani zmienić.

Łatwiejsza praca z danymi zewnętrznymi

Teraz możesz połączyć się z usługą sieci Web jako zewnętrzne źródło danych. Musisz mieć plik definicji usługi sieci Web dostarczony przez administratora usługi sieci Web. Po zainstalowaniu pliku definicji można połączyć dane usługi sieci Web jako tabelę połączoną.

Nowe funkcje ułatwiają importowanie i eksportowanie danych. Możesz zapisać operację importowania lub eksportowania, a następnie ponownie użyć zapisanej operacji, gdy następnym razem będziesz chcieć wykonać to samo zadanie. Kreator importu arkuszy kalkulacyjnych umożliwia zastępowanie typu danych wybranego przez program Access oraz importowanie, eksportowanie i łączenie plików, które mają Office Excel 2007 co najmniej formaty plików.

Lepszy sposób rozwiązywania problemów

Diagnostyka pakietu Microsoft Office to seria testów diagnostycznych, które mogą pomóc w diagnostyce, dlaczego komputer ulega awarii. Testy diagnostyczne pozwalają rozwiązać niektóre problemy bezpośrednio i identyfikować sposoby rozwiązywania innych problemów. Diagnostyka pakietu Microsoft Office zastępuje następujące funkcje pakietu Microsoft Office 2003: Wykrywanie i naprawa oraz Odzyskiwanie aplikacji pakietu Microsoft Office.

Ulepszone sprawdzanie pisowni

Poniżej przedstawiono kilka nowych funkcji modułu sprawdzania pisowni.

  • Moduł sprawdzania pisowni działa spójniej we wszystkich programach pakietu Office. Oto przykłady tej zmiany:

    • Kilka opcji modułu sprawdzania pisowni jest teraz globalnych. Jeśli zmienisz jedną z tych opcji w jednym programie pakietu Office, ta opcja zostanie również zmieniona we wszystkich innych programach pakietu Office.

    • Poza udostępnianiem tego samego słownika niestandardowego wszystkie programy mogą nimi zarządzać przy użyciu tego samego okna dialogowego. Aby uzyskać więcej informacji, zobacz artykuł Używanie słowników niestandardowych do dodawania wyrazów do modułu sprawdzania pisowni.

  • Moduł sprawdzania pisowni uwzględnia słownik francuski po reformie. W psłudze Microsoft Office 2003 był to dodatek, który trzeba było zainstalować oddzielnie.

  • Słownik wykluczeń jest tworzony automatycznie dla języka, gdy ten język jest używany po raz pierwszy. Słowniki wykluczeń mogą wymuszać oznaczanie przez moduł sprawdzania pisowni wyrazów, których chcesz unikać. Słowniki wykluczeń są przydatne w celu uniknięcia wyrazów, które są obsceniczne lub nie są zgodne z twoim przewodnikiem po stylu.

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jak zadowalająca jest jakość tłumaczenia?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×