Jak naprawić błąd #ARG! w funkcjach ŚREDNIA i SUMA

Jeśli średnia lub suma odwołuje się do komórek zawierających #VALUE! błędy, formuły spowodują #VALUE! .

Błąd #ARG! w funkcji ŚREDNIA

W celu pominięcia tych wartości błędów skonstruowaliśmy formułę, która ignoruje błędy w zakresie odwołania podczas obliczania średniej z pozostałych „normalnych” wartości.

Aby obejść ten scenariusz, można użyć połączenia funkcji ŚREDNIA i JEŻELI oraz funkcji CZY.BŁĄD w celu ustalenia, czy w określonym zakresie występuje błąd. W tym konkretnym scenariuszu wymagana jest formuła tablicowa:

=ŚREDNIA(JEŻELI(CZY.BŁĄD(B2:D2);"";B2:D2))

To jest formuła tablicowa. Wystarczy nacisnąć klawisz Enter (tylko wtedy, gdy używasz Microsoft 365 ) lub Ctrl + Shift + Enter w formule.

Uwaga: Jeśli masz aktualną wersję programu Microsoft 365, możesz po prostu wprowadzić formułę w komórce Output, a następnie nacisnąć klawisz Enter , aby potwierdzić formułę jako dynamiczną formułę tablicową. W przeciwnym razie formułę należy wprowadzić jako starszą formułę tablicową, wybierając najpierw komórkę wyjściową, wprowadzając formułę w komórce wyjociowej, a następnie naciskając klawisze CTRL + SHIFT + ENTER , aby potwierdzić. Program Excel wstawia nawiasy klamrowe na początku i końcu formuły. Aby uzyskać więcej informacji na temat formuł tablicowych, zobacz Wskazówki i przykłady dotyczące formuł tablicowych.

Średnia funkcja tablicowa w celu usunięcia #VALUE! błąd

Uwaga: Powyższa funkcja zadziała nie tylko w przypadku błędu #ARG!, ale też w przypadku błędów #N/D, #ZERO, #DZIEL/0! i innych.

W ten sam sposób można też używać funkcji SUMA:

=SUMA(JEŻELI(CZY.BŁĄD(B2:D2);"";B2:D2))

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel lub uzyskać pomoc techniczną w społeczności witryny Answers.

Zobacz też

Naprawianie błędu #ARG! błąd

ŚREDNIA

SUMA, funkcja

Omówienie formuł w programie Excel

Wykrywanie błędów w formułach

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×