Jeśli średnia lub SUMA odnosi się do komórek zawierających #VALUE! formuły będą powodować #VALUE! .

Błąd #ARG! w funkcji ŚREDNIA

W celu pominięcia tych wartości błędów skonstruowaliśmy formułę, która ignoruje błędy w zakresie odwołania podczas obliczania średniej z pozostałych „normalnych” wartości.

Aby obejść ten scenariusz, można użyć połączenia funkcji ŚREDNIA i JEŻELI oraz funkcji CZY.BŁĄD w celu ustalenia, czy w określonym zakresie występuje błąd. W tym konkretnym scenariuszu wymagana jest formuła tablicowa:

=ŚREDNIA(JEŻELI(CZY.BŁĄD(B2:D2);"";B2:D2))

To jest formuła tablicowa. Dlatego należy nacisnąć klawisz ENTER (tylko w przypadku użycia klawiszy Microsoft 365 ) lub klawisze CTRL+SHIFT+ENTER w formule.

Uwaga: Jeśli masz bieżącą wersję programu Microsoft 365, możesz po prostu wprowadzić formułę w komórce wyjściowej, a następnie nacisnąć klawisz ENTER, aby potwierdzić formułę jako dynamiczną formułę tablicową. W przeciwnym razie należy wprowadzić formułę jako starszą formułę tablicową, zaznaczając komórkę wyjściową, wprowadzając formułę w komórce wyjściowej, a następnie naciskając klawisze CTRL+SHIFT+ENTER, aby ją potwierdzić. Program Excel wstawi na początku i końcu formuły nawiasy klamrowe. Aby uzyskać więcej informacji na temat formuł tablicowych, zobacz Wskazówki i przykłady dotyczące formuł tablicowych.

Funkcja tablicowa w funkcji ŚREDNIA, aby #VALUE! typu #ZAJĘTY!

Uwaga: Powyższa funkcja zadziała nie tylko w przypadku błędu #ARG!, ale też w przypadku błędów #N/D, #ZERO, #DZIEL/0! i innych.

W ten sam sposób można też używać funkcji SUMA:

=SUMA(JEŻELI(CZY.BŁĄD(B2:D2);"";B2:D2))

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel lub uzyskać pomoc techniczną w społeczności witryny Answers.

Zobacz też

Naprawianie błędu #ARG! typu #ZAJĘTY!

ŚREDNIA

SUMA

Omówienie formuł w programie Excel

Wykrywanie błędów w formułach

Wszystkie Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów Microsoft Office

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×