Przy użyciu funkcji POLE.WARTOŚĆ można pobierać dane pól z połączonych typów danych, takich jak typy danych Akcje i Geografia. Istnieją łatwiejsze metody pisania formuł odwołujących się do typów danych, dlatego funkcja POLE.WARTOŚĆ powinna być używana głównie do tworzenia obliczeń warunkowych na podstawie połączonych typów danych.

Uwaga: 28 marca 2019 r.: Typy danych zostały opublikowane dla wszystkich Windows Microsoft 365 subskrybentów. Jeśli jesteś subskrybentem usługi Microsoft 365, upewnij się, że masz najnowszą wersję pakietu Office.

Szczegóły techniczne

Składnia

= POLE.WARTOŚĆ(wartość, nazwa_pola)

W składni funkcji POLE.WARTOŚĆ występują następujące argumenty:

Argument

Opis

wartość

Funkcja zwraca wszystkie pasujące pola z połączonego typu danych określonego w argumencie wartości.

nazwa_pola

Nazwa lub nazwy pól, które chcesz wyodrębnić z połączonego typu danych.

Opis

Przykłady

W poniższym podstawowym przykładzie formuła =POLE.WARTOŚĆ(A2,„Price”) wyodrębnia pole Price (Cena) z typu danych giełdowych dotyczących firmy JM Smucker Co.

Pobieranie ceny akcji firmy za pomocą formuły =POLE.WARTOŚĆ(A2,"Price")

Kolejny przykład jest bardziej typowym przykładem funkcji POLE.WARTOŚĆ. Tutaj używamy funkcji JEŻELI.BŁĄD do sprawdzania błędów. Jeśli w komórce A2 nie ma nazwy firmy, formuła POLE.WARTOŚĆ zwraca błąd, a w takim przypadku chcemy, aby nic nie było wyświetlane (""). Ale jeśli jest tam nazwa firmy, chcemy z typu danych w komórce A2 pobrać wartość Price (Cena), używając formuły =JEŻELI.BŁĄD(POLE.WARTOŚĆ($A2,B$1),"").

Pobieranie ceny akcji firmy i ignorowanie błędów za pomocą formuły =JEŻELI.BŁĄD(POLE.WARTOŚĆ($A2,B$1),"")

Zwróć uwagę, że funkcja POLE.WARTOŚĆ umożliwia uzyskiwanie argumentu nazwa_pola przez odwoływanie się do komórek arkusza, dlatego powyższa formuła odwołuje się do komórki B1 w celu uzyskania wartości Price (Cena), zamiast ręcznego wprowadzania tekstu „Price” w formule.  

Uwagi

Jeśli spróbujesz pobrać dane z nieistniejącego pola typu danych, funkcja POLE.WARTOŚĆ zwróci #FIELD!. Na przykład można wprowadzić tekst "Ceny", gdy rzeczywiste pole typu danych nosi nazwę "Cena". Sprawdź formułę, aby upewnić się, że używasz prawidłowej nazwy pola. Aby wyświetlić listę nazw pól rekordu, zaznacz komórkę rekordu i naciśnij klawisze Alt+Shift+F10.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel lub uzyskać pomoc techniczną w społeczności witryny Answers.

Zobacz też

Typy danych giełdowych i geograficznych

Jak pisać formuły odwołujące się do typów danych

Błąd #POLE! typu #ZAJĘTY!

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów Microsoft Office

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×