Praca z łączami w programie Excel

Aby uzyskać szybki dostęp do powiązanych informacji w innym pliku lub na stronie sieci Web, możesz wstawić hiperlink w komórce arkusza. Możesz również wstawiać linki w określonych elementach wykresu.

Uwaga: Większość zrzutów ekranu w tym artykule została wykonana w Excel 2016. Jeśli masz inną wersję programu, wygląd może się nieco różnić, ale funkcje pozostają takie same, chyba że zaznaczono inaczej.

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć link.

    Możesz również zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować link.

    • Na karcie Wstawianie w grupie łącza kliknij przycisk Połącz Przycisk Hiperłącze .

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub grafikę, a następnie w menu skrótów kliknąć polecenie link lub nacisnąć klawisze CTRL + K.

  2. W obszarze Połącz z kliknij przycisk Utwórz nowy dokument.

  3. W polu Nazwa nowego dokumentu wpisz nazwę nowego pliku.

    Porada: Aby określić lokalizację inną niż ta pokazana w obszarze pełna ścieżka, możesz wpisać nową lokalizację przed nazwą w polu Nazwa nowego dokumentu lub kliknąć pozycję Zmień , aby wybrać odpowiednią lokalizację, a następnie kliknąć przycisk OK.

  4. W obszarze Kiedy edytować kliknij opcję Edytuj nowy dokument później lub Edytuj nowy dokument teraz, aby określić, kiedy nowy plik ma zostać otwarty do edycji.

  5. W polu tekst do wyświetlenia wpisz tekst, który ma reprezentować link.

  6. Aby przydatne informacje były wyświetlane po umieszczeniu wskaźnika na łączu, kliknij pozycję etykietka ekranowa, wpisz odpowiedni tekst w polu tekst etykietki ekranowej , a następnie kliknij przycisk OK.

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć link.

    Możesz również zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować link.

    • Na karcie Wstawianie w grupie łącza kliknij przycisk Połącz Przycisk Hiperłącze .

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub obiekt, a następnie kliknąć polecenie link w menu skrótów lub nacisnąć klawisze CTRL + K.

  2. W obszarze Połącz z kliknij opcję Istniejący plik lub strona sieci Web.

  3. Wykonaj jedną z następujących czynności:

    • Aby wybrać plik, kliknij pozycję Bieżący folder, a następnie kliknij plik, do którego ma zostać utworzony link.

      Bieżący folder można zmienić, wybierając inny folder na liście Szukaj w.

    • Aby wybrać stronę sieci Web, kliknij pozycję strony przeglądane , a następnie kliknij stronę sieci Web, do której chcesz utworzyć link.

    • Aby wybrać ostatnio używany plik, kliknij pozycję ostatnio używane pliki, a następnie kliknij plik, do którego chcesz utworzyć link.

    • Aby wprowadzić znaną nazwę i lokalizację pliku lub strony sieci Web, do których ma zostać utworzony link, wpisz te informacje w polu Adres.

    • Aby zlokalizować stronę sieci Web, kliknij pozycję przeglądaj Przycisk Przeglądaj sieć Web sieci Web, Otwórz stronę sieci Web, do której chcesz utworzyć link, a następnie przejdź z powrotem do programu Excel bez zamykania przeglądarki.

  4. Jeśli chcesz utworzyć link do określonej lokalizacji w pliku lub na stronie sieci Web, kliknij pozycję zakładka, a następnie kliknij dwukrotnie wybrany zakładka.

    Uwaga:  Zakładka musi istnieć w pliku lub na stronie sieci Web, do których ma zostać utworzony link.

  5. W polu tekst do wyświetlenia wpisz tekst, który ma reprezentować link.

  6. Aby przydatne informacje były wyświetlane po umieszczeniu wskaźnika na łączu, kliknij pozycję etykietka ekranowa, wpisz odpowiedni tekst w polu tekst etykietki ekranowej , a następnie kliknij przycisk OK.

Aby utworzyć link do określonej lokalizacji w bieżącym lub innym skoroszycie, można albo zdefiniować nazwa komórek miejsce docelowe, albo użyć odwołania do komórki.

  1. Aby posłużyć się nazwą, musisz nadać nazwę komórkom docelowym znajdującym się w skoroszycie docelowym.

    Jak nadać nazwę komórce lub zakresowi komórek

    1. Zaznacz komórkę, zakres komórek albo zaznaczenie nieprzylegające, którym chcesz nadać nazwę.

    2. Kliknij pole Nazwa na lewym końcu pasek formuły Obraz przycisku .

      Przykładowe pole Nazwa

      pole nazwy Obraz przycisku

    3. W polu Nazwa wpisz nazwę dla komórek, a następnie naciśnij klawisz ENTER.

      Uwaga:  Nazwy nie mogą zawierać spacji i muszą zaczynać się od litery.

  2. W arkuszu skoroszytu źródłowego Kliknij komórkę, w której chcesz utworzyć link.

    Możesz również zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować link.

    • Na karcie Wstawianie w grupie łącza kliknij przycisk Połącz Przycisk Hiperłącze .

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub obiekt, a następnie kliknąć polecenie link w menu skrótów lub nacisnąć klawisze CTRL + K.

  3. W obszarze Połącz z wykonaj jedną z następujących czynności:

    • Aby utworzyć link do lokalizacji w bieżącym skoroszycie, kliknij pozycję Miejsce w tym dokumencie.

    • Aby utworzyć link do lokalizacji w innym skoroszycie, kliknij pozycję istniejący plik lub strona sieci Web, Znajdź i zaznacz skoroszyt, do którego chcesz utworzyć link, a następnie kliknij pozycję zakładka.

  4. Wykonaj jedną z następujących czynności:

    • W polu Lub wybierz miejsce w tym dokumencie w obszarze Adres komórki kliknij arkusz, do którego ma zostać utworzony link, wpisz odwołanie do komórki w polu Wpisz odwołanie do komórki, a następnie kliknij przycisk OK.

    • Na liście w obszarze Nazwy zdefiniowane kliknij nazwę reprezentującą komórki, do których ma zostać utworzony link, a następnie kliknij przycisk OK.

  5. W polu tekst do wyświetlenia wpisz tekst, który ma reprezentować link.

  6. Aby przydatne informacje były wyświetlane po umieszczeniu wskaźnika na łączu, kliknij pozycję etykietka ekranowa, wpisz odpowiedni tekst w polu tekst etykietki ekranowej , a następnie kliknij przycisk OK.

Za pomocą funkcji HIPERŁĄCZe można utworzyć łącze otwierające dokument przechowywany na serwerze sieciowym, w intranet lub Internecie. Gdy zostanie kliknięta komórka zawierająca funkcję HIPERŁĄCZE, program Excel otworzy plik przechowywany w lokalizacji, do której prowadzi link.

Składnia

=HIPERŁĄCZE(lokalizacja_docelowa_linku;przyjazna_nazwa)

Lokalizacja_docelowa_linku     to ścieżka i nazwa pliku dokumentu, który ma być otwierany jako tekst. Argument łącze_lokalizacja może się odwoływać do miejsca w dokumencie, na przykład do określonej komórki lub nazwanego zakresu arkusza bądź skoroszytu programu Excel, albo odwoływać się do zakładki w dokumencie programu Microsoft Word. Ścieżka może być plikiem przechowywanym na dysku twardym lub ścieżką może być ścieżka UNC (Universal Naming Convention) na serwerze (w programie Microsoft Excel dla systemu Windows) lub ścieżką URL (Uniform Resource Locator) w Internecie lub intranecie.

  • Argument lokalizacja_docelowa_linku może być ciągiem tekstowym ujętym w znaki cudzysłowu lub komórką, która zawiera link w postaci ciągu tekstowego.

  • Jeśli skok określony w link_location nie istnieje lub nie można go nawigować, po kliknięciu komórki zostanie wyświetlony komunikat o błędzie.

Przyjazna_nazwa     to tekst skoku lub wartość liczbowa, która jest wyświetlana w komórce. Friendly_name są wyświetlane w kolorze niebieskim i są podkreśleniem. Jeśli argument przyjazna_nazwa zostanie pominięty, komórka wyświetli argument lokalizacja_docelowa_linku jako tekst skoku.

  • Argument przyjazna_nazwa może być wartością, ciągiem tekstowym lub komórką, która zawiera tekst skoku lub wartość.

  • Jeśli argument przyjazna_nazwa zwraca wartość błędu (np. #ARG!), to komórka wyświetla błąd zamiast tekstu skoku.

Przykłady

W poniższym przykładzie jest otwierany arkusz o nazwie Report.xls budżetu przechowywany w Internecie w lokalizacji o nazwie example.microsoft.com/report i jest wyświetlany tekst "kliknij, aby wyświetlić raport":

=HYPERLINK("http://example.microsoft.com/report/budget report.xls", "Click for report")

W poniższym przykładzie jest tworzone łącze do komórki F10 w arkuszu o nazwie roczny w Report.xls budżetu skoroszytu, który jest przechowywany w Internecie w lokalizacji o nazwie example.microsoft.com/report. Komórka w arkuszu, która zawiera link, wyświetla zawartość komórki D1 jako tekst skoku:

=HYPERLINK("[http://example.microsoft.com/report/budget report.xls]Annual!F10", D1)

W poniższym przykładzie przedstawiono tworzenie linku do zakresu o nazwie DeptTotal w arkuszu o nazwie pierwszy kwartał w skoroszycie Report.xls budżetu, który jest przechowywany w Internecie w lokalizacji o nazwie example.microsoft.com/report. Komórka w arkuszu, która zawiera link, powoduje wyświetlenie tekstu "kliknij, aby zobaczyć podsumowanie pierwszego kwartału dla działu":

=HYPERLINK("[http://example.microsoft.com/report/budget report.xls]First Quarter!DeptTotal", "Click to see First Quarter Department Total")

Aby utworzyć link do określonej lokalizacji w dokumencie programu Microsoft Word, należy użyć zakładki w celu zdefiniowania lokalizacji, do której chcesz przejść w dokumencie. W poniższym przykładzie jest tworzone łącze do zakładki o nazwie QrtlyProfits w dokumencie o nazwie roczna Report.doc znajdującym się w example.microsoft.com:

=HYPERLINK("[http://example.microsoft.com/Annual Report.doc]QrtlyProfits", "Quarterly Profit Report")

W poniższym przykładzie w programie Excel dla systemu Windows jest wyświetlana zawartość komórki "moje" jako tekst skoku w komórce i zostanie otwarty plik o nazwie 1stqtr.xls, który jest przechowywany na serwerze o nazwie FINANSe w polu Udostępnij instrukcje. W przykładzie jest używana ścieżka UNC:

=HYPERLINK("\\FINANCE\Statements\1stqtr.xls", D5)

W poniższym przykładzie zostanie otwarty plik 1stqtr.xls w programie Excel dla systemu Windows, który jest przechowywany w katalogu o nazwie Finanse na dysku D, i wyświetla wartość liczbową przechowywaną w komórce H10:

=HYPERLINK("D:\FINANCE\1stqtr.xls", H10)

W poniższym przykładzie w programie Excel dla systemu Windows jest tworzony link do obszaru o nazwie sumy w innym (zewnętrznym) skoroszycie, Mybook.xls:

=HYPERLINK("[C:\My Documents\Mybook.xls]Totals")

W poniższym przykładzie w programie Microsoft Excel dla komputerów Macintosh jest wyświetlany komunikat "kliknij tutaj" w komórce i zostanie otwarty plik o nazwie pierwszy kwartał, który jest przechowywany w folderze o nazwie raporty budżetu na dysku twardym o nazwie Macintosh HD:

=HYPERLINK("Macintosh HD:Budget Reports:First Quarter", "Click here")

Możesz utworzyć linki w arkuszu, aby przeskoczyć z jednej komórki do innej. Jeśli na przykład aktywnym arkuszem jest arkusz o nazwie czerwiec w skoroszycie o nazwie budżet, Poniższa formuła tworzy łącze do komórki E56. Sam tekst linku to wartość znajdująca się w komórce E56.

=HYPERLINK("[Budget]June!E56", E56)

Aby skoczyć do innego arkusza w tym samym skoroszycie, należy zmienić nazwę arkusza w linku. W poprzednim przykładzie, aby utworzyć link do komórki E56 w arkuszu Wrzesień, należy zmienić słowo "Czerwiec" na słowo "Wrzesień".

Po kliknięciu linku do adresu e-mail program poczty e-mail zostanie automatycznie uruchomiony i zostanie utworzona wiadomość e-mail z prawidłowym adresem w polu do , pod warunkiem, że jest zainstalowany program poczty e-mail.

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć link.

    Możesz również zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować link.

    • Na karcie Wstawianie w grupie łącza kliknij przycisk Połącz Przycisk Hiperłącze .

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub obiekt, a następnie kliknąć polecenie link w menu skrótów lub nacisnąć klawisze CTRL + K.

  2. W obszarze Połącz z kliknij opcję Adres e-mail.

  3. W polu adres e-mail wpisz odpowiedni adres e-mail.

  4. W polu Temat wpisz temat wiadomości e-mail.

    Uwaga: Niektóre przeglądarki sieci Web i programy poczty e-mail mogą nie rozpoznawać wiersza tematu.

  5. W polu tekst do wyświetlenia wpisz tekst, który ma reprezentować link.

  6. Aby przydatne informacje były wyświetlane po umieszczeniu wskaźnika na łączu, kliknij pozycję etykietka ekranowa, wpisz odpowiedni tekst w polu tekst etykietki ekranowej , a następnie kliknij przycisk OK.

    Możesz również utworzyć link do adresu e-mail w komórce, wpisując adres bezpośrednio w komórce. Na przykład link jest tworzony automatycznie po wpisaniu adresu e-mail, na przykład someone@example.com.

Możesz wstawić co najmniej jedno odwołanie zewnętrzne (nazywane również linkami) ze skoroszytu do innego skoroszytu znajdującego się na intranet lub w Internecie. Skoroszyt nie może zostać zapisany jako plik HTML.

  1. Otwórz źródłowy skoroszyt i zaznacz komórkę lub zakres komórek do skopiowania.

  2. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj.

    Przyciski Kopiuj i Wklej na karcie Narzędzia główne
  3. Przejdź do arkusza, w którym chcesz umieścić informacje, a następnie kliknij komórkę, w której mają się pojawić informacje.

  4. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Wklej specjalnie.

  5. Kliknij pozycję Wklej łącze.

    W programie Excel zostanie utworzony link odwołania zewnętrznego dla zaznaczonej komórki lub wszystkich komórek z zakresu.

Uwaga: Można także utworzyć link odwołania zewnętrznego bez otwierania skoroszytu w sieci Web. W przypadku każdej komórki w skoroszycie docelowym, w której chcesz dodać łącze do odwołania zewnętrznego, kliknij komórkę, a następnie wpisz znak równości (=), adres URL i lokalizację w skoroszycie. Na przykład:

= "http://www.someones.homepage/[file.xls] Arkusz1"! A1

= "FTP. Server. gdzieś/file.xls"! MyNamedCell

Aby wybrać hiperlink bez uaktywniania łącza do miejsce docelowe, wykonaj jedną z następujących czynności:

  • Kliknij komórkę zawierającą link, przytrzymaj przycisk myszy, aż wskaźnik zmieni się w Wskaźnik zaznaczenia w programie Excel krzyżyk, a następnie zwolnij przycisk myszy.

  • Za pomocą klawiszy strzałek wybierz komórkę zawierającą link.

  • Jeśli łącze jest reprezentowane przez grafikę, przytrzymaj naciśnięty klawisz Ctrl i kliknij tę grafikę.

Istniejące łącze w skoroszycie można zmienić, zmieniając jego miejsce docelowe, wygląd lub tekst lub grafikę, które są używane do reprezentowania.

Zmienianie lokalizacji docelowej linku

  1. Zaznacz komórkę lub grafikę zawierającą link, który chcesz zmienić.

    Porada: Aby zaznaczyć komórkę, która zawiera link, nie przechodząc do miejsca docelowego linku, kliknij komórkę i przytrzymaj przycisk myszy, aż wskaźnik zmieni się w Wskaźnik zaznaczenia w programie Excel krzyżowe, a następnie zwolnij przycisk myszy. Komórkę można także zaznaczyć za pomocą klawiszy strzałek. Aby zaznaczyć grafikę, przytrzymaj naciśnięty klawisz Ctrl i kliknij tę grafikę.

    • Na karcie Wstawianie w grupie łącza kliknij przycisk link. Przycisk Hiperłącze

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub grafikę, a następnie w menu skrótów kliknąć polecenie Edytuj łącze lub nacisnąć klawisze CTRL + K.

  2. Wprowadź odpowiednie zmiany w oknie dialogowym Edytowanie hiperlinku .

    Uwaga: Jeśli łącze zostało utworzone za pomocą funkcji HIPERŁĄCZe, należy edytować formułę, aby zmienić miejsce docelowe. Zaznacz komórkę zawierającą łącze, a następnie kliknij pasek formuły, aby edytować formułę.

Możesz zmienić wygląd całego tekstu linku w bieżącym skoroszycie, zmieniając styl komórki dla łączy.

  1. Na karcie Narzędzia główne w grupie Style kliknij przycisk Style komórki.

  2. W obszarze Dane i model wykonaj następujące czynności:

    • Aby zmienić wygląd łączy, które nie zostały kliknięte, aby przejść do ich miejsc docelowych, kliknij łączeprawym przyciskiem myszy, a następnie kliknij polecenie Modyfikuj.

    • Aby zmienić wygląd łączy, które zostały kliknięte, aby przejść do ich miejsc docelowych, kliknij prawym przyciskiem myszy pozycję Odwiedzone łącze, a następnie kliknij polecenie Modyfikuj.

      Uwaga: Styl linku do komórki jest dostępny tylko w przypadku, gdy skoroszyt zawiera link. Styl komórki odwiedzony link jest dostępny tylko wtedy, gdy skoroszyt zawiera łącze, które zostało kliknięte.

  3. W oknie dialogowym Styl kliknij przycisk Formatuj.

  4. Na kartach Czcionka i Wypełnienie zaznacz odpowiednie opcje formatowania, a następnie kliknij przycisk OK.

    Uwagi: 

    • Opcje zaznaczone w oknie dialogowym Formatowanie komórek są wyświetlane jako zaznaczone w obszarze Styl zawiera w oknie dialogowym Styl. Można wyczyścić pola wyboru dla opcji, które nie mają być stosowane.

    • Zmiany wprowadzone w komórkach link i odwiedzony link będą dotyczyć wszystkich linków w bieżącym skoroszycie. Nie można zmienić wyglądu poszczególnych linków.

  1. Zaznacz komórkę lub grafikę zawierającą link, który chcesz zmienić.

    Porada: Aby zaznaczyć komórkę, która zawiera link, nie przechodząc do miejsca docelowego linku, kliknij komórkę i przytrzymaj przycisk myszy, aż wskaźnik zmieni się w Wskaźnik zaznaczenia w programie Excel krzyżowe, a następnie zwolnij przycisk myszy. Komórkę można także zaznaczyć za pomocą klawiszy strzałek. Aby zaznaczyć grafikę, przytrzymaj naciśnięty klawisz Ctrl i kliknij tę grafikę.

  2. Wykonaj co najmniej jedną z następujących czynności:

    • Aby zmienić tekst łącza, kliknij pasek formuły, a następnie Edytuj tekst.

    • Aby zmienić format grafiki, kliknij ją prawym przyciskiem myszy, a następnie kliknij opcję, która jest wymagana do zmiany jego formatu.

    • Aby zmienić tekst w grafice, kliknij dwukrotnie zaznaczoną grafikę, a następnie wprowadź odpowiednie zmiany.

    • Aby zmienić grafikę przedstawiającą link, Wstaw nową grafikę, nadaj jej link do tego samego miejsca docelowego, a następnie usuń starą grafikę i link.

  1. Kliknij prawym przyciskiem myszy hiperlink, które chcesz skopiować lub przenieść, a następnie kliknij polecenie Kopiuj lub Wytnij w menu skrótów.

  2. Kliknij prawym przyciskiem myszy komórkę, do której chcesz skopiować lub przenieść link, a następnie w menu skrótów kliknij polecenie Wklej .

Domyślnie nieokreślone ścieżki do hiperlink plików docelowych są względne w stosunku do lokalizacji aktywnego skoroszytu. Za pomocą tej procedury możesz ustawić inną ścieżkę domyślną. Za każdym razem, gdy tworzysz łącze do pliku w tej lokalizacji, wystarczy określić nazwę pliku, a nie ścieżkę, w oknie dialogowym Wstawianie hiperlinku .

Postępuj zgodnie z jednym z kroków w zależności od używanej wersji programu Excel:

  • W Excel 2016, Excel 2013 i Excel 2010:

    1. Kliknij kartę Plik.

    2. Kliknij pozycję Informacje.

    3. Kliknij pozycję Właściwości, a następnie wybierz pozycję Właściwości zaawansowane.

      Właściwości zaawansowane
    4. Na karcie Podsumowanie w polu tekstowym podstawa hiperłącza wpisz ścieżkę, której chcesz użyć.

      Uwaga: Adres bazowy łącza można zastąpić, używając pełnego lub bezwzględnego adresu dla linku w oknie dialogowym Wstawianie hiperlinku .

  • W Excel 2007:

    1. Kliknij przycisk pakietu Microsoft Office , Obraz przycisku pakietu Office kliknij pozycję Przygotuj, a następnie kliknij pozycję Właściwości.

    2. W panelu informacji o dokumencie kliknij pozycję Właściwości, a następnie kliknij pozycję Właściwości zaawansowane.

      Właściwości zaawansowane
    3. Kliknij kartę Podsumowanie.

    4. W polu Baza hiperłącza wpisz ścieżkę, której chcesz użyć.

    Uwaga: Adres bazowy łącza można zastąpić, używając pełnego lub bezwzględnego adresu dla linku w oknie dialogowym Wstawianie hiperlinku .

Aby usunąć link, wykonaj dowolną z następujących czynności:

  • Aby usunąć link i tekst, który je reprezentuje, kliknij prawym przyciskiem myszy komórkę zawierającą link, a następnie w menu skrótów kliknij polecenie Wyczyść zawartość .

  • Aby usunąć link i grafikę, która je reprezentuje, przytrzymaj naciśnięty klawisz Ctrl i kliknij grafikę, a następnie naciśnij klawisz Delete.

  • Aby wyłączyć jedno łącze, kliknij je prawym przyciskiem myszy, a następnie w menu skrótów kliknij polecenie Usuń łącze .

  • Aby wyłączyć kilka linków jednocześnie, wykonaj następujące czynności:

    1. W pustej komórce wpisz cyfrę 1.

    2. Kliknij komórkę prawym przyciskiem myszy, a następnie w menu skrótów kliknij polecenie Kopiuj .

    3. Przytrzymaj naciśnięty klawisz Ctrl i zaznacz każde łącze, które chcesz wyłączyć.

      Porada: Aby zaznaczyć komórkę, w której znajduje się link, bez przechodzenia do miejsca docelowego linku, kliknij komórkę i przytrzymaj przycisk myszy, aż wskaźnik zmieni się w Wskaźnik zaznaczenia w programie Excel krzyżowe, a następnie zwolnij przycisk myszy.

    4. Na karcie Narzędzia główne w grupie Schowek kliknij strzałkę poniżej przycisku Wklej, a następnie kliknij polecenie Wklej specjalnie.

      Przyciski Kopiuj i Wklej na karcie Narzędzia główne
    5. W obszarze operacjakliknij pozycję pomnóż, a następnie kliknij przycisk OK.

    6. Na karcie Narzędzia główne w grupie Style kliknij przycisk Style komórki.

    7. W obszarze dobre, złe i neutralnewybierz pozycję normalny.

Po kliknięciu linku zostanie otwarta inna strona lub plik. Miejsce docelowe to często inna strona sieci Web, ale może również być obrazem, adresem e-mail lub programem. Sam link może być tekstem lub obrazem.

Gdy użytkownik witryny kliknie łącze, miejsce docelowe jest wyświetlane w przeglądarka sieci Web, otwarty lub uruchomiony, w zależności od typu miejsca docelowego. Na przykład łącze do strony przedstawia stronę w przeglądarce sieci Web, a łącze do pliku AVI otwiera plik w odtwarzaczu multimedialnym.

Jak są używane linki

Za pomocą łączy można wykonywać następujące czynności:

  • Przechodzenie do pliku lub strony sieci Web w sieci, w intranet lub w Internecie

  • Przechodzenie do pliku lub strony sieci Web, która ma zostać utworzona w przyszłości

  • Wysyłanie wiadomości e-mail

  • Uruchamianie transferu pliku, na przykład pobierania pliku z sieci lub sesji protokołu FTP

Gdy wskażesz tekst lub obraz, który zawiera link, wskaźnik przybierze kształt Wskaźnik w kształcie dłoni , co oznacza, że tekst lub obraz będzie miał wybrany element.

Co to jest i jak działa adres URL

Po utworzeniu linku jego miejsce docelowe jest kodowane jako adres URL (Uniform Resource Locator), na przykład:

http://example.microsoft.com/wiadomosci.htm

file://NazwaKomputera/FolderUdostepniony/NazwaPliku.htm

Adres URL zawiera protokół, taki jak HTTP, FTP lub plik, serwer sieci Web lub lokalizacja sieciowa oraz ocieżka i nazwa pliku. Na poniższej ilustracji określono części adresu URL:

Cztery składniki adresu URL

1. Używany protokół (http, ftp, file)

2. serwer sieci Web lub lokalizacja sieciowa

3. Ścieżka

4. Nazwa pliku

Linki bezwzględne i względne

Bezwzględny adres URL zawiera pełny adres, w tym protokół, serwer sieci Web i ścieżkę i nazwę pliku.

We względnym adresie URL brak jednej lub kilku części. Brakujące informacje są uzyskiwane ze strony zawierającej dany adres URL. Na przykład, gdy brak protokołu i serwera sieci Web, przeglądarka sieci Web używa protokołu i domeny, takiej jak com, org albo edu, bieżącej strony.

W sieci Web powszechne jest używanie względnych adresów URL, które zawierają jedynie częściową ścieżkę i nazwę pliku. Jeśli pliki zostaną przeniesione na inny serwer, wszystkie linki będą działać tak długo, jak długo względne pozycje stron pozostaną niezmienione. Na przykład łącze na Products.htm wskazuje stronę o nazwie apple.htm w folderze o nazwie jedzenie; Jeśli obie strony są przenoszone do folderu o nazwie jedzenie na innym serwerze, adres URL linku będzie nadal prawidłowy.

W skoroszycie programu Excel nieokreślone ścieżki do plików docelowych są domyślnie określane względem lokalizacji aktywnego skoroszytu. Możesz ustawić inny adres bazowy, który ma być używany domyślnie, aby każdemu tworzeniu linku do pliku w tej lokalizacji była tylko nazwa pliku, a nie ścieżka, w oknie dialogowym Wstawianie hiperlinku .

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć link.

  2. Na karcie Wstawianie kliknij pozycję Łącze.

    Możesz również kliknąć komórkę prawym przyciskiem myszy, a następnie kliknąć polecenie link w menu skrótów lub nacisnąć klawisze CTRL + K.

  3. W polu tekst wyświetlany wpisz tekst, który ma reprezentować link.

  4. W obszarze adres URLwpisz pełny adres URL (Uniform Resource Locator) strony sieci Web, do której chcesz utworzyć link.

  5. Kliknij przycisk OK.

Aby utworzyć link do lokalizacji w bieżącym skoroszycie, możesz zdefiniować nazwę komórek docelowych lub użyć odwołania do komórki.

  1. Aby użyć nazwy, należy nadać nazwy komórkom docelowym w skoroszycie.

    Definiowanie nazwy komórki lub zakresu komórek

    1. Zaznacz komórkę lub zakres komórek, który chcesz nazwać.

    2. W polu Nazwa na lewym końcu pasek formuły Obraz przycisku wpisz nazwę dla komórek, a następnie naciśnij klawisz ENTER.

      Uwaga:  Nazwy nie mogą zawierać spacji i muszą zaczynać się od litery.

  2. W arkuszu kliknij komórkę, w której chcesz utworzyć link.

  3. Na karcie Wstawianie kliknij pozycję Łącze.

    Możesz również kliknąć komórkę prawym przyciskiem myszy, a następnie kliknąć polecenie link w menu skrótów lub nacisnąć klawisze CTRL + K.

  4. W polu tekst wyświetlany wpisz tekst, który ma reprezentować link.

  5. W polu miejsce w tym dokumencie wprowadź zdefiniowaną nazwę lub odwołanie do komórki.

  6. Kliknij przycisk OK.

Po kliknięciu linku do adresu e-mail program poczty e-mail zostanie automatycznie uruchomiony i zostanie utworzona wiadomość e-mail z prawidłowym adresem w polu do , pod warunkiem, że jest zainstalowany program poczty e-mail.

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć link.

  2. Na karcie Wstawianie kliknij pozycję Łącze.

    Możesz również kliknąć komórkę prawym przyciskiem myszy, a następnie kliknąć polecenie link w menu skrótów lub nacisnąć klawisze CTRL + K.

  3. W polu tekst wyświetlany wpisz tekst, który ma reprezentować link.

  4. W obszarze adres e-mailwpisz odpowiedni adres e-mail.

  5. Kliknij przycisk OK.

Możesz również utworzyć link do adresu e-mail w komórce, wpisując adres bezpośrednio w komórce. Na przykład link jest tworzony automatycznie po wpisaniu adresu e-mail, na przykład someone@example.com.

Za pomocą funkcji hiperłącze można utworzyć łącze do adresu URL.

Uwaga: Link_location może być ciągiem tekstowym ujętym w cudzysłów lub odwołaniem do komórki zawierającej łącze jako ciąg tekstowy.

Aby wybrać hiperlink bez uaktywniania łącza do miejsce docelowe, wykonaj dowolną z następujących czynności:

  • Zaznacz komórkę, klikając ją, gdy wskaźnik myszy jest strzałką.

  • Za pomocą klawiszy strzałek wybierz komórkę zawierającą link.

Istniejące łącze w skoroszycie można zmienić, zmieniając jego miejsce docelowe, wygląd lub tekst, który będzie reprezentował.

  1. Zaznacz komórkę zawierającą link, który chcesz zmienić.

    Porada: Aby wybrać hiperlink bez uaktywniania łącza do miejsce docelowe, użyj klawiszy strzałek, aby zaznaczyć komórkę zawierającą link.

  2. Na karcie Wstawianie kliknij pozycję Łącze.

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub grafikę, a następnie w menu skrótów kliknąć polecenie Edytuj łącze lub nacisnąć klawisze CTRL + K.

  3. Wprowadź odpowiednie zmiany w oknie dialogowym Edytowanie hiperlinku .

    Uwaga: Jeśli łącze zostało utworzone za pomocą funkcji HIPERŁĄCZe, należy edytować formułę, aby zmienić miejsce docelowe. Zaznacz komórkę zawierającą łącze, a następnie kliknij pasek formuły, aby edytować formułę.

  1. Kliknij prawym przyciskiem myszy hiperlink, które chcesz skopiować lub przenieść, a następnie kliknij polecenie Kopiuj lub Wytnij w menu skrótów.

  2. Kliknij prawym przyciskiem myszy komórkę, do której chcesz skopiować lub przenieść link, a następnie w menu skrótów kliknij polecenie Wklej .

Aby usunąć link, wykonaj dowolną z następujących czynności:

  • Aby usunąć link, zaznacz komórkę i naciśnij klawisz Delete.

  • Aby wyłączyć link (Usuń link, ale pozostawić tekst, który go reprezentuje), kliknij komórkę prawym przyciskiem myszy, a następnie kliknij polecenie Usuń łącze.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Usuwanie lub wyłączanie linków

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×