Za pomocą prostej formuły można sumować liczby w zakresie (grupie komórek), ale podczas pracy z więcej niż kilkoma liczbami korzystanie z funkcji SUMA jest łatwiejsze. Na przykład formuła =SUMA(A2:A6) ma mniejsze prawdopodobieństwo błędów pisowni niż =A2+A3+A4+A5+A6.

Używanie funkcji SUMA z dwoma zakresami liczb

Oto formuła, która używa dwóch zakresówkomórek: =SUMA(A2:A4;C2:C3) sumuje liczby w zakresach A2:A4 i C2:C3. Aby uzyskać sumę 39787, należy nacisnąć klawisz Enter.

Aby utworzyć formułę:

  1. Wpisz =SUMA w komórce, a następnie nawias otwierający (.

  2. Aby wprowadzić pierwszy zakres formuły, nazywany argumentem (fragment danych, który musi zostać uruchomiony przez formułę), wpisz A2:A4 (lub zaznacz komórkę A2 i przeciągnij przez komórkę A6).

  3. Aby oddzielić pierwszy argument od następnego, wpisz przecinek (;).

  4. Wpisz drugi argument (C2:C3) (lub przeciągnij, aby zaznaczyć komórki).

  5. Wpisz nawias zamykający ),a następnie naciśnij klawisz Enter.

Każdy argument może być zakresem, liczbą lub pojedynczymi odwołaniami do komórek, oddzielając je przecinkami.

  • =SUMA(A2:A4;2429;10482)

  • =SUMA(4823;A3:A4;C2:C3)

  • =SUMA(4823;12335;9718;C2:C3)

  • =SUMA(A2;A3;A4;2429;10482)

Porada:  Jeśli chcesz zsumować kolumny lub wiersze liczb obok siebie, użyj funkcji Autosumowanie do zsumowania liczb.

Spróbuj użyć tej funkcji

Jeśli chcesz poeksymować z naszymi danymi przykładowymi, oto dane do użycia.

Można zobaczyć, jak działa funkcja SUMA, kopiując następującą tabelę do arkusza i wklejając ją do komórki A1.

Dane

-5

15

30

'5

PRAWDA

Formuła

Opis

Wynik

=SUMA(3;2)

Dodaje 3 i 2.

5

=SUMA("5";15;PRAWDA)

Dodaje 5, 15 i 1. Wartość tekstowa "5" jest najpierw tłumaczona na liczbę, a wartość logiczna PRAWDA jest najpierw tłumaczona na liczbę 1.

21

=SUMA(A2:A4)

Dodaje wartości z komórek od A2 do A4.

40

=SUMA(A2:A4;15)

Dodaje wartości z komórek od A2 do A4, a następnie dodaje do tego wyniku 15.

55

=SUMA(A5;A6;2)

Dodaje wartości w komórkach A5 i A6, a następnie dodaje do tego wyniku 2. Wartości nieliczbowe w odwołaniach nie są tłumaczone — wartość w komórce A5 ('5) i wartość w komórce A6 (PRAWDA) są traktowane jako tekst — wartości w tych komórkach są ignorowane.

2

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel lub uzyskać pomoc techniczną w społeczności witryny Answers.

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności

Poznaj szkolenia >

Uzyskuj nowe funkcje w pierwszej kolejności

Dołącz do niejawnych testerów firmy Microsoft >

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×