Histogram jest wykresem kolumnowym przedstawiającym dane dotyczące częstotliwości.

Uwaga: Ten temat zawiera tylko informacje dotyczące tworzenia histogramu. Aby uzyskać informacje na temat wykresów Pareto (posortowanych histogramów), zobacz Tworzenie wykresu Pareto.

  1. Zaznacz dane.

    Jest to typowy przykład danych histogramu.

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Kliknij pozycję Wstawianie > Wstaw wykres statystyczny > Histogram.

    Polecenie Histogram dostępne przy użyciu przycisku Wstaw wykres statystyczny

    Możesz również utworzyć histogram na karcie Wszystkie wykresy w obszarze Polecane wykresy.

Porady: 

  • Za pomocą kart Projektowanie i Formatowanie dostosuj wygląd wykresu.

  • Jeśli nie widzisz tych kart, kliknij w obrębie histogramu, aby dodać kartę Narzędzia wykresów do wstążki.

Karty Projektowanie i Formatowanie dla obszaru Narzędzia wykresów

  1. Kliknij prawym przyciskiem myszy oś poziomą wykresu, kliknij polecenie Formatujoś, a następnie kliknij polecenie Opcje osi.

    Polecenie Formatuj oś w menu skrótów
  2. Skorzystaj z informacji w poniższej tabeli, aby zdecydować, które opcje mają zostać ustawione na karcie Formatowanie okienko zadań.

    Opcja

    Opis

    Według kategorii

    Wybierz tę opcję, gdy kategorie (oś pozioma) są tekstowe, a nie numeryczne. Histogram będzie grupować te same kategorie i sumować wartości na osi wartości.

    Porada: Aby zliczyć liczbę wystąpień ciągów tekstowych, dodaj kolumnę i wypełnij ją wartością „1”, a następnie wykreśl histogram i ustaw przedziały Według kategorii.

    Automatyczne

    Jest to domyślne ustawienie histogramów. Szerokość kosza jest obliczana przy użyciu reguły odwołania normalnego Scotta.

    Szerokość przedziału

    Wprowadź dodatnią dziesiętną liczbę punktów danych w każdym zakresie.

    Liczba przedziałów

    Wprowadź liczbę przedziałów histogramu (w tym przedziałów przepełnienia i niedopełnienia).

    Przedział przepełnienia

    Zaznacz to pole wyboru, aby utworzyć kosz na wszystkie wartości powyżej wartości w polu po prawej stronie. Aby zmienić wartość, wprowadź w polu inną liczbę dziesiętną.

    Przedział niedopełnienia

    Zaznacz to pole wyboru, aby utworzyć kosz dla wszystkich wartości poniżej lub równych wartości w polu po prawej stronie. Aby zmienić wartość, wprowadź w polu inną liczbę dziesiętną.

    Okienko zadań Formatowanie osi

Porada: Aby dowiedzieć się więcej o histogramie i o tym, jak ułatwia on wizualizowanie danych statystycznych, zobacz ten wpis w blogu na temat histogramu, wykresu Pareto oraz wykresu wąsów i skrzynki Excel zespołu. Być może zainteresuje Cię także więcej informacji o innych nowych typach wykresów opisanych w tym wpisie w blogu.

Opcja automatyczna (reguła odniesienia normalnego Scotta)   

Formuła dla opcji Automatyczna

Zgodnie z regułą odniesienia normalnego Scotta minimalizowane jest obciążenie w wariancji histogramu w porównaniu z zestawem danych przy założeniu normalnego rozkładu danych.

Opcja binora przepełnienia   

Formuła dla opcji Przedział przepełnienia

Opcja Niedopełnienie przepływu   

Formuła dla opcji Przedział niedopełnienia
  1. Upewnij się, że został załadowany dodatek Analysis ToolPak. Aby uzyskać więcej informacji, zobacz Ładowanie dopak Analysis ToolPak w programie Excel.

  2. W arkuszu wpisz dane wejściowe w jednej kolumnie, dodając ewentualnie etykietę w pierwszej komórce.

    Pamiętaj o użyciu ilościowych danych numerycznych, takich jak ilości elementów lub wyniki testów. Narzędzie Histogram nie obsługuje jakościowych danych numerycznych, takich jak numery identyfikacyjne wprowadzone jako tekst.

  3. W następnej kolumnie wpisz wartości graniczne w kolejności rosnącej, dodając ewentualnie etykietę w pierwszej komórce.

    Warto użyć własnych wartości granicznych, ponieważ mogą się okazać przydatniejsze do analizy. Jeśli nie wprowadzisz wartości granicznych, narzędzie Histogram utworzy równomiernie rozłożone interwały graniczne, używając jako punktów początkowych i końcowych wartości minimalnych i maksymalnych w zakresie wejściowym.

  4. Kliknij pozycję Dane > Analiza danych.

    Przycisk Analiza danych w grupie Analiza danych

  5. Kliknij pozycję Histogram > OK.

    Okno dialogowe Analiza danych

  6. W obszarze Wejście zrób tak:

    1. W polu Zakres wejściowy wprowadź odwołanie do komórki dotyczącej zakresu danych zawierającego liczby wejściowe.

    2. W polu Zakres graniczny wprowadź odwołanie do komórki dotyczące zakresu zawierającego wartości graniczne.

      Jeśli w arkuszu były używane etykiety kolumn, możesz je uwzględnić w odwołaniach do komórek.

      Porada: Zamiast ręcznego wprowadzania odwołań możesz kliknąć przycisk Obraz przycisku aby tymczasowo zwinąć okno dialogowe i wybrać zakresy w arkuszu. Ponowne kliknięcie przycisku powoduje rozwinięcie okna dialogowego.

  7. Jeśli etykiety kolumn zostały uwzględnione w odwołaniach do komórek, zaznacz pole wyboru Etykiety.

  8. W obszarze Opcje danych wyjściowych wybierz lokalizację danych wyjściowych.

    Możesz umieścić histogram w tym samym arkuszu, w nowym arkuszu bieżącego skoroszytu lub w nowym skoroszycie.

  9. Zaznacz co najmniej jedno z następujących pól wyboru:

    Pareto (posortowany histogram) Powoduje wyświetlenie danych uporządkowanych według malejącej częstotliwości występowania.

    Łączny udział procentowy     Powoduje wyświetlenie łącznych udziałów procentowych i dodanie wiersza łącznego udziału procentowego do wykresu histogramu.

    Wykres wyjściowy     Powoduje wyświetlenie osadzonego wykresu histogramu.

  10. Kliknij przycisk OK.

    Jeśli chcesz dostosować histogram, możesz zmienić etykiety tekstowe i kliknąć dowolne miejsce na wykresie histogramu, aby użyć przycisków Elementywykresu, Style wykresu i Filtr wykresu po prawej stronie wykresu.

  1. Zaznacz dane.

    Jest to typowy przykład danych histogramu.

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Kliknij pozycję Wstawianie > Wykres.

    Przycisk Wykres w grupie Ilustracje na karcie Wstawianie w programie Word
  3. W oknie dialogowym Wstawianie wykresu w obszarze Wszystkie wykresykliknij pozycję Histogram i kliknij przycisk OK.

Porady: 

  • Za pomocą kart Projektowanie i Formatowanie na wstążce dostosuj wygląd wykresu.

  • Jeśli nie widzisz tych kart, kliknij w obrębie histogramu, aby dodać kartę Narzędzia wykresów do wstążki.

Karty Projektowanie i Formatowanie dla obszaru Narzędzia wykresów

  1. Kliknij prawym przyciskiem myszy oś poziomą wykresu, kliknij polecenie Formatujoś, a następnie kliknij polecenie Opcje osi.

    Polecenie Formatuj oś w menu skrótów
  2. Skorzystaj z informacji w poniższej tabeli, aby zdecydować, które opcje mają zostać ustawione na karcie Formatowanie okienko zadań.

    Opcja

    Opis

    Według kategorii

    Wybierz tę opcję, gdy kategorie (oś pozioma) są tekstowe, a nie numeryczne. Histogram będzie grupować te same kategorie i sumować wartości na osi wartości.

    Porada: Aby zliczyć liczbę wystąpień ciągów tekstowych, dodaj kolumnę i wypełnij ją wartością „1”, a następnie wykreśl histogram i ustaw przedziały Według kategorii.

    Automatyczne

    Jest to domyślne ustawienie histogramów.

    Szerokość przedziału

    Wprowadź dodatnią dziesiętną liczbę punktów danych w każdym zakresie.

    Liczba przedziałów

    Wprowadź liczbę przedziałów histogramu (w tym przedziałów przepełnienia i niedopełnienia).

    Przedział przepełnienia

    Zaznacz to pole wyboru, aby utworzyć kosz na wszystkie wartości powyżej wartości w polu po prawej stronie. Aby zmienić wartość, wprowadź w polu inną liczbę dziesiętną.

    Przedział niedopełnienia

    Zaznacz to pole wyboru, aby utworzyć kosz dla wszystkich wartości poniżej lub równych wartości w polu po prawej stronie. Aby zmienić wartość, wprowadź w polu inną liczbę dziesiętną.

    Okienko zadań Formatowanie osi

Wykonaj poniższe czynności, aby utworzyć histogram w programie Excel dla komputerów Mac:

  1. Zaznacz dane.

    Jest to typowy przykład danych histogramu.

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Na wstążce kliknij kartę Wstawianie, a następnie kliknij pozycję Ikona wykresu statystycznego( Ikona statystyczne) i w obszarze Histogramwybierz pozycję Histogram.

Porady: 

  • Za pomocą kart Projekt wykresu i Formatowanie dostosuj wygląd wykresu.

  • Jeśli nie widzisz kart Projekt wykresu i Formatowanie, kliknij w dowolnym miejscu histogramu, aby dodać je do wstążki.

Aby utworzyć histogram w programie Excel 2011 dla komputerów Mac, musisz pobrać dodatek innej firmy. Aby uzyskać więcej szczegółowych informacji, zobacz: Nie mogę znaleźć dokuczania Analysis Toolpak w programie Excel 2011 dla komputerów Mac.

W programie Excel Online można wyświetlić histogram (wykres kolumnowy z danymi częstotliwości), ale nie można go utworzyć, ponieważ wymaga on dodatku Analysis ToolPak dodatku Excel, który nie jest obsługiwany w programie Excel dla sieci Web.

Jeśli masz aplikację Excel, możesz użyć przycisku Edytuj w programie Excel, aby otworzyć Excel na pulpicie i utworzyć histogram.

Przycisk edytowania w programie Excel

  1. Naciśnij, aby zaznaczyć dane.

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Jeśli masz telefon, naciśnij ikonę edycji w Ikona Edytuj , aby wyświetlić wstążkę. a następnie naciśnij pozycję Narzędzia startowe.

  3. Naciśnij pozycję Wstaw > wykresy > Histogram.

    W razie potrzeby możesz dostosować elementy wykresu.

    Uwaga: Ta funkcja jest dostępna tylko dla posiadaczy subskrypcji platformy Microsoft 365. Jeśli jesteś subskrybentem usługi Microsoft 365, upewnij się, że masz najnowszą wersję pakietu Office.

    Link umożliwiający wypróbowanie lub kupno platformy Microsoft 365

  1. Naciśnij, aby zaznaczyć dane.

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Jeśli masz telefon, naciśnij ikonę edycji w Ikona Edytuj , aby wyświetlić wstążkę, a następnie naciśnij pozycję Narzędzia startowe.

  3. Naciśnij pozycję Wstaw > wykresy > Histogram.

Aby utworzyć histogram w programie Excel, należy podać dwa typy danych — dane, które mają być analizowane, oraz wartości przedziałów reprezentujących interwały, według których będzie mierzyna częstotliwość. Należy uporządkować dane w dwóch kolumnach w arkuszu. Te kolumny muszą zawierać następujące dane:

  • Dane wejściowe    To są dane, które chcesz analizować za pomocą narzędzia Histogram.

  • Bin numbers    Te liczby reprezentują interwały, których narzędzie Histogram ma używać do mierzenia danych wejściowych podczas analizy danych.

Gdy używasz narzędzia Histogram, Excel zlicza punkty danych w każdym koszu danych. Punkt danych jest uwzględniany w określonym koszu, jeśli liczba jest większa niż najniższa granica i równa lub mniejsza niż największa granica dla tego binu danych. Jeśli zakres przedziałów zostanie pominięty, Excel zestaw równomiernie rozłożonych przedziałów między wartościami minimalnymi i maksymalnymi danych wejściowych.

Wynik analizy histogramu zostanie wyświetlony w nowym arkuszu (lub w nowym skoroszycie) i zostanie wyświetlony tabela histogramu oraz wykres kolumnowy, który odzwierciedla dane w tabeli histogramu.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel lub uzyskać pomoc techniczną w społeczności witryny Answers.

Zobacz też

Tworzenie wykresu wodospadowego

Tworzenie wykresu Pareto

Tworzenie wykresu sunburst w programie Office

Tworzenie wykresu w formie skrzynki i wąsów

Tworzenie wykresu mapy drzewa w programie Office

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jak zadowalająca jest jakość tłumaczenia?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×