Aby utworzyć link dynamiczny między zawartością dokumentu a zawartością prezentacji programu PowerPoint, można wstawić zawartość jako obiekt. Wstawienie zawartości jako obiektu połączonego lub osadzonego, w przeciwieństwie do jej wklejania (na przykład przez naciśnięcie klawiszy Ctrl+V), umożliwia dalszą pracę z zawartością w oryginalnym programie, w którym została utworzona.
Jeśli wstawisz slajd do dokumentu jako obiekt programu PowerPoint, program Word uruchomi program PowerPoint po dwukrotnym kliknięciu slajdu i będzie można pracować ze slajdem przy użyciu poleceń programu PowerPoint.
W przypadku wstawienia całej prezentacji programu PowerPoint jako obiektu w dokumencie będzie wyświetlany tylko jeden slajd. Aby wyświetlić inne slajdy, kliknij dwukrotnie obiekt programu PowerPoint, a następnie naciśnij klawisz Enter, aby uruchomić pokaz slajdów.
Wstawianie obiektu połączonego lub osadzonego
Jeden lub więcej slajdów można połączyć albo osadzić. Można także osadzić całą prezentację. W przypadku osadzenia obiektu prezentacji programu PowerPoint w dokumencie program Word uruchamia pokaz slajdów programu PowerPoint po dwukrotnym kliknięciu obiektu prezentacji w dokumencie. W dokumencie nie można edytować prezentacji. Obiekt prezentacji można tylko osadzić, a nie połączyć.
Otwórz dokument programu Word i prezentację programu PowerPoint zawierającą slajdy, na podstawie których chcesz utworzyć obiekt połączony lub osadzony.
Przejdź do programu PowerPoint, a następnie zaznacz całą prezentację lub odpowiednie slajdy.
Uwaga
Aby zaznaczyć slajdy, w widoku Sortowanie slajdów kliknij odpowiedni slajd. Aby zaznaczyć zakres slajdów, przytrzymaj naciśnięty klawisz Shift podczas klikania pierwszego i ostatniego slajdu zakresu. Aby zaznaczyć wiele slajdów, które nie znajdują się obok siebie, przytrzymaj naciśnięty klawisz CTRL podczas klikania odpowiednich slajdów.
Naciśnij klawisze Ctrl+C.
Przejdź do dokumentu programu Word, a następnie kliknij miejsce, w którym mają być wyświetlane informacje.
Na karcie Narzędzia główne w grupie Schowek kliknij strzałkę poniżej przycisku Wklej, a następnie kliknij polecenie Wklej specjalnie.
Na liście Jako wybierz pozycję Obiekt Prezentacja programu Microsoft PowerPoint lub Obiekt Slajd programu Microsoft PowerPoint.
Wybierz pozycję Wklej, aby wstawić obiekt osadzony, lub pozycję Wklej łącze, aby wstawić link do obiektu, a następnie kliknij przycisk OK.
Ewentualnie możesz wstawić link do obiektu w następujący sposób.
- Na karcie Wstawianie w grupie Tekst kliknij strzałkę obok pozycji Obiekt, a następnie wybierz pozycję Obiekt.
- Kliknij kartę Utwórz z pliku, a następnie przejdź do lokalizacji prezentacji.
- Wybierz pozycję Łącze do pliku lub pozycję Wyświetl jako ikonę, a następnie kliknij przycisk OK.
Aktualizowanie obiektów połączonych
Domyślnie obiekty połączone są aktualizowane automatycznie. Oznacza to, że program Word aktualizuje informacje połączone za każdym razem, gdy otwierasz plik programu Word lub gdy plik źródłowy programu PowerPoint zmienia się, gdy plik programu Word jest otwarty. Dla pojedynczych obiektów połączonych można jednak zmienić ustawienia, dzięki czemu obiekt połączony nie będzie aktualizowany lub będzie aktualizowany tylko wówczas, gdy osoba czytająca dokument zaktualizuje go ręcznie.
Dodatkowo można zapobiec aktualizowaniu linków przez program Word we wszystkich otwieranych dokumentach. Może to być środek ostrożności zapobiegający aktualizowaniu dokumentów na podstawie plików, które mogą pochodzić z niezaufanego źródła.
Ważne
Po otwarciu dokumentu zawierającego obiekty połączone w programie Word zostanie wyświetlony monit o zaktualizowanie dokumentu na podstawie danych z plików połączonych. W przypadku podejrzenia, że pliki połączone mogą pochodzić z niezaufanego źródła, kliknij przycisk Nie w komunikacie.
Ponadto można całkowicie zerwać połączenie między obiektem połączonym a jego plikiem źródłowym programu PowerPoint. Po zerwaniu połączenia nie będzie można edytować obiektu w dokumencie — stanie się on obrazem zawartości programu PowerPoint.
Ręczne aktualizowanie obiektu połączonego
- Kliknij prawym przyciskiem myszy obiekt połączony, a następnie kliknij polecenie Aktualizuj łącze.
- Możesz też kliknąć prawym przyciskiem myszy obiekt połączony, kliknąć polecenie Połączony obiekt Slajd lub Połączony obiekt Prezentacja, a następnie kliknąć polecenie Łącza.
- Kliknij link, który chcesz zaktualizować ręcznie, a następnie w obszarze Metoda aktualizowania wybranego łącza kliknij pozycję Ręczna aktualizacja.
Określenie, że obiekt połączony nie będzie aktualizowany
- Kliknij prawym przyciskiem myszy obiekt połączony, a następnie kliknij polecenie Połączone łącza obiektów>.
- Możesz też kliknąć prawym przyciskiem myszy obiekt połączony, kliknąć polecenie Połączony obiekt Slajd lub Połączony obiekt Prezentacja, a następnie kliknąć polecenie Łącza.
- Kliknij link, którego aktualizowaniu chcesz zapobiec, a następnie w obszarze Metoda aktualizowania wybranego łącza zaznacz pole wyboru Zablokowane.
Uwaga
Aby odblokować link, wyczyść pole wyboru Blokada.
Zapobieganie automatycznemu aktualizowaniu linków przez program Word we wszystkich dokumentach
- Na karcie Plik kliknij pozycję Opcje.
- Kliknij przycisk Zaawansowane , a następnie przewiń w dół do pozycji Ogólne.
- Wyczyść pole wyboru Aktualizuj łącza automatycznie przy otwarciu.
Zrywanie połączenia między obiektem połączonym a jego źródłem
- Kliknij prawym przyciskiem myszy obiekt połączony, a następnie kliknij polecenie Połączone łącza obiektów>.
- Możesz też kliknąć prawym przyciskiem myszy obiekt połączony, kliknąć polecenie Połączony obiekt Slajd lub Połączony obiekt Prezentacja, a następnie kliknąć polecenie Łącza.
- Kliknij link, który chcesz rozłączyć, a następnie kliknij przycisk Przerwij łącze.
Zmienianie obiektów połączonych lub osadzonych
- Kliknij prawym przyciskiem myszy obiekt połączony, a następnie kliknij polecenie Obiekt połączony.
- Możesz też kliknąć prawym przyciskiem myszy obiekt połączony, a następnie kliknąć polecenie Połączony obiekt Slajd lub Połączony obiekt Prezentacja.
- Kliknij pozycję Edytuj łącze lub Otwórz łącze, w zależności od tego, czy obiekt jest osadzony, czy połączony, a następnie wprowadź odpowiednie zmiany.
W przypadku obiektu osadzonego zmiany są wprowadzane tylko w kopii, która jest w dokumencie. W przypadku obiektu połączonego zmiany są wprowadzane w pliku źródłowym.
Różnice między obiektami połączonymi a obiektami osadzonymi
Podstawową różnicą między obiektami połączonymi a obiektami osadzonymi jest miejsce przechowywania danych i sposób ich aktualizacji po umieszczeniu w pliku docelowym.
W dokumencie jest umieszczany link do obiektu lub kopii obiektu. W ten sposób można wstawiać zawartość z dowolnego programu, który obsługuje technologię łączenia i osadzania obiektów (łączenie i osadzanie obiektów, czyli OLE).
Miesięczny raport stanu może na przykład zawierać informacje przechowywane oddzielnie na slajdzie programu PowerPoint. Jeśli raport zostanie połączony ze slajdem, dane w raporcie będzie można aktualizować za każdym razem, gdy plik źródłowy będzie aktualizowany. W przypadku osadzenia slajdu raport będzie zawierał statyczną kopię danych.
1. Obiekt osadzony
2. Obiekt połączony
3. Plik źródłowy
W przypadku obiektu połączonego informacje mogą być aktualizowane w razie zmodyfikowania pliku źródłowego. Połączone dane są przechowywane w pliku źródłowym. W pliku programu Word (pliku docelowym) jest przechowywana tylko lokalizacja pliku źródłowego i jest wyświetlane odwzorowanie połączonych danych. Jeśli rozmiar plików jest istotny, należy używać obiektów połączonych.
Tworzenie połączeń jest również przydatne, gdy chcesz zamieścić informacje, które są przechowywane osobno, takie jak dane zebrane przez inny dział, a w dokumencie programu Word muszą one być aktualne.
W przypadku osadzenia obiektu programu PowerPoint modyfikacja źródłowego pliku programu PowerPoint nie powoduje zmiany informacji w pliku programu Word. W chwili wstawienia obiekty osadzone stają się częścią pliku programu Word i przestają być związane z plikiem źródłowym.
Ponieważ informacje są w całości przechowywane w jednym dokumencie programu Word, osadzanie jest przydatne w sytuacjach, gdy nie chcesz, aby informacje odzwierciedlały zmiany w pliku źródłowym, lub gdy nie chcesz, aby odbiorcy dokumentu musieli pamiętać o aktualizowaniu połączonych informacji.