W programie Project możesz filtrować widok, tak aby wyświetlane były tylko krytyczne zadania, punkty kontrolne i inne informacje, które są dla Ciebie najważniejsze. Istnieją trzy sposoby filtrowania zadań i zasobów w projekcie. Wstępnie zdefiniowane filtry służące do wyświetlania określonych aspektów zadań i zasobów. Jeśli żaden z tych filtrów nie spełnia określonych wymagań, możesz utworzyć nowy filtr lub zmodyfikować istniejący.
- Wstępnie zdefiniowane filtry Są to filtry dostarczane z programem Project. Służą one do szybkiego filtrowania zadań lub zasobów, na przykład zadań nieukończonych lub zasobów z nadmierną alokacją.
- Filtry niestandardowe Są to filtry projektowane na potrzeby projektu.
- Autofiltry Gdy te opcje są włączone, są wyświetlane jako strzałki u góry każdej kolumny w widoku arkusza. Służą one do szybkiego filtrowania elementów w kolumnie.
W tym artykule
Filtrowanie zadań lub zasobów
Czasami jest konieczne wyświetlenie w projekcie tylko określonego typu informacji. Na przykład możesz wyświetlić tylko punkty kontrolne projektu lub zadania, które nie rozpoczęły się. Jeśli projekt obejmuje wiele zadań i wiele zasobów, filtry mogą być bardzo przydatne przy wyświetlaniu określonego zakresu informacji. Filtry pozwalają wyświetlić tylko te informacje, które Cię interesują, a resztę ukryć.
Dane zadań lub zasobów można filtrować przy użyciu wstępnie zdefiniowanych filtrów projektu. Jeśli żaden z filtrów nie spełnia określonych wymagań, możesz utworzyć nowy filtr lub zmodyfikować istniejący.
Stosowanie lub usuwanie filtru
Na karcie Widok w grupie Dane wybierz filtr z listy filtrów.
Aby zastosować filtr, którego nie ma na liście, wybierz pozycję Więcej filtrów, a następnie wykonaj jedną z następujących czynności:Aby wybrać filtr zadania, wybierz pozycję Zadanie, wybierz nazwę filtru na liście Filtry , a następnie wybierz pozycję Zastosuj.
Aby wybrać filtr zasobu, wybierz pozycję Zasób, wybierz nazwę filtru na liście Filtry , a następnie wybierz pozycję Zastosuj.
Uwaga
Filtrów zadań nie można stosować do widoków zasobów, a filtrów zasobów do widoków zadań.
Jeśli zastosujesz filtr interaktywny, wpisz żądane wartości, a następnie wybierz przycisk OK.
Aby wyłączyć filtr, wybierz pozycję Bez filtru z listy filtrów.
Stosowanie koloru do odfiltrowanych zadań za pomocą wyróżnienia
Podczas filtrowania zadań lub zasobów można zastosować wyróżnienie. Wyróżnione zadania lub zasoby są wyświetlane z nieodfiltrowanymi zadaniami, ale innym kolorem.
- Na karcie Widok w grupie Dane wybierz filtr z listy filtrów, a następnie wybierz pozycję Więcej filtrów.
- Wybierz filtr z listy filtrów, a następnie wybierz pozycję Wyróżnij.
Porada
Aby zastosować inny kolor do wyróżnionych zadań, użyj innego stylu tekstu. Wybierz kartę Formatowanie , a następnie pozycję Style tekstu. Na liście Element do zmiany wybierz pozycję Wyróżnione zadania, a następnie wybierz opcje formatowania.
Tworzenie filtru niestandardowego
- Na karcie Widok w grupie Dane wybierz strzałkę obok pozycji Filtr, a następnie wybierz pozycję Więcej filtrów.
- Wybierz pozycję Zadanie lub Zasób (w zależności od typu filtru, który chcesz utworzyć), a następnie wybierz pozycję Nowy.
- Wpisz nazwę nowego filtru. Wybierz pozycję Pokaż w menu , jeśli chcesz uwzględnić ten filtr na liście grup danych .
- W kolumnie I/Lub wybierz pozycję I , aby wyświetlić wyniki spełniające więcej niż jedno z kryteriów filtru.
Wybierz pozycję Lub, aby wyświetlić wiersze, które spełniają jedną lub drugą warunek.
- W kolumnie Nazwa pola wybierz pole, które chcesz filtrować.
- W kolumnie Test zdecyduj, jak chcesz dopasować wartość wybraną dla kolumny Nazwa pola do kolumny Wartości w następnym kroku.
- W kolumnie Wartości wybierz odpowiednią wartość lub wpisz nową.
Jeśli w kolumnie Test wybierzesz pozycję Równa się lub Nie równa się, możesz wpisać symbol wieloznaczny w kolumnie Wartości (zamiast wybierać opcję z listy). Na przykład wpisanie znaku zapytania (?) spowoduje znalezienie pojedynczych znaków. Wpisanie gwiazdki (*) powoduje znalezienie dowolnej liczby znaków. Jeśli używasz symboli wieloznacznych, upewnij się, że wybrana kolumna Nazwa pola zawiera tekst (na przykład Nazwa), a nie liczby (na przykład Czas_trwania). - Aby dodać kolejny wiersz do filtru (i wybrać inną nazwę pola do filtrowania), wybierz pozycję Wstaw wiersz. Wiersze można grupować, dodając wiersz pusty. Dodaj operator I bądź LUB w pustym wierszu, aby odfiltrować jedną grupę względem drugiej.
- Po zakończeniu wybierz pozycję Zapisz.
Porada
Aby szybko usunąć wszystkie filtry, użyj klawisza F3. Pamiętaj, że filtry zadań działają tylko z widokami zadań, a filtry zasobów tylko z widokami zasobów.
Modyfikowanie istniejącego filtru
Na karcie Widok w grupie Dane zaznacz listę filtrów, a następnie wybierz pozycję Więcej filtrów.
Wykonaj jedną z następujących czynności:
- Aby zmodyfikować filtr zadań, wybierz pozycję Zadanie, wybierz filtr, który chcesz zmodyfikować, a następnie wybierz pozycję Edytuj.
- Aby zmodyfikować filtr zasobu, wybierz pozycję Zasób, wybierz filtr, który chcesz zmodyfikować, a następnie wybierz pozycję Edytuj.
Zmodyfikuj ustawienia filtru za pomocą kontrolek w oknie dialogowym Definicja filtru .
Używanie Autofiltrów
Autofiltr można zastosować do pól w dowolnym widoku arkusza. Oprócz standardowych filtrów program Project udostępnia Autofiltry widoczne w górnej części każdej kolumny w widokach arkusza.
Stosowanie i usuwanie Autofiltrów
Na karcie Widok w grupie Dane wybierz strzałkę listy filtrów, a następnie wybierz pozycję Wyświetl Autofiltr.
Wybierz strzałkę Autofiltru obok nagłówka kolumny zawierającej informacje, które chcesz wyświetlić, a następnie wybierz wartość, aby przefiltrować tabelę.
Strzałka Autofiltr i nagłówek pola zmienią kolor na niebieski.Aby zastosować dodatkowy warunek na podstawie wartości w innej kolumnie, powtórz krok 2 dla innej kolumny.
Aby usunąć filtrowanie dla określonego wiersza, wybierz pozycję Wyczyść wszystkie filtry z listy Autofiltru dla tego pola.
Aby wyłączyć Autofiltry, wybierz ponownie pozycję Wyświetl Autofiltr .
Uwaga
Jeśli informacje w jednym z wierszy widoku ulegną zmianie, możesz odświeżyć ustawienia Autofiltru, wybierając strzałkę i ponownie wybierając wartości filtrowania.
Tworzenie Autofiltru niestandardowego
Wyświetlanie Autofiltrów.
Wybierz strzałkę Autofiltru, wskaż pozycję Filtr, a następnie wybierz pozycję Niestandardowy.
W pierwszym polu wybierz operator, którego chcesz użyć, a następnie w drugim polu wpisz lub wybierz wartość, którą chcesz dopasować.
Aby na przykład dopasować określoną datę w polu daty, w pierwszym polu wybierz operator "równa się ", a następnie w drugim polu wybierz datę, do której ma zostać dopasowana.Aby zastosować do Autofiltru dwa warunki, wykonaj jedną z następujących czynności:
- Aby wyświetlić w widoku wiersze spełniające oba warunki, wybierz operator i wartość w drugim wierszu pól, a następnie wybierz pozycję Oraz.
- Aby wyświetlić w widoku wiersze spełniające jeden lub inny warunek, wybierz operator i odpowiednią wartość w drugim wierszu pól, a następnie wybierz pozycję Lub.
Aby zapisać ustawienia Autofiltru, wybierz pozycję Zapisz.
Jeśli do widoku zastosowano już wstępnie zdefiniowany filtr, warunki ustawione dla Autofiltru zostaną uwzględnione jako warunki dodatkowe bieżącego filtru. Po zapisaniu ustawienia Autofiltru filtr jest zapisywany wraz z innymi filtrami w pliku i jest dostępny tylko za pośrednictwem okna dialogowego Więcej filtrów .
Automatyczne włączanie Autofiltru dla nowych projektów
- Na karcie Plik wybierz pozycję Opcje.
- Wybierz pozycję Zaawansowane, a następnie w sekcji Ogólne zaznacz pole wyboru Ustaw Autofiltr dla nowych projektów .