Po uruchomieniu funkcji duńskich w celu wygenerowania pliku faktur elektronicznych OIOUBL w systemie Microsoft Dynamics AX 2009 z dodatkiem Service Pack 1 system nie grupuje transakcji poliformowanych według kodu podatkowego.

Dotyczy
Dynamics AX 2009 Service Pack 1

Ten artykuł dotyczy oprogramowania Microsoft Dynamics AX dla regionu Danii (dk).

Objawy

Załóżmy, że zaksięgujesz zlecenie sprzedaży lub fakturę projektu zawierającą wiele linii transakcji w dodatku Service Pack 1 (SP1) dla oprogramowania Microsoft Dynamics AX 2009. W niektórych wierszach transakcji jest używany kod podatku od sprzedaży, a w innych — inny kod podatku. Po uruchomieniu funkcji duńskich w celu wygenerowania pliku faktury elektronicznej OIOUBL system nie grupuje transakcji podatkowych według kodu podatkowego w źródłowym języku XML (Extensible Markup Language) zgodnie z oczekiwaniami. Dlatego ostateczny plik OIOUBL nie jest opanowy opisem pliku i nie można wystawić faktur klientom z sektora publicznego.
Opis pliku jest widoczny w następującym linku:

http://www.oioubl.info/documents/en/en/Dokument/oioubl_guide_bibliotek.pdf
      

Przyczyna

Ten problem występuje, ponieważ docelowy kod XML wygeneruje również transakcje sumypodsubtotalne dla każdego wiersza transakcji. Dlatego ostateczny plik OIOUBL nie podlega opisowi pliku i zostanie odrzucony przez klientów z sektora publicznego.

Rozwiązanie

Informacje dotyczące poprawek

Obsługiwana poprawka jest dostępna od firmy Microsoft. W górnej części tego artykułu z bazy wiedzy znajduje się sekcja "Dostępne do pobrania poprawki". Jeśli napotkasz problem podczas pobierania, instalowania tej poprawki lub masz inne pytania dotyczące pomocy technicznej, skontaktuj się z partnerem lub, jeśli korzystasz z planu pomocy technicznej bezpośrednio z firmą Microsoft, możesz skontaktować się z pomocą techniczną dla oprogramowania Microsoft Dynamics i utworzyć nowy wniosek o pomoc techniczną. Aby to zrobić, odwiedź następującą witrynę internetową firmy Microsoft:

https://mbs.microsoft.com/support/newstart.aspx Możesz również skontaktować się z pomocą techniczną w zakresie oprogramowania Microsoft Dynamics telefonicznie, korzystając z tych linków w przypadku numerów telefonów określonych w danym kraju. Aby to zrobić, odwiedź jedną z następujących witryn internetowych firmy Microsoft:

Partnerzy

https://mbs.microsoft.com/partnersource/support/ Klienci

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm W specjalnych przypadkach opłaty, które są zwykle naliczane za połączenia z pomocą techniczną, mogą zostać anulowane, jeśli specjalista pomocy technicznej w zakresie oprogramowania Microsoft Dynamics i produktów pokrewnych stwierdzi, że określona aktualizacja rozwiąże problem. Typowe koszty pomocy technicznej będą miały zastosowanie do wszelkich dodatkowych pytań dotyczących pomocy technicznej i problemów, które nie kwalifikują się do określonej aktualizacji.

Informacje o instalacji

W przypadku dostosowań co najmniej jednej metody lub tabel, na które ma ona wpływ ta poprawka, należy wykonać następujące czynności:

  1. Przejrzyj zmiany opisane w pliku xpo.
  2. Zastosuj te zmiany w środowisku testowym przed zastosowaniem poprawki w środowisku produkcyjnym.

                
 Aby uzyskać więcej informacji na temat instalowania tej poprawki, kliknij następujący numer artykułu, aby wyświetlić ten artykuł w bazie wiedzy Baza wiedzy Microsoft Knowledge Base:

893082 Jak zainstalować poprawkę systemu Microsoft Dynamics AX

Wymagania wstępne

Aby zastosować tę poprawkę, musisz mieć zainstalowany dodatek Service Pack 1 dla oprogramowania Microsoft Dynamics AX 2009.

Wymóg ponownego uruchomienia

Po zastosowaniu tej poprawki należy ponownie uruchomić usługę Application Object Server (AOS).

Informacje o plikach

Wersja duńska tej poprawki zawiera atrybuty plików (lub nowsze atrybuty plików) wymienione w poniższej tabeli. Daty i godziny dla tych plików są wymienione w uniwersalnym czasie koordynowanym (UTC). Podczas wyświetlania informacji o pliku są konwertowane na czas lokalny. Aby znaleźć różnicę między czasem UTC a czasem lokalnym, użyj karty Strefa czasowa w elemencie Data i godzina w Panel sterowania.

Nazwa pliku Wersja pliku Rozmiar pliku Data Godzina Platforma
Eprojectinvoice_dk_oioubl.xsl Nie dotyczy 68,587 02-kwi-2012 05:43 Nie dotyczy
Esalesinvoice_dk_oioubl.xsl Nie dotyczy 63,607 02-kwi-2012 05:43 Nie dotyczy

Sprawdzanie poprawności instalacji poprawek aplikacji

Aby sprawdzić poprawność instalacji poprawki aplikacji, otwórz klasę SysHotfixManifest w drzewie obiektów aplikacji (AOT). Następnie sprawdź, czy istnieje metoda, której nazwa zawiera numer artykułu bazy wiedzy (KB) zainstalowanej poprawki. Ponadto można sprawdzać krzyżowo obiekty, których dotyczy problem, porównując plik.txt KBXXXXXX z obiektami w AOT. W ten sposób można się upewnić, że obiekty są poprawnie zmieniane w warstwie SYP lub w warstwie GLP.

Uwaga Symbol zastępczy XXXXXX odpowiada numerowi artykułu z bazy wiedzy zainstalowanej poprawki.

Stan

Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.

Więcej informacji

Aby uzyskać więcej informacji, kliknij następujący numer artykułu, aby wyświetlić ten artykuł w bazie wiedzy Baza wiedzy Microsoft Knowledge Base:

974255 funkcji Analiza wpływu dla systemu Dynamics AX 2009

Uwaga Jest to artykuł "SZYBKIE PUBLIKOWANIE" utworzony bezpośrednio z poziomu organizacji pomocy technicznej firmy Microsoft. Informacje zawarte w niniejszym artykule są dostarczane w stanie odpowiadającym na pojawiające się problemy. Ze względu na szybkość jego udostępnienia materiały mogą zawierać błędy typograficzne i mogą zostać poprawione w dowolnym momencie bez powiadomienia. Zobacz Warunki użytkowania , aby zapoznać się z innymi zagadnieniami.