Usługa NAS przestaje odpowiadać na zdarzenia po przekroeniu limitu czasu blokady w usłudze Microsoft Dynamics NAV

Dotyczy
Dynamics NAV 2009 Dynamics NAV 2009 Service Pack 1

Aplikacje Microsoft Business Solutions-Navision i Microsoft Navision są teraz częścią przeglądarki Microsoft Dynamics NAV. Wszystkie odwołania do programu Microsoft Business Solutions-Navision lub do usługi Microsoft Navision odnoszą się do programu Microsoft Dynamics NAV.

Ten artykuł dotyczy funkcji Microsoft Dynamics NAV dla wszystkich krajów i wszystkich ustawień regionalnych języków.

Objawy

Gdy limit czasu blokady występuje w usłudze Microsoft Dynamics NAV, serwer aplikacji Microsoft Dynamics NAV (NAS) przestaje odpowiadać na zdarzenia. Ponadto, gdy nas otrzymuje limit czasu blokady, NAS przetwarza tylko co drugą wiadomość z kolejki.

Przyczyna

Ten problem występuje, ponieważ nas traktuje limit czasu blokady jako błąd sieci. W związku z tym naS nie jest odłączony od bazy danych przed nas próbuje ponownie nawiązać połączenie z bazą danych.

Rozwiązanie

Informacje dotyczące poprawek

Obsługiwana poprawka jest teraz dostępna od firmy Microsoft. Poprawka naprawia problem opisany w tym artykule. Zastosuj poprawkę tylko do systemów, w których występuje ten konkretny problem.

Aby natychmiast rozwiązać ten problem, skontaktuj się z pomocą techniczną dla oprogramowania Microsoft Dynamics i powiązanych produktów w celu uzyskania poprawki. Możesz zalogować się do witryny usługi Microsoft Dynamics i utworzyć nowy wniosek o pomoc techniczną. Aby to zrobić, odwiedź następującą witrynę internetową firmy Microsoft:

https://mbs.microsoft.com/support/newstart.aspx Możesz również skontaktować się z pomocą techniczną w zakresie oprogramowania Microsoft Dynamics i pokrewnych produktów telefonicznie pod numerem (888) 477-7877.

Uwaga W specjalnych przypadkach opłaty, które zwykle naliczane są w związku z połączeniami pomocy technicznej, mogą zostać anulowane, jeśli specjalista pomocy technicznej w zakresie oprogramowania Microsoft Dynamics i produktów pokrewnych ustali, że określona aktualizacja rozwiąże problem. Typowe koszty pomocy technicznej będą miały zastosowanie do wszelkich dodatkowych pytań dotyczących pomocy technicznej i problemów, które nie kwalifikują się do określonej aktualizacji.

Wymagania wstępne

Aby zastosować tę poprawkę, musisz mieć zainstalowany dodatek Service Pack 3 dla oprogramowania Microsoft Dynamics NAV 4.0 z aktualizacją 6.

Jak uzyskać poprawkę systemu Microsoft Dynamics NAV lub zaktualizować pliki

Po zażądaniu poprawki Microsoft Dynamics NAV lub pliku aktualizacji od pomocy technicznej dotyczącej oprogramowania Microsoft Dynamics hiperlink zostanie wysłany do Ciebie w wiadomości e-mail.

Wiadomość e-mail będzie zawierać hiperlink i hasło. Hiperlink umożliwia pobranie poprawki Microsoft Dynamics NAV lub plików aktualizacji. Po kliknięciu hiperlinku zostanie otwarte okno dialogowe Pobieranie pliku — ostrzeżenie o zabezpieczeniach . Następnie zostanie wyświetlony monit o uruchomienie, zapisanie lub anulowanie pobierania.

Jeśli klikniesz przycisk Uruchom, pliki rozpoczną proces pobierania i wyodrębniania. Musisz określić folder dla nowych plików, a następnie podać hasło.

Jeśli klikniesz przycisk Zapisz, musisz określić ścieżkę zapisywania skompresowanego pliku. Po otwarciu zapisanego pliku zostanie wyświetlony monit o określenie ścieżki dla plików. Następnie musisz podać hasło podane w wiadomości e-mail.

Kliknięcie przycisku Anuluj powoduje zatrzymanie procesu pobierania.

Jak zainstalować poprawkę programu Microsoft Dynamics NAV lub plik aktualizacji

Poprawki i aktualizacje platformy Microsoft Dynamics NAV są udostępniane jako pojedyncze pliki. Aby zainstalować poprawkę lub aktualizację systemu Microsoft Dynamics NAV, musisz zamienić istniejące pliki instalacji microsoft dynamics NAV na poprawki lub pliki aktualizacji. W tym celu wykonaj następujące czynności:

  1. Użyj poprawki lub plików aktualizacji, aby zamienić pliki w instalacji klienta microsoft Dynamics NAV wymienione w następujących tabelach:

    Microsoft Dynamics NAV 2009

    Nazwa pliku Wersja pliku Rozmiar pliku Data Godzina Platforma
    Dbm.dll 6.0.30233.0 444,232 24-lis-2009 17:09 x86
    Fin.exe 6.0.30233.0 12,257,096 24-lis-2009 17:09 x86
    Finhlink.exe 6.0.30233.0 452,432 24-lis-2009 17:09 x86
    Finsql.exe 6.0.30233.0 12,343,120 24-lis-2009 17:09 x86
    Nc_netb.dll 6.0.30233.0 108,368 24-lis-2009 17:09 x86
    Nc_tcp.dll 6.0.30233.0 108,368 24-lis-2009 17:09 x86
    Nc_tcps.dll 6.0.30233.0 153,424 24-lis-2009 17:09 x86
    Ndbcs.dll 6.0.30233.0 1,333,072 24-lis-2009 17:09 x86
    Slave.exe 6.0.30233.0 161,616 24-lis-2009 17:09 x86

    Microsoft Dynamics NAV 2009 SP1

    Nazwa pliku Wersja pliku Rozmiar pliku Data Godzina Platforma
    Dbm.dll 6.0.30232.0 427,848 23-lis-2009 23:16 x86
    Fin.exe 6.0.30232.0 12,598,600 23-lis-2009 23:17 x86
    Finhlink.exe 6.0.30232.0 452,432 23-lis-2009 23:17 x86
    Finsql.exe 6.0.30232.0 12,713,808 23-lis-2009 23:17 x86
    Nc_netb.dll 6.0.30232.0 96,592 23-lis-2009 23:16 x86
    Nc_tcp.dll 6.0.30232.0 98,640 23-lis-2009 23:17 x86
    Nc_tcps.dll 6.0.30232.0 141,136 23-lis-2009 23:16 x86
    Ndbcs.dll 6.0.30232.0 1,348,944 23-lis-2009 23:16 x86
    Slave.exe 6.0.30232.0 152,400 23-lis-2009 23:16 x86

    Uwaga Zazwyczaj klient Microsoft Dynamics NAV jest instalowany w następującym folderze:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\Aby zamienić istniejące pliki, wykonaj następujące czynności:

    1. Zamknij program Microsoft Dynamics NAV.
    2. Znajdź folder instalacji klienta programu Microsoft Dynamics NAV.
    3. Skopiuj pobrane pliki.
    4. Wklej pobrane pliki do folderu instalacji klienta microsoft dynamics NAV.
    5. W oknie dialogowym Potwierdzanie zamieniania pliku kliknij przycisk Tak , aby zastąpić pliki w folderze instalacji.
  2. Zastąp pliki w instalacji programu Microsoft Dynamics NAV Application Server wymienione w poniższej tabeli:

    Microsoft Dynamics NAV 2009

    Nazwa pliku Wersja pliku Rozmiar pliku Data Godzina Platforma
    Dbm.dll 6.0.30233.0 444,232 24-lis-2009 02:13 x86
    Nas.exe 6.0.30233.0 2,082,632 24-lis-2009 02:13 x86
    Nassql.exe 6.0.30233.0 2,168,656 24-lis-2009 02:13 x86
    Ndbcs.dll 6.0.30233.0 1,333,072 24-lis-2009 02:13 x86
    Slave.exe 6.0.30233.0 161,616 24-lis-2009 02:13 x86

    Microsoft Dynamics NAV 2009 SP1

    Nazwa pliku Wersja pliku Rozmiar pliku Data Godzina Platforma
    Dbm.dll 6.0.30232.0 427,848 23-lis-2009 23:16 x86
    Nas.exe 6.0.30232.0 2,259,784 23-lis-2009 23:16 x86
    Nassql.exe 6.0.30232.0 2,352,464 23-lis-2009 23:16 x86
    Ndbcs.dll 6.0.30232.0 1,348,944 23-lis-2009 23:16 x86
    Slave.exe 6.0.30232.0 152,400 23-lis-2009 23:16 x86

    Aby zamienić pliki, wykonaj poniższe czynności.

    1. Zatrzymaj program Microsoft Dynamics NAV Application Server.
    2. Znajdź folder instalacji programu Microsoft Dynamics NAV Application Server. Zazwyczaj program Microsoft Dynamics NAV Application Server jest instalowany w następującym folderze:
      C:\Program Files\Microsoft Business Solutions-Navision\Application Server\
    3. Skopiuj pobrane pliki.
    4. Wklej pobrane pliki do folderu instalacji Microsoft Dynamics NAV Application Server.
    5. Kliknij przycisk Tak , aby zastąpić pliki w folderze.
    6. Uruchom program Microsoft Dynamics NAV Application Server.

Stan

Firma Microsoft potwierdziła, że jest to błąd w produktach firmy Microsoft wymienionych w sekcji "Dotyczy".

Więcej informacji

Aby uzyskać więcej informacji, kliknij następujący numer artykułu, aby wyświetlić ten artykuł w bazie wiedzy Baza wiedzy Microsoft Knowledge Base:

824684 Opis standardowej terminologii używanej do opisywania aktualizacji oprogramowania firmy Microsoft