Objawy
Instalujesz aktualizację zbiorczą programu SQL Server lub instalację programu SQL Server obejmującą aktualizację zbiorczą (określaną również jako instalacja strumieniowa poślizgowa) w wersji systemu Windows Server 2016, która ma włączony bezpieczny rozruch.
W tym scenariuszu program instalacyjny zgłasza błąd i kończy się niepowodzeniem lub kończy się powodzeniem, wyzwalając ostrzeżenia i komunikaty o błędach podobne do poniższych.
Komunikat o błędzie, gdy funkcja Filestream została wybrana podczas instalacji lub jest już włączona w istniejącej instalacji programu SQL Server, do której zastosowano aktualizację skumulowaną:
Uwaga
Wystąpił następujący błąd:
System Windows nie może zweryfikować podpisu cyfrowego tego pliku. Niedawna zmiana sprzętu lub oprogramowania mogła doprowadzić do instalacji pliku, który jest niepoprawnie podpisany lub uszkodzony albo może być złośliwym oprogramowaniem z nieznanego źródła.
Kliknij przycisk "Ponów próbę" lub ponów próbę wykonania nieudanej akcji lub kliknij przycisk "Anuluj", aby anulować tę akcję i kontynuować konfigurowanie.
A to:
Asystent zgodności programów
Uwaga
Wymagany jest sterownik podpisany cyfrowo
Sterownik rsFx
Microsoft Corporation
Komunikat ostrzegawczy, gdy funkcja Filestream nie jest wybrana podczas instalacji programu SQL Server z pominięciem aktualizacji skumulowanej:
Uwaga W tym scenariuszu nie można włączyć funkcji Filestream przy użyciu SQL Server Configuration Manager po zakończeniu konfiguracji.
W poniższej tabeli wymieniono kombinacje, w wyniku których te objawy mogą wystąpić w różnych wersjach programu SQL Server.
SQL Server 2016 (dotyczy aktualizacji CU2 dla wersji RTM)
| Kombinacja | Funkcja Filestream | Błąd/ostrzeżenie? |
|---|---|---|
| CU2 w SQL 2016 | Włączone | Błąd |
| SQL 2016+ CU2 Slipstream | Włączone | Błąd |
| SQL 2016+ CU2 Slipstream | Wyłączone lub niezaznaczone (domyślne) | Ostrzeżenie |
SQL Server 2014 (dotyczy aktualizacji CU9 dla dodatku SP1)
| Kombinacja | Funkcja Filestream | Błąd/ostrzeżenie? |
|---|---|---|
| CU9 on SQL 2014 SP1 | Włączone | Błąd |
| SQL 2014+ SP1+ CU9 Slipstream | Włączone | Błąd |
| SQL 2014+ SP1+ CU9 Slipstream | Wyłączone lub niezaznaczone (domyślne) | Ostrzeżenie |
SQL Server 2012 (dotyczy aktualizacji CU5 dla dodatku SP3 i aktualizacji CU14 dla dodatku SP2)
| Kombinacja | Funkcja Filestream | Błąd/ostrzeżenie? |
|---|---|---|
| CU5 dla SQL 2012 z dodatkiem SP3 | Włączone | Błąd |
| SQL 2012+ SP3+CU5 Slipstream | Włączone | Błąd |
| SQL 2012+ SP3+CU5 Slipstream | Wyłączone lub niezaznaczone (domyślne) | Ostrzeżenie |
| CU14 on SQL 2012 SP2 | Włączone | Błąd |
| SQL 2012+ SP2+CU14 Strumień poślizgowy | Włączone | Błąd |
| SQL 2012+ SP2+CU14 Strumień poślizgowy | Wyłączone lub niezaznaczone (domyślne) | Ostrzeżenie |
Uwaga: maszyny wirtualne typu Hyper-V Gen2 mają domyślnie włączony bezpieczny rozruch, dlatego użytkownicy są bardziej narażeni na ten problem podczas instalowania SQL 2016 i aktualizacji zbiorczej 2 (CU2) na systemie Windows Server 2016 lub Windows 10 na maszynie wirtualnej Hyper-V Gen2. Jednak ten problem może również wystąpić na serwerach fizycznych, jeśli jest włączony bezpieczny rozruch.
Rozwiązanie
Aby rozwiązać ten problem, należy zainstalować dodatek Service Pack 1 (SP1) dla programu Microsoft SQL Server 2016
SQL Server 2016
Aktualizacja zbiorcza 4 dla programu SQL Server 2016
SQL Server 2014
Aktualizacja zbiorcza 11 dla programu SQL Server 2014 z dodatkiem SP1
SQL Server 2012
Aktualizacja zbiorcza 7 dla programu SQL Server 2012 z dodatkiem Service Pack 3
Aktualizacja skumulowana 16 dla programu SQL Server 2012 z dodatkiem SP2
Zalecenie: zainstalowanie najnowszej aktualizacji zbiorczej dla programu SQL Server
Każda nowa aktualizacja zbiorcza programu SQL Server zawiera wszystkie poprawki zabezpieczeń uwzględnione w poprzedniej aktualizacji skumulowanej. Zalecamy pobranie i zainstalowanie najnowszych aktualizacji zbiorczych dla programu SQL Server:
Najnowsza aktualizacja zbiorcza dla programu SQL Server 2016
Najnowsza aktualizacja zbiorcza dla programu SQL Server 2014
Najnowsza aktualizacja zbiorcza dla programu SQL Server 2012 z dodatkiem SP3
Najnowsza aktualizacja zbiorcza dla programu SQL Server 2012 z dodatkiem SP2
Obejście
Aby obejść ten problem, zastosuj jedną z następujących metod, które mają zastosowanie do Twojego środowiska:
- Jeśli w Twoim środowisku nie jest używana funkcja Filestream, ten problem nie będzie Cię dotyczył, z wyjątkiem komunikatu ostrzegawczego wyświetlanego na końcu procesu instalacji. W tym scenariuszu można bezpiecznie zignorować ostrzeżenie.
- Jeśli funkcja Filestream/FileTable jest używana w danym środowisku i jest planowane zainstalowanie jednej z aktualizacji zbiorczych, na które wpływa problem, opisanych w sekcji "Objawy" systemu Windows Server 2016, można wybrać opcję tymczasowego wyłączenia bezpiecznego rozruchu. Pozwala to obejść ten problem do czasu wydania nadchodzącej wersji serwisowej zawierającej sterownik RsFx z podpisanym kodem.
- Jeśli funkcja Filestream/FileTable jest używana w danym środowisku i jeśli planowane jest zainstalowanie programu SQL Server 2016 na systemie Windows Server 2016 i nie można wyłączyć funkcji bezpiecznego rozruchu, zaleca się, aby nie instalować aktualizacji zbiorczych, których dotyczy problem. Zamiast tego poczekaj na przyszłą aktualizację zbiorczą, która ma podpisany sterownik RsFx.
Więcej informacji
- Filestream RsFx driver fails to load after installing SQL Server 2016 with CU2 on Windows Server 2016 with SecureBoot ON
- Wyłączanie funkcji Bezpieczny rozruch
- Aktualizacja zbiorcza 2 dla programu SQL Server 2016
- Aktualizacja zbiorcza 9 dla programu SQL Server 2014 z dodatkiem SP1
- Aktualizacja zbiorcza 5 dla programu SQL Server 2012 z dodatkiem Service Pack 3
- Aktualizacja zbiorcza 14 dla programu SQL Server 2012 z dodatkiem SP2