KB3040804 — POPRAWKA: Po uruchomieniu zadania sprawdzania poprawności kodu XML w programie SSIS 2012 lub SSIS 2014 występuje błąd "Odmowa dostępu"

Dotyczy
SQL Server 2012 Business Intelligence SQL Server 2014 Business Intelligence - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Objawy

Załóżmy, że zadanie sprawdzania poprawności danych XML jest uruchamiane w usłudze Microsoft SQL Server 2012 Integration Service (SSIS 2012) lub SQL Server 2014 Integration Service (SSIS 2014). Gdy wejściowy plik źródłowy jest w trybie tylko do odczytu, usługi SSIS zgłaszają błąd "Odmowa dostępu".

Przyczyna

Ten problem występuje, ponieważ w usługach SSIS 2012 domyślnym trybem dostępu do pliku źródłowego jest odczyt/zapis. Dlatego po otwarciu pliku źródłowego tylko do odczytu w domyślnym trybie dostępu do pliku przez program SSIS 2012 wystąpi błąd IOException powodujący błąd "Access Denied" (Odmowa dostępu).

Rozwiązanie

Informacje o aktualizacji zbiorczej

Ten problem został po raz pierwszy rozwiązany w następującej aktualizacji zbiorczej programu SQL Server.

Zalecenie: zainstalowanie najnowszej aktualizacji zbiorczej dla programu SQL Server

Każda nowa aktualizacja zbiorcza programu SQL Server zawiera wszystkie poprawki zabezpieczeń uwzględnione w poprzedniej aktualizacji skumulowanej. Zalecamy pobranie i zainstalowanie najnowszych aktualizacji zbiorczych dla programu SQL Server:

      

Stan

Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.