Objawy
Załóżmy, że zadanie sprawdzania poprawności danych XML jest uruchamiane w usłudze Microsoft SQL Server 2012 Integration Service (SSIS 2012) lub SQL Server 2014 Integration Service (SSIS 2014). Gdy wejściowy plik źródłowy jest w trybie tylko do odczytu, usługi SSIS zgłaszają błąd "Odmowa dostępu".
Przyczyna
Ten problem występuje, ponieważ w usługach SSIS 2012 domyślnym trybem dostępu do pliku źródłowego jest odczyt/zapis. Dlatego po otwarciu pliku źródłowego tylko do odczytu w domyślnym trybie dostępu do pliku przez program SSIS 2012 wystąpi błąd IOException powodujący błąd "Access Denied" (Odmowa dostępu).
Rozwiązanie
Informacje o aktualizacji zbiorczej
Ten problem został po raz pierwszy rozwiązany w następującej aktualizacji zbiorczej programu SQL Server.
- Aktualizacja zbiorcza 1 dla programu SQL Server 2014 z dodatkiem SP1
- Aktualizacja zbiorcza 7 dla programu SQL Server 2014
- Aktualizacja skumulowana 5 dla programu SQL Server 2012 z dodatkiem SP2
Zalecenie: zainstalowanie najnowszej aktualizacji zbiorczej dla programu SQL Server
Każda nowa aktualizacja zbiorcza programu SQL Server zawiera wszystkie poprawki zabezpieczeń uwzględnione w poprzedniej aktualizacji skumulowanej. Zalecamy pobranie i zainstalowanie najnowszych aktualizacji zbiorczych dla programu SQL Server:
- Najnowsza aktualizacja zbiorcza dla programu SQL Server 2014 z dodatkiem SP1
- Najnowsza aktualizacja zbiorcza dla programu SQL Server 2014
- Najnowsza aktualizacja zbiorcza dla programu SQL Server 2012 z dodatkiem SP2
Stan
Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.