KB2485396 - POPRAWKA: Błąd podczas korzystania z modułu renderowania twardego podziału strony w celu wyeksportowania raportu w SSRS 2008 R2, jeśli właściwość HideDuplicates nie jest ustawiona na None

Firma Microsoft dystrybuuje poprawki do programu Microsoft SQL Server 2008 R2 jako jeden plik do pobrania. Ponieważ poprawki są zbiorcze, każda nowa wersja zawiera wszystkie poprawki i poprawki zabezpieczeń zawarte w poprzedniej wersji poprawki programu SQL Server 2008 R2.

Objawy

Rozważmy następujący scenariusz:

  • Instalujesz program Microsoft SQL Server 2008 R2 Reporting Services (SSRS 2008 R2) na komputerze.

  • Tworzysz raport zawierający kontrolkę elementu tablix. Ta kontrolka elementu tablix zawiera pole tekstowe.

  • Właściwość HideDuplicates pola tekstowego należy ustawić na wartość należącą do zakresu raportu. Dlatego wartość tej właściwości nie jest ustawiona na wartość Brak.

  • Próbujesz renderować lub eksportować raport przy użyciu dowolnego modułu renderowania z twardym podziałem strony. Na przykład próbujesz użyć jednego z następujących modułów renderowania:

    • PDF
    • TIFF
    • Drukuj/Układ wydruku/Podgląd wydruku

W takim przypadku raport nie jest eksportowany. Ponadto w narzędziu do projektowania raportów jest wyświetlany następujący komunikat o błędzie:

Uwaga

Wystąpił błąd podczas przetwarzania raportu lokalnego.
(przetwarzanie): ScalableList: identyfikator indeksu <poza dozwolonym zakresem [0::<id-1>]>

Ponadto w Menedżerze raportów lub usłudze sieci Web serwera raportów jest wyświetlany następujący komunikat o błędzie:

Uwaga

Wystąpił błąd wewnętrzny na serwerze raportów. Więcej informacji można znaleźć w dzienniku błędów. (rsInternalError)
Opis: podczas wykonywania bieżącego żądania sieci Web wystąpił nieobsługiwany wyjątek. Przejrzyj śledzenie stosu, aby uzyskać więcej informacji o błędzie i miejscu jego pochodzenia w kodzie.
Szczegóły wyjątku: Microsoft.Reporting.WebForms.ReportServerException: Wystąpił błąd wewnętrzny na serwerze raportów. Więcej informacji można znaleźć w dzienniku błędów. (rsInternalError)
Błąd źródła:
Podczas wykonywania bieżącego żądania internetowego został wygenerowany nieobsługiwany wyjątek. Informacje dotyczące pochodzenia i lokalizacji wyjątku można zidentyfikować przy użyciu poniższego śledzenia stosu wyjątków.

Przyczyna

Ten problem występuje, ponieważ moduły renderowania z twardym podziałem strony zgłaszają wyjątek, gdy właściwość HideDuplicates nie jest ustawiona na wartość Brak dla pola tekstowego w kontrolce elementu tablix.

Rozwiązanie

Informacje o aktualizacji zbiorczej

SQL Server 2008 R2

Poprawka rozwiązująca ten problem została po raz pierwszy opublikowana w aktualizacji zbiorczej 6. Aby uzyskać więcej informacji dotyczących sposobu uzyskania tego pakietu aktualizacji zbiorczej dla programu SQL Server 2008 R2, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Baza wiedzy Microsoft Knowledge Base:

2489376 Pakiet 6 aktualizacji zbiorczych dla SQL Server 2008 R2 Uwaga Ponieważ te kompilacje mają charakter zbiorczy, każda nowa poprawka zawiera wszystkie poprawki i poprawki zabezpieczeń, które zostały uwzględnione w poprzedniej wersji poprawki SQL Server 2008 R2. Zalecamy rozważenie zastosowania najnowszej wersji poprawki zawierającej tę poprawkę. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Baza wiedzy Microsoft Knowledge Base:

981356 Kompilacje SQL Server 2008 R2 wydane po wydaniu SQL Server 2008 R2

Stan

Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.

Źródła informacji

Aby uzyskać więcej informacji o właściwości HideDuplicates pola tekstowego, odwiedź następującą witrynę sieci Microsoft Developer Network (MSDN) w sieci Web:

Ogólne informacje o właściwości HideDuplicates pola tekstowego
        
Aby uzyskać więcej informacji dotyczących modelu obsługi przyrostowej dla programu SQL Server, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Baza wiedzy Microsoft Knowledge Base:

935897 Zespół SQL Server udostępnia model obsługi przyrostowej w celu dostarczania poprawek dla zgłoszonych problemówAby uzyskać więcej informacji dotyczących schematu nazewnictwa dla SQL Server aktualizacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Baza wiedzy Microsoft Knowledge Base:

822499 Nowy schemat nazewnictwa pakietów aktualizacji oprogramowania firmy Microsoft SQL Server Aby uzyskać więcej informacji dotyczących terminologii związanej z aktualizacjami oprogramowania, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Baza wiedzy Microsoft Knowledge Base:

824684 Opis standardowej terminologii używanej do opisywania aktualizacji oprogramowania firmy Microsoft