KB5005689 — POPRAWKA: SQL Server nie uruchamia się z komunikatami o błędach, gdy zainicjowano nieprawidłowy certyfikat dla protokołu SSL

Dotyczy
SQL Server 2016 SQL Server 2016 Service Pack 3 - duplicate (do not use)

Objawy

Załóżmy, że ustanowiono nieprawidłowy certyfikat dla protokołu SSL. Program Microsoft SQL Server 2016 nie uruchamia się, a Instalator rejestruje następujące wpisy błędów w dzienniku błędów. Jednak te komunikaty nie wskazują, której właściwości brakuje.

Serwer nie może załadować certyfikatu wymaganego do zainicjowania połączenia SSL. Zwrócony został następujący błąd: 0x8009030e. Sprawdź certyfikaty, aby się upewnić, że są prawidłowe.

Błąd: 26014, Ważność: 16, Stan: 1.

Nie można załadować certyfikatu określonego przez użytkownika [Cert Hash(sha1) "HashNumber"]. Serwer nie zaakceptuje połączenia. Należy sprawdzić, czy certyfikat jest zainstalowany poprawnie. Zobacz sekcję "Konfigurowanie certyfikatu do użytku przez SSL" w

Błąd: 17182, Ważność: 16, Stan: 1.

Inicjalizacja TDSSNIClient nie powiodła się. Błąd 0x80092004, kod stanu 0x80. Przyczyna: Nie można zainicjować obsługi SSL. Nie można odnaleźć obiektu lub właściwości.

Błąd: 17182, Ważność: 16, Stan: 1.

Inicjalizacja TDSSNIClient nie powiodła się z powodu błędu 0x80092004, kodu stanu 0x1. Przyczyna: Inicjowanie nie powiodło się z powodu błędu infrastruktury. Sprawdź, czy nie wystąpiły poprzednie błędy. Nie można odnaleźć obiektu lub właściwości.

Błąd: 17826, Dotkliwość: 18, Stan: 3.

Nie można uruchomić biblioteki sieciowej z powodu wewnętrznego błędu w bibliotece sieciowej. Aby ustalić przyczynę, przejrzyj błędy w dzienniku błędów, które występowały bezpośrednio przed tym błędem.

Błąd: 17120, Ważność: 16, Stan: 1.

Wątek programu SQL Server nie mógł zduplikować wątku FRunCommunicationsManager. Informacje o możliwych problemach pokrewnych można znaleźć w dzienniku błędów programu SQL Server i dzienniku zdarzeń systemu Windows.

Rozwiązanie

Informacje o dodatku Service Pack dla programu SQL Server 2016

Ta aktualizacja jest zawarta w następującym dodatku Service Pack dla programu SQL Server:

Informacje o dodatkach Service Pack dla programu SQL Server:

Dodatki Service Pack są kumulatywne. Każdy nowy dodatek Service Pack zawiera wszystkie poprawki zawarte w poprzednich dodatkach Service Pack oraz nowe poprawki. Zaleca się stosowanie dla tego dodatku Service Pack najnowszego dodatku Service Pack i najnowszej aktualizacji zbiorczej. Instalowanie poprzedniego dodatku Service Pack przed zainstalowaniem najnowszego dodatku Service Pack nie jest konieczne. Więcej informacji na temat najnowszego dodatku Service Pack i najnowszej aktualizacji zbiorczej znajdziesz w tabeli 1 w następującym artykule.

Określanie wersji, edycji i poziomu aktualizacji programu SQL Server i jego składników

Źródła informacji

Dowiedz się więcej o terminologii używanej przez firmę Microsoft do opisywania aktualizacji oprogramowania.