Wprowadzenie do programu SharePoint Designer

Dotyczy
SharePoint Designer 2013

Ważne

Zakończenie świadczenia pomocy technicznej dla programu SharePoint Designer 2013 zaplanowano na 14 lipca 2026 r. Aby uzyskać więcej informacji, zapoznaj się z artykułem dotyczącym stałych zasad cyklu życia

SharePoint Designer 2013 to program do projektowania sieci Web i aplikacji służący do tworzenia i dostosowywania witryn i aplikacji programu SharePoint. Za pomocą programu SharePoint Designer 2013 możesz tworzyć strony z dużą ilością danych, tworzyć zaawansowane rozwiązania z obsługą przepływów pracy oraz projektować wygląd i działanie witryny.

Program SharePoint Designer 2013 zapewnia unikatowe możliwości tworzenia witryn, zapewniając jedno miejsce, w którym można utworzyć witrynę, dostosować składniki składające się na witrynę, zaprojektować logikę witryny wokół procesu biznesowego, a następnie wdrożyć witrynę jako spakowane rozwiązanie. Możesz to wszystko zrobić bez pisania linijki kodu.

Uwaga

Większość informacji tutaj dotyczy zarówno programu SharePoint Designer 2013. Program SharePoint Designer 2013 jest przeznaczony dla witryn programu SharePoint 2013 i nowszych wersji.

W poniższych sekcjach dowiesz się więcej o programie SharePoint Designer 2013 i o tym, jak rozpocząć korzystanie z niego w Twojej organizacji.

Pobieranie i instalowanie programu SharePoint Designer 2013

Aby uzyskać program SharePoint Designer 2013, zobacz Pobieranie i instalowanie programu SharePoint Designer 2013.

Środowisko programu SharePoint Designer 2013

Witryny programu SharePoint szybko stają się coraz bardziej złożone, dostosowując się do potrzeb firm każdego typu i wielkości. Nie były one repozytorium dokumentów, list zadań i harmonogramów, a stały się witrynami o wysokiej dynamice, bogatymi w dane i procesami biznesowymi.

Dla projektanta witryny oznacza to nie tylko zrozumienie potrzeb firmy, ale także zrozumienie programu SharePoint i wszystkich elementów, które składają się na jedną z jego witryn. Zrozumienie relacji między wieloma ruchomymi częściami witryny i zarządzanie nimi z jednego miejsca jest szczególnie ważne.

Program SharePoint Designer 2013 udostępnia jedno środowisko, w którym można pracować nad witryną, jej listami i bibliotekami, stronami, źródłami danych, przepływami pracy, uprawnieniami i innymi elementami. Można nie tylko wyświetlać te kluczowe składniki witryny w jednym miejscu, ale także przeglądać relacje między tymi obiektami.

Ta struktura umożliwia rozpoczęcie projektowania i tworzenia witryn z wysoce dostosowanymi rozwiązaniami biznesowymi. Zacznij od nawiązania połączenia ze źródłami danych w programie SharePoint i poza nim. Przedstaw te informacje użytkownikom i pozwól im przesłać je z powrotem za pomocą witryny programu SharePoint lub aplikacji klienckiej pakietu Office. Twórz wysoce dostosowane przepływy pracy, które automatyzują procesy biznesowe. Na koniec dostosuj wygląd i działanie witryny, aby pasowały do oznakowania Twojej organizacji.

Udostępnienie jednego środowiska dla tych zadań pozwala poświęcić więcej czasu na projektowanie, tworzenie i dostosowywanie rozwiązań, a mniej na wyszukiwanie i aktualizowanie poszczególnych składników witryny przy użyciu różnych narzędzi i metod.

W poniższych sekcjach omówiono środowisko i interfejs użytkownika programu SharePoint Designer 2013:

Otwieranie programu SharePoint Designer 2013

SharePoint Designer 2013 to program kliencki instalowany na komputerze lokalnym. Jest również ściśle zintegrowany z programem SharePoint. W związku z tym można ją uruchomić bezpośrednio z komputera za pomocą menu Start systemu Windows i różnych miejsc w programie SharePoint, takich jak przycisk Edytuj w menu Strona.

Wybieranie programu SharePoint Designer z menu Edycja

Program SharePoint Designer 2013 można otworzyć w wielu miejscach, na przykład podczas dostosowywania list, widoków, przepływów pracy i stron wzorcowych. Jeśli program SharePoint Designer 2013 nie został jeszcze zainstalowany, przy pierwszym uruchomieniu z programu SharePoint zostanie wyświetlony monit o pobranie i zainstalowanie go z sieci Web. Przy następnym otwarciu programu SharePoint Designer 2013 zostanie on otwarty natychmiast. Jest ona również dostępna w menu Start systemu Windows .

Uwaga

Program SharePoint Designer 2013 i jego poszczególne funkcje można ograniczać lub wyłączać za pomocą strony ustawień programu SharePoint Designer. Jeśli nie możesz wykonać zadań opisanych w tym artykule, taka właśnie może być przyczyna. Aby uzyskać szczegółowe informacje, skontaktuj się z administratorem.

Karta Plik w programie SharePoint Designer 2013

Po otwarciu programu SharePoint Designer 2013 z menu Start systemu Windows pierwszą rzeczą, jaką widzisz, jest karta Plik. Na tym ekranie możesz dostosować istniejącą witrynę lub utworzyć nową.

Karta i strona pliku

Aby dostosować istniejącą witrynę, możesz przejść do istniejącej witryny, dostosować swoją witrynę Moja witryna lub wybrać jedną z ostatnio otwieranych witryn w programie SharePoint Designer 2013.

Aby utworzyć nową witrynę, możesz użyć pustego szablonu, wybrać szablon z listy lub wybrać jeden z proponowanych szablonów. W tym miejscu wystarczy określić serwer oraz nazwę lokacji, a następnie utworzyć lokację. Witryna zostanie utworzona, a następnie otwarta w programie SharePoint Designer 2013.

Ten ekran nie zostanie wyświetlony, jeśli otworzysz program SharePoint Designer 2013 z poziomu programu SharePoint. Zamiast tego witryna będzie otwarta w interfejsie programu SharePoint Designer 2013.

Interfejs programu SharePoint Designer 2013

Program SharePoint Designer 2013 zapewnia jedno środowisko, w którym można tworzyć, dostosowywać i wdrażać witryny i rozwiązania programu SharePoint. Jest to możliwe dzięki interfejsowi użytkownika, który pokazuje wszystkie składniki składające się na witrynę oraz relacje między nimi.

Przy pierwszym otwarciu witryny widoczne jest podsumowanie witryny wraz z jej tytułem, opisem, bieżącymi uprawnieniami i podwitrynami.

Karta witryny

Trzyczęściowy interfejs: Nawigacja, Podsumowanie i Wstążka

Istnieją trzy główne obszary interfejsu programu SharePoint Designer 2013, w których pracuje się podczas projektowania i tworzenia witryn:

  1. Okienko nawigacji służy do nawigowania między głównymi częściami (składnikami) witryny
  2. Strony Galeria i Podsumowanie , aby wyświetlić listy każdego typu składnika i podsumowania jednego konkretnego składnika.
  3. Wstążka umożliwiająca wykonywanie akcji na wybranym składniku.

Strona witryny z objaśnieniami

W okienku nawigacji są wyświetlane składniki składające się na witrynę, takie jak listy, biblioteki, typy zawartości, źródła danych, przepływy pracy i inne. Aby edytować jeden ze składników, na przykład listę Anonsy, otwórz listę Listy i biblioteki. Zostanie wyświetlona strona galerii zawierająca wszystkie listy i biblioteki.

W tym miejscu możesz otworzyć listę Anonsy, co spowoduje przejście do strony podsumowania tej listy. Na stronie podsumowania są widoczne skojarzone widoki, formularze, przepływy pracy i inne elementy. Aby edytować jeden z widoków, otwórz go bezpośrednio z tej strony.

Po otwarciu widoku zauważysz, że na Wstążce wyświetlane są najczęstsze i najbardziej kontekstowe zadania edycyjne dotyczące widoków edycji. Jeśli znasz Wstążkę w aplikacjach pakietu Microsoft Office, wiesz, że dzięki niej tworzenie i edytowanie zadań jest szybkie i łatwe. Po zakończeniu edytowania użyj przycisku Wstecz lub nawigacji w stylu linków do stron nadrzędnych u góry strony, aby powrócić do podsumowania witryny.

Interfejs programu SharePoint Designer 2013 ułatwia identyfikowanie różnych składników witryny, przechodzenie do szczegółów i edytowanie jednego z tych składników, a następnie powrót do głównego widoku witryny.

Otwieranie karty Plik

Oprócz pracy nad różnymi obiektami witryny w programie SharePoint Designer 2013 możesz chcieć wyświetlać większe ustawienia witryny lub aplikacji oraz uzyskiwać do nich dostęp. Obejmuje to otwieranie innej witryny, dodawanie stron, importowanie plików i zmienianie ustawień aplikacji programu SharePoint Designer 2013. Te akcje można wykonać na karcie Plik, która jest pierwszym ekranem wyświetlanym po otwarciu programu SharePoint Designer 2013 z menu Start systemu Windows.

Kliknij kartę Plik w lewym górnym rogu, aby przejść do tego widoku. Kliknij przycisk Wstecz, aby powrócić do interfejsu programu SharePoint Designer 2013.

Filary dostosowywania w programie SharePoint Designer 2013

Za pomocą programu SharePoint Designer 2013 można tworzyć i dostosowywać witryny i rozwiązania, które zawierają logikę aplikacji, ale nie wymagają pisania kodu. Za jego pomocą można między innymi dodawać i modyfikować źródła danych, dostosowywać widoki list i danych, tworzyć i wdrażać przepływy pracy biznesowe oraz projektować markę firmy. Jednak prawdziwe wykorzystanie możliwości i możliwości programu SharePoint Designer 2013 zaczyna się wtedy, gdy przekształcasz gotową witrynę w prawdziwe rozwiązanie biznesowe dla organizacji.

W poniższych sekcjach opisano filary dostosowywania podczas projektowania i tworzenia rozwiązań przy użyciu programu SharePoint Designer 2013.

Łączenie się z danymi w programie SharePoint i poza nim

Program SharePoint Designer 2013 umożliwia łączenie się z wieloma źródłami danych, a następnie integrowanie tych danych z witryną i aplikacjami klienckimi pakietu Office. Dzięki temu użytkownicy będą mogli wyświetlać dane biznesowe w witrynie i pracować z nimi w wybranych programach, bez konieczności osobnego łączenia się z tymi źródłami.

Przyciski opcji nowego połączenia danych

Bezpośrednio z poziomu Wstążki możesz łączyć się z zewnętrzną bazą danych, usługami SOAP, REST i innymi.

Łączenie się ze źródłami danych jest bardzo użyteczną funkcją programu SharePoint Designer 2013, ponieważ istnieje wiele obsługiwanych opcji, dzięki którym można udostępnić dane użytkownikom. Za pomocą połączeń danych możesz łączyć listy i biblioteki, zewnętrzne bazy danych i źródła danych, usługi sieci Web i nie tylko.

Oto podgląd źródeł danych, z którymi można się połączyć przy użyciu programu SharePoint Designer 2013.

Listy i biblioteki

Listy i biblioteki są typowym źródłem danych używanym w witrynie. Różnią się one od innych źródeł danych tym, że są już częścią programu SharePoint i korzystają z tej samej bazy danych co program SharePoint. Nie musisz wykonywać żadnych dodatkowych czynności, aby utworzyć połączenie z tymi źródłami danych — wystarczy dodać je przy użyciu galerii Listy i biblioteki w programie SharePoint Designer 2013 lub dodać je w przeglądarce. Po utworzeniu listy lub biblioteki możesz dostosować skojarzone z nią kolumny, typy zawartości i inne atrybuty schematu.

Zewnętrzne dane biznesowe

Uwaga

Ta funkcja nie jest dostępna we wszystkich implementacjach technologii programu SharePoint. Aby uzyskać więcej informacji, skontaktuj się z administratorem usługi.

Usługi łączności biznesowej (BCS, Business Connectivity Services) to oparta na programie SharePoint struktura zapewniająca ustandaryzowane interfejsy do istniejących procesów i danych biznesowych. Usługi łączności biznesowej umożliwiają łączenie zewnętrznych źródeł danych biznesowych — programów SQL Server, SAP i Siebel, usług sieci Web i aplikacji niestandardowych — z witrynami programu SharePoint i aplikacjami pakietu Office.

W programie SharePoint Designer 2013 łączenie się z danymi zewnętrznymi odbywa się przez tworzenie typów zawartości zewnętrznej. Typy zawartości zewnętrznej reprezentują dane w zewnętrznym źródle danych, przechowując szczegóły połączenia, obiekty używane w aplikacji biznesowej, metody tworzenia, odczytywania, aktualizowania i usuwania oraz akcje, które użytkownicy mogą wykonywać na obiektach.

Typ zawartości zewnętrznej jest przechowywany w Data Catalog Firma. Po utworzeniu typu zawartości zewnętrznej Ty i inne osoby w organizacji możecie łatwo tworzyć oparte na nim listy, widoki, formularze, przepływy pracy, a nawet integrację klienta pakietu Office w programie SharePoint. Dane zewnętrzne stają się częścią programu SharePoint, tak jak każdy inny składnik, co umożliwia tworzenie całkowicie dostosowanych interfejsów użytkownika dla tych zewnętrznych źródeł danych.

Zewnętrzne bazy danych

Dodanie bazy danych jako źródła danych umożliwia zintegrowanie danych z innej bazy danych z witryną. Możesz połączyć się z programem Microsoft SQL Server, Oracle i dowolną bazą danych obsługującą protokoły OLE DB lub ODBC. Wystarczy znać nazwę serwera, na którym znajduje się baza danych, dostawcę danych i typ uwierzytelniania, którego chcesz użyć. Po dodaniu i skonfigurowaniu bazy danych jako źródła danych można utworzyć widoki i formularze, które umożliwią użytkownikom odczytywanie i zapisywanie danych w źródle danych bez konieczności opuszczania witryny programu SharePoint.

Usługi XML sieci Web za pośrednictwem protokołu SOAP

Protokół SOAP (Simple Object Access Protocol) służy do wymiany komunikatów opartych na kodzie XML, co umożliwia łączenie się z różnymi źródłami danych przy użyciu usługi sieci Web XML. W programie SharePoint Designer 2013 możesz użyć tej funkcji do utworzenia połączenia ze źródłem danych w innej witrynie w organizacji lub witrynie w Internecie, niezależnie od technologii, języka programowania czy platformy. Za pomocą usługi XML sieci Web możesz wyświetlić w witrynie przelicznik walut, notowania giełdowe, kalkulator lub usługę pogodową.

Skrypty po stronie serwera za pośrednictwem usługi REST

Representational state transfer (REST, reprezentacyjny transfer stanu) to styl architektoniczny oprogramowania sieciowego, który wykorzystuje technologie i protokoły sieciowe, a nie tylko metodę tworzenia usług internetowych. Tego typu można używać do pobierania danych z witryny przez odczytanie wyznaczonego skryptu po stronie serwera, który opisuje zawartość. Podobnie jak w przypadku protokołu SOAP, możesz użyć go w programie SharePoint Designer 2013, aby połączyć się ze źródłem danych w innej witrynie w celu wyświetlenia na przykład konwertera walut, notowań giełdowych, kalkulatora lub serwisu pogodowego. Ten typ połączenia danych jest prostszy do zaimplementowania niż protokół SOAP, ale jest ograniczony do protokołu HTTP.

Pliki źródłowe XML

Jeśli Twoja organizacja przechowuje dane w plikach XML, możesz utworzyć połączenie z tymi plikami jako źródło danych w programie SharePoint Designer 2013. Aby połączyć się z plikami XML jako źródło danych, możesz utworzyć je bezpośrednio w programie SharePoint Designer 2013, zaimportować je z lokalizacji na komputerze lub w sieci albo połączyć się z nimi z lokalizacji zewnętrznej.

Tworzenie interfejsów bogatych w dane

Po ustanowieniu połączeń z potrzebnymi źródłami danych możesz przystąpić do tworzenia interakcyjnych, bogatych w dane interfejsów dla użytkowników z tymi źródłami danych. Za pomocą programu SharePoint Designer 2013 możesz tworzyć zaawansowane i dynamiczne interfejsy użytkownika dla źródeł danych, udostępniając je w wielu miejscach, w tym w witrynie programu SharePoint i niestandardowych oknach, okienkach i polach w aplikacjach biznesowych pakietu Office.

Tworzone są między innymi widoki niestandardowe, formularze, składniki Web Part, nawigacja oraz niestandardowe okna klienta pakietu Office i okienka zadań. Ten rodzaj elastyczności pozwala na tworzenie środowisk użytkownika całkowicie dostosowanych do danych biznesowych.

Możesz połączyć wiele źródeł danych w jeden widok, tworzyć pulpity nawigacyjne z powiązanymi widokami elementów, projektować formularze niestandardowe dostosowane do poszczególnych ról oraz dostosować dostępne paski narzędzi i polecenia Wstążki skojarzone z danymi.

Poniżej przedstawiono wiele sposobów dostosowywania interfejsu użytkownika skojarzonego z danymi przy użyciu programu SharePoint Designer 2013.

Widoki

Widoki umożliwiają wyświetlanie danych na różne sposoby. Niezależnie od tego, czy przeglądasz listę, bibliotekę, czy zewnętrzne źródło danych, możesz użyć widoków, aby wyświetlić informacje, które są istotne dla Ciebie i Twoich użytkowników. W programie SharePoint Designer 2013 każdy tworzony widok jest widokiem danych wyświetlanym w formacie XSLT (przekształcenie języka rozszerzonego arkusza stylów) i korzysta z technologii ASP.NET firmy Microsoft. W widoku można między innymi pokazywać i ukrywać pola, sortować, filtrować, wykonywać obliczenia, stosować formatowanie warunkowe. Istnieje również kilka stylów widoku, z których można szybko rozpocząć pracę. Docelowo możesz utworzyć i dostosować dowolny widok, aby pasował do modelu danych, użytkowników i firmy.

Formularze

Aby zbierać informacje od użytkowników, należy utworzyć formularze. Dzięki wysoce dostosowanym formularzom opartym na sieci Web użytkownicy mogą łatwo zapisywać dane w źródle danych. Podobnie jak w przypadku widoków możesz dostosowywać wygląd pól na podstawie stanu danych, roli użytkownika i innych elementów. Za pomocą formularzy można wyświetlać dane, edytować i tworzyć dane, a także projektować formularze za pomocą wbudowanego edytora formularzy programu SharePoint Designer 2013 (w przypadku plików .aspx) lub programu Microsoft InfoPath (w przypadku plików xsn). Formularze można tworzyć i dostosowywać pod kątem określonych źródeł danych, takich jak lista zadań, a także mogą być używane do zbierania informacji o użytkownikach w przepływie pracy, jak wyjaśniono w dalszej części artykułu.

Akcje niestandardowe

Za pomocą Konstruktora akcji niestandardowych w programie SharePoint Designer 2013 możesz tworzyć akcje niestandardowe, takie jak linki, ikony i skrypty do wstążki, paska narzędzi i menu elementów listy programu SharePoint. Za każdym razem, gdy dodajesz nową funkcję do witryny, możesz ułatwić użytkownikom odnajdowanie jej i używanie, udostępniając ją w menu programu SharePoint. Akcje niestandardowe umożliwiają także zachęcanie użytkowników do wykonywania określonych zadań na danym obiekcie, takich jak uruchamianie przepływu pracy na liście.

Składniki Web Part

Składniki Web Part to modularne jednostki informacji — niezależne dane lub funkcje — dodawane do strony programu SharePoint. Opisane wcześniej widoki i formularze są przechowywane w składnikach Web Part, ale oprócz nich można dodawać składniki Web Part, które spełniają wiele funkcji i sposobów interakcji z danymi. Użytkownicy mogą dodatkowo dostosowywać składniki Web Part w przeglądarce, jeśli dodasz je do strefy składników Web Part w programie SharePoint Designer 2013. Składniki Web Part i strony składników Web Part to zaawansowany i skuteczny sposób dostosowywania interfejsu sieci Web dla użytkowników w programie SharePoint.

Integracja z klientem

W przypadku zewnętrznych źródeł danych korzystających z typów zawartości zewnętrznej informacje można udostępniać w aplikacjach klienckich, takich jak programy Microsoft Outlook i SharePoint Workspace. Możesz utworzyć interfejs umożliwiający użytkownikom odczytywanie, zapisywanie i usuwanie zewnętrznych danych biznesowych, tak jakby były one częścią aplikacji. Robi się to za pomocą formularzy klienta, regionów i okienek zadań. Dzięki temu użytkownicy mogą pracować ze swoimi danymi biznesowymi w witrynach i aplikacjach pakietu Office, które znają najlepiej i z których już korzystają.

Nawigacja odgrywa kluczową rolę w interfejsach tworzonych dla użytkowników i jest obszarem, którym zarządza się w całym programie SharePoint, nie tylko w programie SharePoint Designer 2013. Można na przykład dostosować linki nawigacji w obrębie widoku danych lub formularza, składnika Web Part, przepływu pracy lub na poziomie witryny, na przykład górny pasek łączy lub pasek Szybkie uruchamianie. Chcesz się upewnić, że witryna i wszystkie jej części mają dobrze zaplanowany model nawigacji, który będzie dostępny dla użytkowników.

Zarządzanie procesami biznesowymi

Każdy proces biznesowy w organizacji składa się z zestawu działań, które są ze sobą powiązane w oparciu o wspólną potrzebę biznesową. Przepływy pracy są projektowane zgodnie z tym modelem, zapewniając przepływy pracy oparte na regułach składające się z zestawów warunków i akcji. Organizujesz i uruchamiasz serię akcji, które odpowiadają procesowi pracy w oparciu o sekwencję warunków i akcji.

Ilustracja przedstawiająca program SharePoint Designer 2010

Za pomocą programu SharePoint Designer 2013 można tworzyć przepływy pracy do zarządzania od najprostszych do najbardziej złożonych procesów biznesowych w organizacji. Przepływy pracy robią to, automatyzując zarówno procesy aplikacji biznesowych, jak i procesy współpracy między ludźmi. Przepływy pracy dla procesów aplikacji biznesowych mogą aktualizować jedno źródło danych, gdy zmienia się inne źródło danych; Przepływy pracy dla procesów współpracy między pracownikami mogą wysyłać dokumenty do przełożonego pracownika w celu zatwierdzenia.

Przepływ pracy programu SharePoint wprowadza logikę aplikacji do procesów biznesowych bez konieczności pisania kodu. Jest to możliwe dzięki zaawansowanemu, a jednocześnie intuicyjnemu edytorowi przepływów pracy w programie SharePoint Designer 2013, który pozwala na zagnieżdżoną logikę, podkroki i nie tylko. Możesz również projektować i udostępniać przepływy pracy przy użyciu programu Microsoft Visio z szablonami schematów blokowych, które można eksportować do programu SharePoint Designer 2013.

Poniżej przedstawiono bloki konstrukcyjne przepływu pracy w programie SharePoint Designer 2013.

Zdarzenia

Zdarzenie uruchamia lub inicjuje przepływ pracy. Zmiana źródła danych, na przykład utworzenie nowego elementu lub zmiana elementu, to jeden z typów zdarzeń. Innym typem zdarzenia jest zdarzenie aktywowane przez użytkownika, uczestnika przepływu pracy. Przepływy pracy uruchamiane po zmianie źródła danych są zwykle częścią przepływu pracy aplikacji służącego do automatyzowania procesów biznesowych, takich jak kopiowanie plików na podstawie stanu danych. Przepływy pracy, które mogą być uruchamiane przez użytkowników, są zazwyczaj częścią wspólnego przepływu pracy, takiego jak zatwierdzanie zawartości. Przepływy pracy można skonfigurować w taki sposób, aby rozpoznawały oba typy zdarzeń, a nawet mogą opierać się na połączeniu tych dwóch zdarzeń.

Warunki

Warunki określają, kiedy przepływ pracy jest uruchamiany lub wykonuje działanie. Ponieważ przepływy pracy są skojarzone ze źródłem danych, warunek określa zmianę w źródle danych, która musi zostać wprowadzona, aby przepływ pracy mógł zostać wdrożony. Warunki zwykle zaczynają się od zdania "Jeśli pole równa się wartość". Jeden warunek może być użyty z wieloma akcjami, a wiele warunków może być użytych z jedną akcją. Reguły łączą warunki z co najmniej jedną akcją: Jeśli wszystkie klauzule warunku są prawdziwe, wykonywana jest skojarzona akcja.

Akcje

Akcje są najbardziej podstawowymi jednostkami pracy w przepływie pracy. Podczas projektowania przepływu pracy określa się niezbędną sekwencję akcji, a następnie tworzy się tę sekwencję akcji w narzędziu Designer przepływu pracy. Możesz je skonfigurować tak, aby następowały jedno po drugim (akcje szeregowe) lub oba w tym samym czasie (akcje równoległe). Przepływ pracy może zawierać dowolną liczbę akcji wykonywanych przez sam przepływ pracy lub jego uczestników. Program SharePoint Designer 2013 zawiera bogaty zestaw gotowych akcji wielokrotnego użytku. Za pomocą tych akcji przepływy pracy mogą na przykład wysyłać wiadomości e-mail, zaznaczać elementy na listach i usuwać je z nich, wykonywać obliczenia i nie tylko.

Część tych akcji zawiera specjalny zestaw akcji zadań, takich jak Rozpocznij proces zatwierdzania i Uruchom proces opinii, który zawiera oddzielny edytor przepływu pracy zaprojektowany specjalnie pod kątem procesów zadań wykonywanych przez ludzkie osoby w organizacji. Przy użyciu tych akcji można tworzyć i dostosowywać zaawansowane przepływy pracy, które mogą zarządzać niemal każdym procesem biznesowym.

Czynności

Przepływy pracy składają się z co najmniej jednego etapu i podetapu. Kroki umożliwiają grupowanie warunków i akcji, dzięki czemu jeden zestaw reguł może być oceniany i wykonywany przed drugim zestawem. Każdy krok może zawierać dowolną liczbę warunków i akcji. Przepływ pracy można zaprojektować jako sekwencję czynności w kroku lub podkroku. Reguły w jednym kroku są przetwarzane do końca przed przejściem do następnego kroku, dlatego chcesz zgrupować w tym samym kroku wszystkie reguły niezbędne do wykonania określonej akcji lub określonych akcji. Kroki mogą być także używane jako sposób organizowania przepływu pracy, zwłaszcza jeśli zawiera on wiele akcji i bardzo mało warunków.

Formularze

Przepływy pracy często zawierają formularze umożliwiające zbieranie informacji od uczestników przepływu pracy w wstępnie zdefiniowanych momentach przepływu pracy. Umożliwiają one również uczestnikom interakcję z zadaniami skojarzonymi z przepływem pracy. W przepływie pracy można zaprojektować formularze inicjowania w celu zbierania informacji od użytkowników podczas uruchamiania przepływu pracy, formularze skojarzenia w celu skojarzenia przepływu pracy z listą lub typem zawartości oraz formularze zadań niestandardowych skojarzonych z listą zadań. Podczas projektowania formularzy można używać natywnej aplikacji ASP. Formularze oparte na sieci NET (.aspx strony) w programie SharePoint Designer 2013 lub formularze niestandardowe (strony xsn) zaprojektowane przy użyciu Microsoft® InfoPath® 2010. Program InfoPath oferuje znacznie więcej możliwości dostosowywania i znakowania formularzy przepływu pracy.

Zmienne

Zmienna jest lokalizacją przechowywania danych lub pamięcią podręczną wewnątrz przepływu pracy. Za pomocą zmiennych można przechowywać różne typy danych w przepływie pracy, a w późniejszym czasie odwoływać się do tych danych za pomocą odnośników przepływu pracy. Istnieje wiele typów zmiennych, których można używać w przepływie pracy. Można użyć na przykład zmiennych generowanych przez parametry formularza inicjowania oraz zmiennych lokalnych, które przechowują dane skojarzone z bieżącym przepływem pracy. W zmiennej lokalnej można używać wielu typów danych zmiennych, w tym danych logicznych, daty/godziny, identyfikatora elementu listy, liczby i ciągów. Po utworzeniu zmiennej i ustawieniu dla niej wartości możesz odwołać się do tej zmiennej w warunku lub akcji w dalszej części przepływu pracy.

Projekt i marka

Ostatnim obszarem dostosowywania zapewnianym przez program SharePoint Designer 2013 jest projekt i marka, czyli zastosowanie wyglądu i sposobu działania firmy do witryny programu SharePoint. Możesz dodać logo firmy, schemat kolorów, nagłówki i stopki, grafikę pomocniczą, nawigację niestandardową i nie tylko. Dzięki temu każda strona w witrynie może być od razu rozpoznawana jako część większej witryny firmowej. W programie SharePoint Designer 2013 można projektować i oznaczać markami witryny programu SharePoint przy użyciu stron wzorcowych, układów stron i kaskadowych arkuszy stylów.

Projektowanie i znakowanie witryny różni się od pozostałych filarów dostosowywania, gdzie nacisk kładziony jest na tworzenie niestandardowych rozwiązań biznesowych. Znakowanie jest wykonywane rzadziej i znajduje się u góry zbioru witryn — na przykład w intranecie lub w portalu internetowym. Ta marka niestandardowa jest następnie dziedziczona przez utworzone poniżej jej podwitryny. Wysiłek brandingowy będzie również prawdopodobnie wykonywany przez projektanta stron internetowych, a nie twórcę rozwiązań.

Z tego powodu strony wzorcowe, układy stron i kaskadowe arkusze stylów są domyślnie wyłączone dla wszystkich użytkowników z wyjątkiem administratorów zbiorów witryn. W ten sposób tylko osoby odpowiedzialne za markę witryny mają dostęp do tych potężnych, ale poufnych plików. Oczywiście można je ponownie włączyć dla określonych użytkowników.

Projektant witryn może skorzystać ze sposobów tworzenia niestandardowej marki witryn przy użyciu programu SharePoint Designer 2013.

Strony wzorcowe

Strony wzorcowe to funkcja ASP.NET, która jest dołączana do programu SharePoint jako sposób na zaprojektowanie układu witryny w jednym miejscu i ponowne użycie go jako szablonu na innych stronach w przedsiębiorstwie. Za każdym razem, gdy wyświetlasz stronę w witrynie programu SharePoint, są wyświetlane dwie scalone strony — strona wzorcowa i strona zawartości. Strona wzorcowa definiuje wspólny układ i elementy nawigacji (które zwykle zajmują lewą, górną i dolną część strony). Strona zawartości zawiera zawartość specyficzną dla strony. Program SharePoint Designer 2013 udostępnia bogaty zestaw narzędzi do edytowania stron, których można używać do dostosowywania stron wzorcowych i udostępniania ich innym osobom.

Układy stron

Jeśli pracujesz z witryną publikowania, możesz również zaprojektować wygląd i układ witryny przy użyciu układów stron. Układy stron służą jako szablony dla stron publikowania utworzonych przez użytkowników w organizacji. Oprócz strony wzorcowej zapewniają one szczegółową kontrolę i strukturę strony publikowania, na przykład określanie miejsc, w których można umieścić tytuł, tekst podstawowy i grafikę na stronie. Strony publikowania korzystają z infrastruktury publikowania w programie SharePoint i pomagają usprawnić tworzenie i publikowanie zawartości w przeglądarce bez nadmiernego obciążenia związanego z tym procesem.

Kaskadowe arkusze stylów

Podobnie jak większość witryn i aplikacji sieci Web, program SharePoint używa kaskadowych arkuszy stylów (CSS, cascading style sheet) do stosowania kolorów, grafik i pozycjonowania do różnych obiektów, które składają się na strony w witrynie. W wielu przypadkach do strony zastosowano wiele arkuszy stylów. Aby dostosować te style, możesz je zmodyfikować bezpośrednio na stronie wzorcowej, w układzie strony lub na stronie witryny albo zmodyfikować style bezpośrednio w pliku CSS dołączonym do strony — oba te elementy możesz wykonać przy użyciu zaawansowanych narzędzi do edycji arkuszy CSS w programie SharePoint Designer 2013. Możesz również dostosować motywy programu SharePoint przy użyciu plików CSS. Dostosowując pliki CSS, można zmienić wygląd (czyli "skórkę") witryny programu SharePoint, nadając jej wygląd korporacyjny.

Wdrażanie niestandardowych rozwiązań programu SharePoint

Do tej pory koncentrowano się na sposobach używania programu SharePoint Designer 2013 do tworzenia rzeczywistych rozwiązań biznesowych. Wiesz już, że możesz tworzyć połączenia z danymi w programie SharePoint i poza nim i integrować się z nimi, tworzyć zaawansowane interfejsy użytkownika dla tych danych, zarządzać procesami biznesowymi za pomocą przepływów pracy oraz dodawać do witryny markę pasującą do wyglądu i działania firmy.

Teraz jednak musisz coś zrobić ze swoimi rozwiązaniami — na przykład wdrożyć je na innym serwerze lub w całym przedsiębiorstwie, otworzyć je w programie Visual Studio w celu dodatkowych dostosowań lub zapisać je w trybie offline, aby zabrać je ze sobą w trasę. Potrzebny jest sposób przekształcenia rozwiązania w pakiet i tu właśnie pojawia się opcja Zapisz jako szablon.

Przyciski zarządzania witryną

Możliwość zapisania rozwiązania jako szablonu to bardzo przydatna funkcja programu SharePoint. Szablon jest zapisywany jako pakiet rozwiązania sieci Web (plik wsp), który zawiera całą zawartość witryny, w tym źródła danych i strukturę, widoki i formularze, przepływy pracy oraz składniki Web Part.

Szablony są również szczegółowe. Być może pracujesz nad określoną częścią witryny, taką jak lista, widok lub przepływ pracy. Możesz również zapisać je jako osobne składniki jako szablony, co oferuje zupełnie nowy sposób współpracy nad opracowywaniem rozwiązań.

Kończenie cyklu rozwiązania biznesowego w programie SharePoint

Spędzając więcej czasu w programie SharePoint Designer 2013, szybko zdajesz sobie sprawę, że możesz zrobić znacznie więcej niż podstawowe dostosowywanie witryny. Możesz tworzyć rzeczywiste rozwiązania biznesowe zawierające połączenia danych, interfejsy użytkownika bogate w dane, niestandardowe przepływy pracy i kompletne znakowanie witryny. Wszystko to możesz utworzyć w programie SharePoint i śledzić cykl życia tworzenia aplikacji, który kończy się wdrożeniem rozwiązania.