Aktualizacja ulepszająca proxy programu AD FS i niezawodność STS w systemie Windows Server 2012 R2 podczas logowania wielu klientów

Pracuj w dowolnym miejscu i na dowolnym urządzeniu dzięki platformie Microsoft 365

Uaktualnij program Microsoft 365, aby pracować w dowolnym miejscu z najnowszymi funkcjami i aktualizacjami.

Zaktualizuj teraz

W tym artykule opisano problem, gdy serwer proxy programu AD FS i wydajności STS jest wolno Windows Server 2012 R2. Ten problem został rozwiązany w pakiecie zbiorczym aktualizacji 2955164 dla systemu Windows Server 2012 R2 lub Windows 8.1 lub w poprawce 2948086 opisane w tym artykule i warunkiem wstępnym.

Objawy

Załóżmy, że Security Token Service (STS) zainstalowany na komputerze z systemem Windows Server 2012 R2. Gdy wielu klientów (ponad 200) próbuje zarejestrować się przy użyciu serwera proxy programu Active Directory Federation Services (AD FS), serwera proxy usług AD FS zużywa 100% wykorzystania Procesora. W tej sytuacji wydajność serwera proxy usług AD FS jest powolne i powoduje opóźnienia, który przekracza 10seconds. Powoduje to również o. do pracy przy minimalnym obciążeniu. W związku z tym o. odrzuca ona żądania lub służy tylko 5-10 żądań na sekundę.

Przyczyna

Ten problem występuje, ponieważ dodatkowe żądania "starych" są dodawane do puli żądania, gdy wielu klientów, spróbuj się zarejestrować. W związku z tym Obciążenie zasobów w programie AD FS jest wyczerpana.

Rozwiązanie

Aby rozwiązać ten problem, należy zainstalować pakiet zbiorczy aktualizacji 2955164 lub zainstalowania poprawki, którą opisano w tym artykule.

Informacje o aktualizacji

Aby uzyskać więcej informacji dotyczących sposobu uzyskiwania tego pakietu zbiorczego aktualizacji kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

pakiet zbiorczy aktualizacji Windows RT 8.1, 8.1 systemu Windows i systemu Windows Server 2012 R2: 2014 maja

Informacje o poprawce

Obsługiwana poprawka jest udostępniana przez firmę Microsoft. Jednak ta poprawka jest przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tylko w systemach, których dotyczy ten problem, należy zastosować tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, pojawi się sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma tej sekcji, należy przesłać żądanie do centrum obsługi klienta firmy Microsoft i obsługi technicznej w celu uzyskania poprawki.

Uwaga Jeśli wystąpią dodatkowe błędy lub konieczność rozwiązania problemu, być może trzeba będzie utworzyć osobne zlecenie usługi. Zwykłe koszty obsługi będą zastosowane do dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi odwiedź następujące witryny firmy Microsoft:

Uwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których dostępna jest poprawka. Jeśli odpowiedni język nie jest widoczny, to dlatego, że poprawka nie jest dostępna dla danego języka.

Wymagania wstępne

Aby zastosować tę poprawkę, należy najpierw zainstalować aktualizację 2919355 w systemie Windows Server 2012 R2. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

Windows RT 8.1, Windows 8.1 i systemu Windows Server 2012 R2 aktualizacji kwietnia 2014

Informacje dotyczące rejestru

Aby użyć poprawki w tym pakiecie, nie trzeba wprowadzać żadnych zmian w rejestrze.

Wymagania dotyczące ponownego uruchomienia

Po zastosowaniu tej poprawki należy ponownie uruchomić komputer.

Informacje dotyczące zastępowania poprawek

Ta poprawka nie zastępuje wcześniej wydanej poprawki.

Wersja globalna tej poprawki instaluje pliki, których atrybuty wymieniono w poniższych tabelach. Daty i godziny odpowiadające tym plikom są podane w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time). Daty i godziny odpowiadające tym plikom na komputerze lokalnym są wyświetlane w formacie czasu lokalnego, wraz z Twoim bieżącym bias czasu letniego (DST). Dodatkowo, daty mogą ulec zmianie podczas wykonywania pewnych operacji na plikach.

Informacje o plikach systemu Windows Server 2012 R2 i notatkiWażne Poprawki systemu Windows 8.1 i systemu Windows Server 2012 R2 są zawarte w tych samych opakowaniach. Jednak poprawki na stronie żądanie poprawki są wymienione w obu systemach operacyjnych. Aby zażądać pakietu poprawek, który dotyczy jednej lub obu systemów operacyjnych, wybierz poprawkę, która jest wyświetlana w obszarze "Windows 8.1/Windows Server 2012 R2" na stronie. Zawsze sprawdzaj w sekcji „Stosuje się do”, do jakiego systemu operacyjnego dotyczy każda z poprawek.

  • Pliki dotyczące określonego produktu, etapu rozwoju (RTM, SPn) i składnika usługi (LDR, GDR) można zidentyfikować przez sprawdzenie wersji pliku, jak pokazano w poniższej tabeli:

  • Pliki MANIFEST (.manifest) i pliki MUM (.mum) zainstalowane dla każdego środowiska są wymienione osobno w sekcji „Informacje o dodatkowych plikach". Pliki MUM, MANIFESTU oraz skojarzone pliki wykazu zabezpieczeń (.cat), muszą posiadać zaktualizowane składniki. Pliki katalogu zabezpieczeń, których atrybuty nie zostały wymienione, są podpisane za pomocą podpisu cyfrowego firmy Microsoft.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Dotyczy”.

Więcej informacji

Aby uzyskać więcej informacji dotyczących terminologii aktualizacji oprogramowania, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

Opis standardowej terminologii używanej do opisywania aktualizacji oprogramowania firmy Microsoft.

Informacje o dodatkowych plikach

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×