Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Symptomy

Podczas próby uruchomienia jednego z scenariuszy aktualizacji na ekranie konserwacja bazy danych (98.290.00) w systemie Microsoft Dynamics SL jest wyświetlany jeden z następujących komunikatów o błędach:komunikat 1

W aplikacji wystąpił nieobsługiwany wyjątek. Jeśli klikniesz przycisk Kontynuuj, aplikacja zignoruje ten błąd i spróbuje kontynuować. Jeśli klikniesz pozycję Zamknij, aplikacja zostanie natychmiast ZAMKNIĘTA. Pobieranie fabryki zajęć COM dla składnika o identyfikatorze CLSID [A440BD76-CFE-4D46-AB1F-15F238437A3D] nie powiodło się z powodu następującego błędu: 80040154.

Wiadomość 2

Błąd czasu wykonania 429 "składnik Active X nie może utworzyć obiektu" Pobieranie fabryki zajęć COM dla składnika o identyfikatorze CLSID {10020200-E260-11CF-AE68-00AA004A34d}

Przyczyna

jedno. Ten problem występuje, ponieważ plik SQLDMO. dll nie jest zarejestrowany na komputerze lokalnym.2,6. Ten problem występuje, ponieważ plik CAPICOM. dll nie jest zarejestrowany na komputerze lokalnym.

Rozwiązanie

Użyj co najmniej jednej z następujących rozdzielczości, stosownie do sytuacji.Rozwiązanie 1 Ręczne rejestrowanie pliku SQLDMO. dll. W tym celu wykonaj następujące czynności:

  1. Zlokalizuj plik SQLDMO. dll na komputerze lokalnym. Domyślnie ten plik znajduje się w folderze c:\Program Files\Microsoft SQL Server\MSSQL\80\Tools\Binn.

  2. Kliknij prawym przyciskiem myszy plik SQLDMO. dll, a następnie kliknij polecenie Otwórz za pomocą.

  3. W oknie dialogowym Windows kliknij pozycję Wybierz program z listy, a następnie kliknij przycisk OK.

  4. W oknie dialogowym otwieranie za pomocą kliknij przycisk Przeglądaj.

  5. Zlokalizuj, a następnie otwórz następujący folder: dysk_systemowy : \Windows\System32.

  6. Kliknij dwukrotnie plik regsvr32. exe, a następnie kliknij przycisk OK.

  7. Kliknij przycisk OK , gdy zostanie wyświetlony następujący komunikat:

    RegSvr32-DllRegisterServer w SQLDMO. dll powiodło się.

Uwaga Jeśli nie możesz zarejestrować pliku SQLDMO. dll lub nie ma pliku SQLDMO. dll w katalogu BINN, przejdź do obszaru "Rozwiązanie 3". Rozwiązanie 2

  1. Zlokalizuj plik CAPICOM. dll na komputerze lokalnym. Domyślnie ten plik znajduje się na stronie dysk_systemowy : \Windows\System32.

  2. Kliknij prawym przyciskiem myszy plik CAPICOM. dll, a następnie kliknij polecenie Otwórz za pomocą.

  3. W oknie dialogowym Windows kliknij pozycję Wybierz program z listy, a następnie kliknij przycisk OK.

  4. W oknie dialogowym otwieranie za pomocą kliknij przycisk Przeglądaj.

  5. Zlokalizuj, a następnie otwórz następujący folder: dysk_systemowy : \Windows\System32.

  6. Kliknij dwukrotnie plik regsvr32. exe, a następnie kliknij przycisk OK.

  7. Kliknij przycisk OK , gdy zostanie wyświetlony następujący komunikat:

    RegSvr32-DllRegisterServer w pliku CAPICOM. dll powiodło się.

Uwaga Jeśli nie możesz zarejestrować pliku SQLDMO. dll lub nie ma pliku SQLDMO. dll w katalogu, przejdź do obszaru "Rozwiązanie 4". Rozwiązanie 3 Jeśli nie możesz zarejestrować pliku SQLDMO. dll lub nie ma pliku SQLDMO. dll w katalogu BINN, może to oznaczać, że katalog Binn jest niekompletny. W takim przypadku należy skopiować katalog Binn z roboczej stacji roboczej i zamienić katalog Binn na stację roboczą, która odbierze błąd. Następnie uruchom rozwiązanie 1. Jeśli nie są dostępne żadne inne stacje robocze, z których możesz skopiować katalog Binn, skontaktuj się z działem obsługi Microsoft Dynamics SL, aby uzyskać pomoc dotyczącą odbudowywania katalogu BINN.Rozwiązanie 4 Jeśli nie możesz zarejestrować pliku CAPICOM. dll lub brakuje pliku, przejdź do serwera lub innej maszyny działającej w celu skopiowania pliku CAPICOM. dll z tego źródła, a następnie wklej go na stacji roboczej, gdy został podany błąd. Następnie uruchom rozwiązanie 2. Jeśli nie są dostępne żadne inne stacje robocze, z których możesz skopiować plik CAPICOM. dll, skontaktuj się z pomocą techniczną Microsoft Dynamics SL, aby uzyskać pomoc dotyczącą pobierania pliku CAPICOM. dll.Uwaga Jeśli sprawa pomocowa jest zainicjowana, obowiązują zasady normalnych opłat.

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×