Tylko aktualizacje zabezpieczeń dla.NET Framework 2.0 z dodatkiem SP2, 3.0 z dodatkiem SP2, 4.5.2 i 4.6 dla systemu Windows Server 2008 z dodatkiem SP2 (KB 4457917)

Streszczenie

Ta aktualizacja zabezpieczeń usuwa luki w zabezpieczeniach w Microsoft.NET Framework, która umożliwia zdalne wykonywanie kodu po.NET Framework przetwarza niezaufanych danych wejściowych. Intruz, któremu uda się wykorzystać tę lukę w zabezpieczeniach oprogramowania przy użyciu.NET Framework może uzyskać kontrolę nad systemem podlegającym usterce. Osoba atakująca może wówczas instalować programy; Przeglądanie, zmienianie lub usuwanie danych; lub tworzyć nowe konta z pełnymi prawami użytkownika. Użytkownicy, których konta zostały skonfigurowane do mają mniej uprawnień w systemie ponoszą mniejsze ryzyko niż ci, którzy pracują z uprawnieniami administracyjnymi.

Aby wykorzystać tę lukę, osoba atakująca najpierw musiałaby przekonać użytkownika do jego otwarcia złośliwie zmodyfikowanego dokumentu lub aplikacji.

Ta aktualizacja zabezpieczeń usuwa lukę, modyfikując sposób.NET Framework sprawdza poprawność niezaufanych danych wejściowych.

Aby dowiedzieć się więcej na temat tej luki, zobacz Microsoft znanych luk i zagrożeń CVE-2018-8421.

Ważne

  • Wszystkie aktualizacje programu.NET Framework 4.6 dla systemu Windows Server 2008 Service Pack 2 (SP2) wymaga zainstalowania aktualizacji d3dcompiler_47.dll. Firma Microsoft zaleca zainstalowanie aktualizacji d3dcompiler_47.dll zawarte przed zastosowaniem tej aktualizacji. Aby uzyskać więcej informacji na temat aktualizacji d3dcompiler_47.dll, zobacz KB 4019478.

  • Jeśli po zainstalowaniu tej aktualizacji zainstalowany zostanie pakiet językowy, należy ponownie zainstalować tę aktualizację. Dlatego przed zainstalowaniem tej aktualizacji zaleca się zainstalowanie potrzebnego pakietu językowego. Aby uzyskać więcej informacji zobacz Dodawanie pakietów językowych systemu Windows.

Znane problemy

Po września 2018 aktualizacji zabezpieczeń.NET Framework jest stosowane aby rozwiązać CVE-2018-8421 (umożliwiająca wykonanie zdalnego kodu.NET Framework), przepływów pracy programu SharePoint out of box przestać działać.

Aby uzyskać więcej informacji o tym znanym problemie zobacz następujący artykuł z bazy wiedzy Microsoft Knowledge Base:

4465015 Przepływy pracy programu SharePoint przestają działać po zainstalowaniu aktualizacji zabezpieczeń systemu .NET dla CVE-2018-8421

Dodatkowe informacje dotyczące tej aktualizacji zabezpieczeń

Poniższe artykuły zawierają dodatkowe informacje dotyczące tej aktualizacji zabezpieczeń, ponieważ odnosi się do wersji poszczególnych produktów.

  • 4457054 Opis aktualizacji zabezpieczeń tylko dla programu.NET Framework 2.0 z dodatkiem SP2 i 3.0 z dodatkiem SP2 dla systemu Windows Server 2008 z dodatkiem SP2 (KB 4457054)

  • 4457030 Opis zabezpieczeń tylko aktualizacji programu.NET Framework 4.5.2 dla systemu Windows 7 z dodatkiem SP1, Server 2008 R2 z dodatkiem SP1 i Server 2008 z dodatkiem SP2 (KB 4457030)

  • 4457027 Opis zabezpieczeń tylko aktualizacji programu.NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 i 4.7.2 dla systemu Windows 7 z dodatkiem SP1 i Server 2008 R2 z dodatkiem SP1 oraz.NET Framework 4.6 Server 2008 z dodatkiem SP2 (KB 4457027)

Jak uzyskać pomoc i obsługę techniczną dla tej aktualizacji zabezpieczeń

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×