Symptomy
Występuje co najmniej jeden z następujących objawów:
-
Użytkownicy nie mogą odbierać wiadomości e-mail ani łączyć się ze swoją skrzynką pocztową.
-
Microsoft Exchange Server przestaje odpowiadać i wydaje się, że jest zablokowana.
-
Proces noderunner zużywa zbyt dużo pamięci.
Przyczyna
Proces noderunner w Exchange Server może zużywać nadmierną ilość pamięci podczas próby indeksowania niektórych elementów. To zachowanie powoduje różne problemy z wydajnością na serwerze.
Rozwiązanie
Aby rozwiązać ten problem, ogranicz ilość pamięci, którą może zużywać proces noderunner. Wykonaj następujące czynności na każdym serwerze Exchange:
-
Znajdź plik Noderunner.exe.config w folderze %ExchangeInstallPath%Bin\Search\Ceres\Runtime\1.0 .
-
Otwórz plik Noderunner.exe.config , a następnie znajdź węzeł <RunnerSettings memoryLimitMegabytes="0"/> węzeł XML.
-
Ustaw parametr memoryLimitMegabytes na wartość 25 procent zainstalowanej pamięci serwera. Wprowadź wartość w megabajtach. Jeśli problem będzie się powtarzał po wykonaniu tych czynności, zmniejsz wartość memoryLimitMegabytes o pięć procent, a następnie przetestuj ponownie.
Uwaga: W przypadku serwera z zainstalowanymi Exchange Server 2019 i 128 GB pamięci ustaw parametr memoryLimitMegabytes na wartość z przedziału od 10000 do 32000 (10–32 GB). Wydajność wyszukiwania będzie miała wpływ na ustawienie zbyt niskiej wartości memoryLimitMegabytes .
-
Uruchom następujące polecenie programu PowerShell, aby ponownie uruchomić usługę kontrolera hosta wyszukiwania programu Microsoft Exchange:Restart-Service HostControllerService
-
Uruchom następujące polecenie w oknie programu PowerShell lub wiersza polecenia, aby ponownie uruchomić usługę IIS:IISReset /restart