Ao salvar seu desenho no OneDrive for Business ou no SharePoint Online, você pode trabalhar em um desenho ao mesmo tempo que os seus colegas. Para trabalhar em um desenho ao mesmo tempo, todos os autores no Windows precisam do Visio Plano 2 e estar usando o aplicativo da área de trabalho do Visio.
Compartilhar seu desenho com outras pessoas e colaborar nele ao mesmo tempo
Abra o desenho do Visio no aplicativo da área de trabalho e escolha Compartilhar no canto superior direito da faixa de opções quando estiver pronto para colaborar.
Na caixa de diálogo Compartilhar, insira o endereço de email da pessoa com quem você deseja compartilhar o desenho.
Se as informações de contato da pessoa já estiverem armazenadas, basta apenas inserir o nome. A lista suspensa permite que você determine com quem você deseja compartilhar o desenho.
Clique em Enviar.
Se o arquivo já tiver sido salvo na nuvem, um convite por email será enviado aos convidados. Se você ainda não salvou seu desenho no OneDrive for Business ou no SharePoint Online, o Visio solicitará que você faça isso.
Após salvar o arquivo na nuvem, o convite por email será enviado.
Veja quem está trabalhando em seu desenho compartilhado
- Abra o desenho no aplicativo Visio e comece a trabalhar nele. Se outra pessoa estiver visualizando ou trabalhando no desenho, a imagem em miniatura dela será exibida no canto superior direito da faixa de opções. O Visio o alertará quando as pessoas entrarem ou saírem do seu desenho.
- Para revisar e adicionar comentários, escolha Comentários
.
Você também pode responder a ou excluir os comentários.
Se você quiser ver onde uma pessoa fez comentários no desenho, clique em um ícone de comentário.
Para adicionar seu próprio comentário a qualquer forma, clique com botão direito do mouse na forma e escolha Adicionar comentário.
- Ao terminar de trabalhar, salve o arquivo.
Se as suas atualizações e as atualizações de outros autores não entrarem em conflito, elas serão mescladas automaticamente e você não precisará fazer mais nada.
Ver versões anteriores de um arquivo de desenho
Você pode exibir versões anteriores de um arquivo de desenho do Visio. Também é possível substituir a versão atual de um arquivo de desenho por uma versão anterior.
Exibir uma versão anterior de um arquivo de desenho
- Selecione Informações do Arquivo>Exibir>Histórico de Versões.
A caixa de diálogo Versões salvas para ... é aberta. As versões salvas do arquivo são listadas, começando com a versão atual na parte superior.
- Selecione a versão do arquivo que você deseja ver.
- Escolha Abrir.
Uma exibição somente leitura dessa versão é aberta em uma nova janela do Visio.
- Selecione Fechar arquivo> quando terminar de revisar a versão anterior somente leitura do arquivo.
Restaurar uma versão anterior de um arquivo de desenho
- Selecione Informações do Arquivo>Exibir>Histórico de Versões.
A caixa de diálogo Versões salvas para ... é aberta. As versões salvas do arquivo são listadas, começando com a versão atual na parte superior.
- Selecione a versão do arquivo que você deseja tornar a versão atual.
- Selecione Restaurar.
Uma caixa de mensagem solicita que você confirme se deseja substituir a versão atual do arquivo pela versão anterior selecionada.
- Selecione OK para confirmar que você deseja fazer a alteração.
O arquivo de desenho aberto é atualizado para refletir a versão do arquivo que você escolheu para ser a nova versão atual.
O recurso de coautoria no Visio para a web permite editar simultaneamente um diagrama com outras pessoas. Se o seu diagrama estiver armazenado online no SharePoint ou no OneDrive corporativo ou de estudante, você poderá facilmente convidar outras pessoas para criar, editar, revisar o diagrama e adicionar comentários como parte de uma conversa encadeada.
Compartilhar um diagrama com outras pessoas que têm o SharePoint ou o OneDrive
É possível compartilhar um diagrama com outras pessoas enviando seu link por email.
Abra o diagrama no Visio para a Web.
Siga um destes procedimentos:
- Quando estiver visualizando o diagrama, selecione o comando Compartilhar
.
- Quando você estiver editando o diagrama, selecione Arquivo>Compartilhar>Compartilhar com People.
Na caixa de diálogo Compartilhar, selecione Enviar.
Compartilhe com outras pessoas que não têm o SharePoint ou o OneDrive
Você pode compartilhar um diagrama enviando um link. As People podem exibi-lo em qualquer navegador da Web, mesmo que não tenham o aplicativo da área de trabalho do Visio. As etapas a seguir exigem que um administrador habilite o compartilhamento externo para SharePoint no Microsoft 365.
Saiba mais.
Abra o diagrama no Visio para a Web.
Siga um destes procedimentos:
- Quando estiver visualizando o diagrama, selecione o comando Compartilhar
.
- Quando você estiver editando o diagrama, selecione Arquivo>Compartilhar>Compartilhar com People.
Na caixa de diálogo Compartilhar, selecione Copiar link.
Compartilhar um diagrama com outras pessoas no Microsoft Teams
Você pode compartilhar um diagrama com outras pessoas usando o Microsoft Teams.
Se o arquivo estiver disponível em um canal do Teams:
Vá para o canal do Teams e selecione o desenho do Visio que você deseja compartilhar.
Siga um destes procedimentos:
- Na faixa de opções, selecione Copiar link.
- Selecione a opção mais (...) ao lado do nome do arquivo e selecione Copiar link.
Na caixa de diálogo, defina as permissões e selecione Copiar.
Se você já tiver o link para o arquivo de um dos métodos acima, faça o seguinte:
- Envie o link para outras pessoas em um canal ou chat do Teams.
- Depois que o arquivo for enviado, o outro usuário que tentar abrir o arquivo poderá selecionar entre mais opções e escolher Editar no Teams também.
Coautoria de um desenho ao mesmo tempo
Qualquer pessoa com permissões de edição e uma licença do Visio para a Web pode trabalhar em coautoria em um arquivo compartilhado com ela.
- Abra o link do diagrama compartilhado com você.
- Selecione Editar Diagrama>Editar no navegador.
- Faça as alterações como faria normalmente, sem interrupção.
Ver onde as outras pessoas estão no documento
Os cocriadores atuais encontram-se listados junto ao friso da barra de ferramentas. Um indicador de presença permite-lhe ver onde é que outros coautores estão a trabalhar na tela. Por exemplo, quando um cocriador seleciona um objeto, verá um limite colorido na caixa delimitadora do objeto:
Quando um cocriador seleciona formas múltiplas ou descontínuas, verá um limite de presença em cada forma e um limite de seleção no grupo.
Pode fornecer comentários no diagrama tanto no modo de edição como no modo de visualização. É possível adicionar comentários a formas e à página inteira. Quando adiciona comentários a uma forma, estes mantêm-se na forma, mesmo que esta seja movida.
No modo de exibição:
Abra o diagrama para exibição.
Selecione Mostrar mais comandos (...) >Comentários.
O painel Comentários é exibido.
Adicione seus próprios comentários e veja os comentários de outras pessoas.
Utilize a opção Atualizar Dados para carregar comentários de outras pessoas.
No modo de edição:
Selecione a forma à qual pretende adicionar um comentário ou clique numa área em branco da página, para que nada seja selecionado para adicionar um comentário à página.
Execute um dos seguintes procedimentos para adicionar um comentário:
- No separador Rever , selecione Novo Comentário e adicione o seu comentário.
- No canto superior direito da página, selecione Comentários>Novo Comentário e adicione o seu comentário.
Também pode responder ou eliminar um comentário através destes dois botões:
Pode ver os comentários de outras pessoas na página ou na forma como aparecem.
Mensagens que poderá encontrar durante a cocriação
Quando edita um diagrama, a sua sessão excede o tempo limite após 10 minutos de inatividade para ajudar a minimizar a possibilidade de um conflito de edição. Pode continuar a editar ao selecionar Continuar a Trabalhar na barra de mensagens apresentada nesta situação:
Por vezes, ao cocriar, poderá descobrir que a sua última operação não foi concluída pelo Visio. Isto acontece quando o utilizador e o cocriador estão a tentar modificar o mesmo objeto de uma forma conflituosa. Pode continuar a trabalhar no mesmo diagrama mas tem de executar a última operação novamente. A mensagem pop-up desaparece automaticamente.
Numa sessão de cocriação em que os utilizadores têm preferências de idioma diferentes, o Visio só pode mostrar o texto da forma de um stencil específico num idioma. O Visio utiliza a preferência de idioma da pessoa na sessão que primeiro arrasta uma forma desse stencil para a tela.
Se outro utilizador já estiver a editar um desenho do Visio na aplicação de ambiente de trabalho e você tentar editá-lo no browser, o diagrama será bloqueado para edição e será apresentada uma caixa de mensagem. Nesses casos, você pode pedir ao usuário da área de trabalho para fechar o arquivo ou siga as instruções na caixa de mensagem.
- Para exibir o diagrama, selecione Abrir no modo de exibição de leitura.
- Para guardar uma cópia do diagrama novamente na biblioteca do SharePoint ou na pasta do OneDrive para trabalho ou escola, selecione Guardar uma cópia.
Todas as pessoas que vão trabalhar no diagrama têm de ter Visio Professional edição instalada no computador.
Configurar um diagrama para cocriação
- Crie um diagrama do Visio numa biblioteca do SharePoint ou inicie um diagrama no Visio e, em seguida, carregue-o para o OneDrive.
- Conceda permissão a todas as pessoas que vão trabalhar no ficheiro para editarem.
Cada autor abre o diagrama a partir do servidor no Visio e começa a criar, editar ou rever. Uma notificação no canto mostra quando alguém entra ou sai de uma sessão (o que basicamente significa que essa pessoa abre o diagrama para edição ou o fecha). Pode sempre ver na barra de status quantas pessoas estão a trabalhar no diagrama.
Como aparecem as alterações no diagrama
Os ícones pequenos aparecem por formas que foram editadas de alguma forma por outra pessoa. Não está bloqueado para sair de uma forma que tem um ícone que mostra que está a ser editado – por exemplo, mesmo que outra pessoa esteja a alterar a cor, pode editar o texto na forma ao mesmo tempo. Se todas as pessoas da equipa estiverem a colaborar e a trabalhar em áreas específicas, raramente deverá ter um problema em que duas pessoas editem exatamente a mesma coisa ao mesmo tempo, como alterar o texto na mesma forma. Se isso acontecer, a última alteração é a que permanece (até que alguém a altere novamente).
Sempre que guarda as alterações efetuadas ao diagrama, o Visio sincroniza-as com o servidor. Ao mesmo tempo, o Visio incorpora as alterações que todas as outras pessoas fizeram na sua cópia do diagrama. Pode saber quando alguém guardou as alterações no servidor através de ícones que são apresentados e de uma notificação na barra de status que o informa de que existem atualizações disponíveis. Guarde frequentemente para se certificar de que tem as alterações mais recentes feitas por outros autores e para disponibilizar as suas alterações aos mesmos.