Criar um novo banco de dados

Aplica-se a
Access para Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

Este artigo aborda o processo básico de inicialização do Access e criação de um banco de dados que será usado em computadores desktop, não na Web. Ele explica como criar um banco de dados da área de trabalho usando um modelo e como criar um banco de dados do zero criando suas próprias tabelas, formulários, relatórios e outros objetos de banco de dados. Ele também explica algumas técnicas que você pode usar para obter dados existentes em seu novo banco de dados.

Neste artigo

Visão Geral

Ao iniciar o Access pela primeira vez ou se fechar um banco de dados sem fechar o Access, o modo de exibição Backstage do MicrosoftOffice é exibido.

O modo de exibição Backstage é um ponto de partida a partir do qual você pode criar um novo banco de dados, abrir um banco de dados existente, exibir conteúdo em destaque do Office.com — qualquer coisa que você possa usar o Access para fazer em um arquivo de banco de dados ou fora de um banco de dados, em vez de dentro de um banco de dados.

Criando um banco de dados

Quando você abre o Access, o modo de exibição Backstage exibe a guia Novo . A guia Novo fornece várias maneiras de criar um novo banco de dados:

  • Um banco de dados em branco Você pode começar do zero, se quiser. Essa é uma boa opção se você tiver requisitos de design muito específicos ou tiver dados existentes que precise acomodar ou incorporar.
  • Um modelo instalado com o Access Considere usar um modelo se você estiver iniciando um novo projeto e quiser um avanço. O Access vem com vários modelos instalados por padrão.
  • Um modelo do Office.com Além dos modelos que vêm com o Access, você pode encontrar muitos outros modelos no Office.com. Você nem precisa abrir um navegador, os modelos estão disponíveis na guia Novo .

Adicionando a um banco de dados

Depois de trabalhar em um banco de dados, você pode adicionar campos, tabelas ou partes do aplicativo.

As partes do aplicativo são um recurso que permite usar vários objetos de banco de dados relacionados juntos como se fossem um. Por exemplo, uma parte do aplicativo pode consistir em uma tabela e um formulário baseados na tabela. Você pode adicionar a tabela e o formulário ao mesmo tempo usando a parte do aplicativo.

Você também pode criar consultas, formulários, relatórios, macros - todos os objetos de banco de dados com os quais você está acostumado a trabalhar.

Criar um banco de dados usando um modelo

O Access vem com uma variedade de modelos que você pode usar no estado em que se encontram ou como ponto de partida. Um modelo é um banco de dados pronto para uso que contém todas as tabelas, consultas, formulários, macros e relatórios necessários para executar uma tarefa específica. Por exemplo, existem modelos que você pode usar para rastrear problemas, gerenciar contatos ou manter um registro de despesas. Alguns modelos contêm alguns registros de exemplo para ajudar a demonstrar seu uso.

Se um desses modelos atender às suas necessidades, usá-lo geralmente será a maneira mais rápida de iniciar um banco de dados. No entanto, se você tiver dados em outro programa que deseja importar para o Access, talvez decida que é melhor criar um banco de dados sem usar um modelo. Os modelos têm uma estrutura de dados já definida e pode exigir muito trabalho para adaptar seus dados existentes à estrutura do modelo.

  1. Se você tiver um banco de dados aberto, na guia Arquivo , clique em Fechar. O modo de exibição Backstage exibe a guia Novo .
  2. Vários conjuntos de modelos estão disponíveis na guia Novo , alguns dos quais são integrados ao Access. Você pode baixar modelos adicionais do Office.com. Confira a próxima seção desse artigo para obter detalhes.
  3. Selecione o modelo que você deseja usar.
  4. O Access sugere um nome de arquivo para o banco de dados na caixa Nome do Arquivo — você pode alterar o nome do arquivo, se desejar. Para salvar o banco de dados em uma pasta diferente da exibida abaixo da caixa nome do arquivo, clique em , navegue até a pasta na qual deseja salvá-lo e clique em OK. Opcionalmente, você pode criar e vincular seu banco de dados a um site do SharePoint.
  5. Clique em Criar.
    O Access cria um banco de dados com base no modelo escolhido e abre o banco de dados. Para muitos modelos, é exibido um formulário no qual você pode começar a inserir dados. Se o seu modelo contiver dados de exemplo, você poderá excluir cada registro clicando no seletor de registro (a caixa sombreada ou barra à esquerda do registro) e fazendo o seguinte:
    Na guia Página Inicial, no grupo Registros, clique em Excluir.
  6. Para começar a inserir dados, clique na primeira célula vazia do formulário e comece a digitar. Use o Painel de Navegação para procurar outros formulários ou relatórios que talvez você queira usar. Alguns modelos incluem um formulário de navegação que permite a você mover-se entre os diferentes objetos do banco de dados.

Para obter mais informações sobre como trabalhar com modelos, consulte o artigo Usar um modelo para criar um banco de dados da área de trabalho do Access.

Início da Página

Criar um banco de dados sem usar um modelo

Se você não estiver interessado em usar um modelo, poderá criar um banco de dados criando suas próprias tabelas, formulários, relatórios e outros objetos de banco de dados. Na maioria dos casos, isso envolve um ou ambos os seguintes:

  • Inserir, colar ou importar dados para a tabela criada ao criar um novo banco de dados e, em seguida, repetir o processo com novas tabelas criadas usando o comando Tabela na guia Criar .
  • Importar dados de outras fontes e criar novas tabelas no processo.

Criar um banco de dados em branco

  1. Na guia Arquivo , clique em Novo e em Banco de Dados em Branco.
  2. Digite um nome de arquivo na caixa Nome do Arquivo . Para alterar o local do arquivo do padrão, clique em Procurar um local para colocar o banco de dados (ao lado da caixa Nome do Arquivo), navegue até o novo local e clique em OK.
  3. Clique em Criar.
    O Access cria o banco de dados com uma tabela vazia chamada Tabela1 e abre a Tabela1 no modo Folha de Dados. O cursor é colocado na primeira célula vazia na coluna Clique para Adicionar .
  4. Comece a digitar para adicionar dados ou cole dados de outra fonte, conforme descrito na seção Copiar dados de outra fonte para uma tabela do Access.

A inserção de dados no modo Folha de Dados foi projetada para ser muito semelhante a trabalhar em uma planilha do Excel. A estrutura da tabela é criada enquanto você insere dados. Quando você adiciona uma nova coluna à folha de dados, um novo campo é definido na tabela. O Access define automaticamente o tipo de dados de cada campo com base nos dados inseridos.

Se você não quiser inserir dados na Tabela1 neste momento, clique em Fechar . Se você tiver feito alterações na tabela, o Access solicitará que você salve as alterações. Clique em Sim para salvar suas alterações, clique em Não para descartá-las ou clique em Cancelar para deixar a tabela aberta.

Dica

O Access procura um arquivo chamado Blank.accdb na pasta localizada na [unidade de instalação]:\Program Files\MicrosoftOffice\Templates\1033\Access\. Se existir, Blank.accdb será o modelo para todos os novos bancos de dados em branco. Todo o conteúdo contido é herdado por todos os novos bancos de dados em branco. Essa é uma boa maneira de distribuir conteúdo padrão, como números de peça ou isenções de responsabilidade e políticas da empresa.

Importante

Se você fechar a Tabela1 sem salvá-la pelo menos uma vez, o Access excluirá a tabela inteira, mesmo que você tenha inserido dados nela.

Adicionar uma tabela

Você pode adicionar novas tabelas a um banco de dados existente usando os comandos no grupo Tabelas na guia Criar .

Imagem da faixa de opções do Access

Criar uma tabela começando no modo Folha de Dados No modo Folha de Dados, você pode inserir dados imediatamente e deixar que o Access crie a estrutura da tabela nos bastidores. Os nomes dos campos são atribuídos numericamente (Campo1, Campo2 e assim por diante), e o Access define automaticamente o tipo de dados de cada campo, com base nos dados inseridos.

  1. Na guia Criar, no grupo Tabelas, clique em Tabela.
    O Access cria a tabela e seleciona a primeira célula vazia na coluna Clique para Adicionar .
  2. Na guia Campos de Tabela , no grupo Adicionar & Excluir , clique no tipo de campo que você deseja adicionar. Se você não vir o tipo desejado, clique em Mais Campos .
  3. O Access exibe uma lista de tipos de campo comumente usados. Clique no tipo de campo desejado e o Access adicionará o novo campo à folha de dados no ponto de inserção.
    Para mover o campo, arraste-o. Quando você arrasta um campo em uma folha de dados, uma barra de inserção vertical aparece onde o campo será colocado.
  4. Para adicionar dados, comece a digitar na primeira célula vazia ou cole dados de outra fonte, conforme descrito na seção Copiar dados de outra fonte para uma tabela do Access.
  5. Para renomear uma coluna (campo), clique duas vezes no título da coluna e digite o novo nome.
    Você deve dar um nome significativo a cada campo, para que possa saber o que ele contém quando o vir no painel Lista de Campos .
  6. Para mover uma coluna, clique no cabeçalho para selecionar a coluna e arraste-a para o local desejado. Você também pode selecionar várias colunas contíguas e arrastá-las para um novo local de uma só vez. Para selecionar várias colunas contíguas, clique no cabeçalho da coluna da primeira coluna e, mantendo pressionada a tecla SHIFT, clique no cabeçalho da última coluna.

Criar uma tabela começando no modo Design No modo Design, primeiro você cria a estrutura da tabela. Em seguida, você alterna para o modo Folha de Dados para inserir dados ou inserir dados usando algum outro método, como colar ou importar.

  1. Na guia Criar, no grupo Tabelas, clique em Design de Tabela.

  2. Para cada campo da tabela, digite um nome na coluna Nome do Campo e selecione um tipo de dados na lista Tipo de Dados .

  3. Se desejar, você pode digitar uma descrição para cada campo na coluna Descrição . A descrição, então, é exibida na barra de status quando o cursor está localizado nesse campo no modo Folha de Dados. A descrição também é usada como o texto da barra de status para todos os controles em um formulário ou relatório que você cria arrastando o campo do painel Lista de Campos e para todos os controles criados para esse campo quando você usa o Assistente de Formulário ou o Assistente de Relatório.

  4. Depois de adicionar todos os campos, salve a tabela:

    • Na guia Arquivo, clique em Salvar.
  5. Você pode começar a digitar dados na tabela a qualquer momento alternando para o modo Folha de Dados e clicando na primeira célula vazia. Você também pode colar dados de outra fonte, conforme descrito na seção Copiar dados de outra fonte para uma tabela do Access.

Definir propriedades de campo no modo Design Independentemente de como você criou sua tabela, é uma boa ideia examinar e definir as propriedades do campo. Embora algumas propriedades estejam disponíveis no modo Folha de Dados, algumas propriedades só podem ser definidas no modo Design. Para alternar para o modo Design, clique com o botão direito do mouse na tabela no Painel de Navegação e depois clique em Modo Design. Para ver as propriedades de um campo, clique no campo na grade de design. As propriedades são exibidas abaixo da grade de design, em Propriedades do Campo.

Para ver a descrição de cada propriedade de campo, clique na propriedade e leia a descrição na caixa ao lado da lista de propriedades em Propriedades do Campo. Você pode obter informações mais detalhadas clicando no botão Ajuda.

A tabela a seguir descreve algumas das propriedades do campo que são comumente ajustadas.

Propriedade Descrição
Tamanho do Campo Para campos de Texto, essa propriedade define o número máximo de caracteres que podem ser armazenados no campo. O máximo é 255. Para campos Número, esta propriedade define o tipo de número que será armazenado (Inteiro Longo, Duplo e assim por diante). Para obter o armazenamento de dados mais eficiente, é recomendável alocar a menor quantidade de espaço que você acha que precisará para os dados. Você pode ajustar o valor para cima mais tarde, se suas necessidades mudarem.
Formatar Esta propriedade define como os dados são exibidos. Isso não afeta os dados reais, pois eles são armazenados no campo. Você pode selecionar um formato predefinido ou inserir um formato personalizado.
Máscara de Entrada Use esta propriedade para especificar um padrão para todos os dados que serão inseridos neste campo. Isso ajuda a garantir que todos os dados sejam inseridos corretamente e que contenham o número necessário de caracteres. Para obter ajuda sobre como criar uma máscara de entrada, clique no botão Construtor no lado direito da caixa de propriedade.
Valor Padrão Use esta propriedade para especificar o valor padrão que aparecerá nesse campo sempre que um novo registro for adicionado. Por exemplo, se você tiver um campo Data/Hora no qual sempre deseja registrar a data em que o registro foi adicionado, poderá inserir "Data()" (sem as aspas) como valor padrão.
Obrigatório Esta propriedade define se um valor é obrigatório neste campo. Se você definir essa propriedade como Sim, o Access não permitirá adicionar um novo registro, a menos que um valor seja inserido para esse campo.

Início da Página

Copiar dados de outra fonte para uma tabela do Access

Se os dados estiverem armazenados em outro programa, como o Excel, você poderá copiá-los e colá-los em uma tabela do Access. Em geral, isso funciona melhor se os dados já estiverem separados em colunas, como estão em uma planilha do Excel. Se os dados estiverem em um programa de processamento de texto, é melhor separar as colunas de dados usando guias ou converter os dados em uma tabela no programa de processamento de texto antes de copiá-los. Se seus dados precisarem de alguma edição ou manipulação (por exemplo, separar nomes completos em nomes e sobrenomes), convém fazer isso antes de copiar os dados, especialmente se você não estiver familiarizado com o Access.

Quando você cola dados em uma tabela vazia, o Access define o tipo de dados de cada campo de acordo com o tipo de dados encontrados lá. Por exemplo, se um campo colado não contiver nada além de valores de data, o Access aplicará o tipo de dados Data/Hora a esse campo. Se o campo colado contiver apenas as palavras "sim" e "não", o Access aplicará o tipo de dados Sim/Não ao campo.

O Access nomeia os campos de acordo com o que encontra na primeira linha de dados colados. Se a primeira linha de dados colados for semelhante em tipo às linhas seguintes, o Access determinará que a primeira linha faz parte dos dados e atribuirá nomes genéricos aos campos (F1, F2 etc.). Se a primeira linha de dados colados não for semelhante às linhas seguintes, o Access determinará que a primeira linha consiste em nomes de campo. O Access nomeia os campos de acordo e não inclui a primeira linha nos dados.

Se o Access atribuir nomes de campos genéricos, você deverá renomear os campos assim que possível para evitar confusão. Use o seguinte procedimento:

  1. Pressione CTRL+S para salvar a tabela.
  2. No modo Folha de Dados, clique duas vezes em cada título de coluna e digite um nome de campo descritivo para cada coluna.
  3. Salve a tabela novamente.

Observação

Você também pode renomear os campos alternando para o modo Design e editando os nomes dos campos lá. Para alternar para o modo Design, clique com o botão direito do mouse na tabela no Painel de Navegação e clique em Modo Design. Para voltar ao modo Folha de Dados, clique duas vezes na tabela no Painel de Navegação.

Início da Página

Você pode ter dados armazenados em outro programa e deseja importar esses dados para uma nova tabela ou acrescentá-los a uma tabela existente no Access. Ou você pode trabalhar com pessoas que mantêm seus dados em outros programas e deseja trabalhar com eles no Access vinculando-os a eles. De qualquer forma, o Access facilita o trabalho com dados de outras fontes. Você pode importar dados de uma planilha do Excel, de uma tabela em outro banco de dados do Access, de uma lista do SharePoint ou de uma variedade de outras fontes. O processo usado é um pouco diferente, dependendo da sua origem, mas o procedimento a seguir o ajudará a começar.

  1. No Access, na guia Dados Externos , no grupo Importar & Vincular , selecione Nova Fonte de Dados e, em seguida, selecione o comando para o tipo de arquivo que você está importando.
    Por exemplo, se você estiver importando dados de uma planilha do Excel, clique em Nova Fonte>de Dados do Arquivo>do Excel.

    Observação

    Se você não conseguir encontrar o tipo de formato correto no grupo Importar & Vincular , talvez seja necessário iniciar o programa no qual você criou originalmente os dados e, em seguida, usar esse programa para salvar os dados em um formato de arquivo comum (como um arquivo de texto delimitado) antes de importar esses dados para o Access.

  2. Na caixa de diálogo Obter Dados Externos , clique em Procurar para localizar o arquivo de dados de origem ou digite o caminho completo do arquivo de dados de origem na caixa Nome do arquivo .

  3. Clique na opção desejada (todos os programas permitem importar e alguns permitem anexar ou vincular) em Especifique como e onde deseja armazenar os dados no banco de dados atual. Você pode criar uma nova tabela que use os dados importados ou (com alguns programas) você pode anexar os dados a uma tabela existente ou criar uma tabela vinculada que mantenha um vínculo com os dados no programa de origem.

  4. Se um assistente for iniciado, siga as instruções nas próximas páginas do assistente. Na última página do assistente, clique em Concluir.
    Se você importar objetos ou vincular tabelas de um banco de dados, a caixa de diálogo Importar Objetos ou Vincular Tabelas será exibida. Escolha os itens desejados e clique em OK.
    O processo exato depende se você optar por importar, acrescentar ou vincular dados.

  5. O Access pergunta se você deseja salvar os detalhes da operação de importação que acabou de concluir. Se você acha que executará essa mesma operação de importação novamente no futuro, clique em Salvar etapas de importação e insira os detalhes. Em seguida, você pode repetir facilmente a operação no futuro clicando em Importações Salvas no grupo Importar & Link na guia Dados Externos . Se você não quiser salvar os detalhes da operação, clique em Fechar.

Se você optar por importar uma tabela, o Access importará os dados para uma nova tabela e exibirá a tabela no grupo Tabelas no Painel de Navegação. Se você optar por acrescentar dados a uma tabela existente, os dados serão adicionados a essa tabela. Se você optar por vincular aos dados, o Access criará uma tabela vinculada no grupo Tabelas do Painel de Navegação.

Início da Página

Adicionar uma parte do aplicativo

Você pode usar uma parte do aplicativo para adicionar funcionalidade a um banco de dados existente. Uma parte do aplicativo pode ser tão simples quanto uma única tabela ou pode incluir vários objetos relacionados, como uma tabela e um formulário associado.

Por exemplo, a parte do aplicativo Comentários consiste em uma tabela com um campo ID de Numeração Automática, um campo de data e um campo de memorando. Você pode adicioná-lo a qualquer banco de dados e usá-lo no estado em que se encontra ou com personalização mínima.

  1. Abra o banco de dados ao qual você deseja adicionar uma parte do aplicativo.
  2. Clique na guia Criar .
  3. No grupo Modelos , clique em Partes do Aplicativo. Uma lista de peças disponíveis é aberta.
  4. Clique na parte do aplicativo que você deseja adicionar.

Início da Página

Abrir um banco de dados do Access existente

  1. Na guia Arquivo, clique em Abrir.

  2. Na caixa de diálogo Abrir , navegue até o banco de dados que deseja abrir.

  3. Siga um destes procedimentos:

    • Clique duas vezes no banco de dados para abri-lo no modo padrão especificado na caixa de diálogo Opções do Access ou no modo definido por uma política administrativa.
    • Clique em Abrir para abrir o banco de dados para acesso compartilhado em um ambiente multiusuário para que você e outros usuários possam ler e gravar no banco de dados.
    • Clique na seta ao lado do botão Abrir e clique em Abrir Somente Leitura para abrir o banco de dados para acesso somente leitura, de modo que você possa exibi-lo, mas não editá-lo. Outros usuários ainda podem ler e gravar no banco de dados.
    • Clique na seta ao lado do botão Abrir e clique em Abrir Exclusivo para abrir o banco de dados usando o acesso exclusivo. Quando você tem um banco de dados aberto com acesso exclusivo, qualquer outra pessoa que tentar abrir o banco de dados receberá uma mensagem "arquivo já em uso".
    • Clique na seta ao lado do botão Abrir e, em seguida, clique em Abrir Somente Leitura Exclusivo para abrir o banco de dados para acesso somente leitura. Outros usuários ainda podem abrir o banco de dados, mas estão limitados ao modo somente leitura.

Observação

Você pode abrir diretamente um arquivo de dados em um formato de arquivo externo, como dBASE, MicrosoftExchange ou Excel. Você também pode abrir diretamente qualquer fonte de dados ODBC, como o MicrosoftSQL Server. O Access cria automaticamente um novo banco de dados do Access na mesma pasta que o arquivo de dados e adiciona links a cada tabela no banco de dados externo.

Dicas

  • Para abrir um dos bancos de dados abertos mais recentemente, na guia Arquivo , clique em Recentes e, em seguida, clique no nome do arquivo desse banco de dados. O Access abre o banco de dados usando as mesmas configurações de opção da última vez que você o abriu. Se a lista de arquivos usados recentemente não for exibida, na guia Arquivo , clique em Opções. Na caixa de diálogo Opções do Access , clique em Configurações do Cliente. Em Exibição, insira o número de documentos a serem exibidos na lista Documentos recentes, até no máximo 50.
    Você também pode mostrar bancos de dados recentes na barra de navegação do modo de exibição Backstage, para acesso com dois cliques: 1) a guia Arquivo , 2) o banco de dados recente que você deseja abrir. Perto da parte inferior da guia Recente, marque a caixa de marcar Acesso rápido a este número de bancos de dados recentes e ajuste o número de bancos de dados a serem exibidos.
  • Se você estiver abrindo um banco de dados clicando no comando Abrir na guia Arquivo , poderá exibir uma lista de atalhos para bancos de dados que você abriu anteriormente clicando em Meus Documentos Recentes na caixa de diálogo Abrir .

Início da Página