Criar um gráfico de caixa

Aplica-se a
Excel 2013

Se você estiver fazendo uma análise estatística, talvez queira criar um gráfico de caixa padrão para mostrar a distribuição de um conjunto de dados. Em um gráfico de caixa, os dados numéricos são divididos em quartis e uma caixa é desenhada entre o primeiro e o terceiro quartis, com uma linha adicional desenhada ao longo do segundo quartil para marcar o mediano. Em alguns gráficos de caixa, os mínimos e máximos fora do primeiro e terceiro quartis são representados com linhas, que geralmente são chamadas de bigodes.

As diferentes partes de um gráfico de caixa Embora o Excel 2013 não tenha um modelo de gráfico para gráfico de caixa, você pode criar gráficos de caixa executando as seguintes etapas:

  1. Calcule os valores quartis do conjunto de dados de origem.
  2. Calcular diferenças de quartis.
  3. Crie um tipo de gráfico de colunas empilhadas a partir dos intervalos de quartis.
  4. Converta o gráfico de colunas empilhadas para o estilo de gráfico de caixa.

Em nosso exemplo, o conjunto de dados de origem contém três colunas. Cada coluna tem 30 entradas dos seguintes intervalos:

  • Coluna 1 (2013): 100–200
  • Coluna 2 (2014): 120–200
  • Coluna 3 (2015): 100–180

Tabela de dados de origem Neste artigo

Etapa 1: Calcular os valores de quartil

Primeiro, você precisa calcular os valores mínimo, máximo e mediano, bem como o primeiro e o terceiro quartis, a partir do conjunto de dados.

  1. Para fazer isso, crie uma segunda tabela e preencha-a com as seguintes fórmulas:

    Valor Fórmula
    Valor mínimo MÍN(intervalo de células)
    Primeiro quartil QUARTIL. INC (intervalo de células, 1)
    Valor mediano QUARTIL. INC (intervalo de células, 2)
    Terceiro quartil QUARTIL. INC (intervalo de células, 3)
    Valor máximo MÁXIMO(intervalo de células)
  2. Como resultado, você deve obter uma tabela contendo os valores corretos. Os seguintes quartis são calculados a partir do conjunto de dados de exemplo:

    A tabela final e os valores

Início da Página

Etapa 2: Calcular diferenças de quartis

Em seguida, calcule as diferenças entre cada fase. Com efeito, você deve calcular os diferenciais entre o seguinte:

  • Primeiro quartil e valor mínimo
  • Mediana e primeiro quartil
  • Terceiro quartil e mediana
  • Valor máximo e terceiro quartil
  1. Para começar, crie uma terceira tabela e copie os valores mínimos da última tabela diretamente para lá.
  2. Calcule as diferenças de quartil com a fórmula de subtração do Excel (célula1 – célula2) e preencha a terceira tabela com os diferenciais.

Para o conjunto de dados de exemplo, a terceira tabela tem a seguinte aparência:

Início da Página

Etapa 3: Criar um gráfico de colunas empilhadas

Os dados na terceira tabela são adequados para um gráfico de caixa, e começaremos criando um gráfico de colunas empilhadas que modificaremos em seguida.

  1. Selecione todos os dados da terceira tabela e clique em Inserir>Inserir Coluna Gráfico>de Colunas Empilhada Coluna.

    Comece selecionando Coluna Empilhada.

    A princípio, o gráfico ainda não se parece com um gráfico de caixa, pois o Excel desenha colunas empilhadas por padrão de conjuntos de dados horizontais e não verticais.

    O gráfico padrão com colunas empilhadas

  2. Para inverter os eixos do gráfico, clique com o botão direito do mouse no gráfico e clique em Selecionar Dados.

  3. Clique em Alternar Linha/Coluna.

    Dica

    • Para renomear as colunas, no lado de rótulos do eixo Horizontal (Categoria), clique em Editar, selecione o intervalo de células na terceira tabela com os nomes de categoria desejados e clique em OK. Selecione o intervalo de células que deseja renomear.
    • Para renomear suas entradas de legenda, no lado Entradas de Legenda (Série), clique em Editar e digite a entrada desejada.
  4. Clique em OK.

O gráfico agora deve se parecer com o mostrado abaixo. Neste exemplo, o título do gráfico também foi editado e a legenda fica oculta neste ponto.

É assim que seu gráfico deve ser agora. Início da Página

Etapa 4: Converter o gráfico de colunas empilhadas para o estilo de gráfico de caixa

Ocultar a série de dados inferior

Para converter o gráfico de colunas empilhadas em um gráfico de caixa, comece ocultando a série de dados inferior:

  1. Selecione a parte inferior das colunas.

    Observação

    Quando você clica em uma única coluna, todas as instâncias da mesma série são selecionadas.

  2. Clique em Formatar>Seleção Atual Formatar>Seleção. O painel Formatar é aberto à direita.

    A opção Formatar Seleção está na guia Formatar.

  3. Na guia Preenchimento , no painel Formal , selecione Sem preenchimento.
    As séries de dados inferiores ficam ocultas no gráfico.

    Os dados inferiores estão ocultos neste gráfico.

Criar bigodes para o gráfico de caixa

O próximo passo é substituir as séries de dados mais altas e secundárias (as áreas azul e laranja profundas na imagem) por linhas ou bigodes.

  1. Selecione a série de dados superior.

  2. Na guia Preenchimento , no painel Formal , selecione Sem preenchimento.

  3. Na faixa de opções, clique em Design>Adicionar Elemento de Gráfico>Barras de> Erro Standard Desvio.

    Os menus Adicionar elemento de gráfico e Barras de erro.

  4. Clique em uma das barras de erro desenhadas.

  5. Abra a guia Opções da Barra de Erros , no painel Formato , e defina o seguinte:

    • Defina a direção como sinal de subtração.

    • Defina o estilo finalcomo sem maiúscula.

    • Para Valor do erro, defina Porcentagem como 100.

      Para o Valor do Erro, a porcentagem deverá ser 100%.

  6. Repita as etapas anteriores para a segunda série de dados da parte inferior.
    O gráfico de colunas empilhadas agora deve começar a se parecer com um gráfico de caixa.

    O gráfico final agora tem bigodes.

Pintar as áreas do meio

Os gráficos de caixa geralmente são desenhados em uma cor de preenchimento, com uma pequena borda de contorno. As etapas a seguir descrevem como concluir o layout.

  1. Selecione a área superior do seu gráfico de caixa.

  2. Na guia Preenchimento & Linha no painel Formatar , clique em Preenchimento sólido.

  3. Selecione uma cor de preenchimento.

  4. Clique em Linha Sólida na mesma guia.

  5. Selecione uma cor de contorno e uma largura de traçado.

  6. Defina os mesmos valores para outras áreas do gráfico de caixa.
    O resultado final deve ser semelhante a um gráfico de caixa.

    Os seus gráficos de caixa devem ter esta aparência.

Início da Página

Confira também

Tipos de gráficos disponíveis no Office

Gráficos e outras visualizações no Power View